Zero-byte report inside zip file returned from API

67 views
Skip to first unread message

dkasak

unread,
Dec 1, 2008, 11:51:11 PM12/1/08
to AdWords API Forum
Hi all.

I posted this question ... somewhere else ... but I can't find where
now, so maybe I posted it in the wrong place? Anyway ...

I've been asked to look at an issue where some reports that we
download contain no information. The compressed file itself is valid
( ie not corrupted ), but when we unpack it, the report file inside is
0 bytes. ( Example report ID: 582000854 )

Does anyone know why we're ( intermittently ) getting these 0-byte
reports?

AdWords API Advisor

unread,
Dec 2, 2008, 11:31:12 AM12/2/08
to AdWords API Forum
Hello Daniel,

In addition to being exposed via the AdWords API, all the reports you
schedule should also be available via the http://adwords.google.com/
web interface, in the Report Center of the account in question (this
may be the Report Center of the MCC account or of the actual AdWords
account, depending on how to scheduled it).

Assuming you haven't scheduled 15 other reports since then and bumped
the report you mention out of the queue in the Report Center, what
happens when you take a look at the report via the web interface? Do
you see a properly populated report, or is it empty there as well?

Cheers,
-Jeff Posnick, AdWords API Team

pedro

unread,
Dec 3, 2008, 3:57:18 PM12/3/08
to AdWords API Forum
Jeff

I have been experiencing this too. I thought initially it was my
server running out of space but now that someone else is getting this
behaviour I am more suspicious. I will investigate my situation more
and report back.

Peter Doyle

On Dec 2, 4:31 pm, AdWords API Advisor <adwordsapiadvi...@google.com>
wrote:
> Hello Daniel,
>
>  In addition to being exposed via the AdWords API, all the reports you
> schedule should also be available via thehttp://adwords.google.com/

Pete Lavetsky (AdWords API Guru)

unread,
Dec 3, 2008, 4:17:54 PM12/3/08
to AdWords API Forum
Might be an issue if you're waiting too long to download the report.

http://code.google.com/apis/adwords/docs/developer/ReportService.html

"When your report job is complete, use getReportDownloadUrl to
retrieve the URL where your report is stored. The returned URL is
valid for five minutes. If the URL expires, just call
getReportDownloadUrl again. Keep this URL private, since anyone can
use it to access your report."

I've seen both 404s for the URLs and also empty data reports but I had
always assumed we waited too long to download the report. I'd be
interested to see if the empty report can be more definitely nailed
down to a different cause.

Pete

AdWords API Advisor

unread,
Dec 3, 2008, 5:02:23 PM12/3/08
to AdWords API Forum
I'd definitely like to get to the bottom of the situation, so again,
if anyone is seeing this behavior, the most useful thing you could
check on is whether the report is also empty in the Report Center of
the AdWords web interface. That information, along with the reportId
and ideally some sort of way of identifying your getReportDownloadUrl
() request (either a log or the returned URL or the requestId SOAP
response header) would be great.

Cheers,
-Jeff Posnick, AdWords API Team


On Dec 3, 4:17 pm, "Pete Lavetsky (AdWords API Guru)"

Pete Lavetsky (AdWords API Guru)

unread,
Dec 4, 2008, 10:15:48 AM12/4/08
to AdWords API Forum
Jeff,

Here is a job that just happened that was empty when we downloaded it,
but *not* empty in the MCC Report Center: 539587199

I don't have the URL that was given to us by the report service, but
if that information is imperative, I can add in logging.

Pete

On Dec 3, 5:02 pm, AdWords API Advisor <adwordsapiadvi...@google.com>

AdWords API Advisor

unread,
Dec 4, 2008, 11:40:03 AM12/4/08
to AdWords API Forum
Hello Pete,

I'm not able to find a report with that id currently active in the
Report Center.

I'll ping you off-thread to get some more details that might help
track this down.

Cheers,
-Jeff Posnick, AdWords API Team


On Dec 4, 10:15 am, "Pete Lavetsky (AdWords API Guru)"

dkasak

unread,
Dec 4, 2008, 6:46:02 PM12/4/08
to AdWords API Forum
HI Jeff. Here's another one for you.

URL: https://adwords.google.com/api/adwords/ReportDownload?t=AAAAACOvQ1YAAAEeA0ykEQEAAAACC5-26QMEfNNzBwREY2ZdPse-m-pr5a3E

ReportID: 598688598

And a bit of our log:

1204-133949 S Google.pm/412 Creative Report version: Google API v12
1204-133950 S Base.pm/1404 Creating Service ReportService
1204-133950 S Base.pm/1620 Checking the report status for report
598688598
1204-133950 S Base.pm/1624 Waiting 10 seconds..
1204-134000 S Base.pm/1630 Current status for report 598688598 is
Completed
1204-134000 S Base.pm/1634 Success: finished report(598688598)
1204-134000 S Base.pm/1545 Doing a file download from URL
1204-134019 S Base.pm/1716 Download URL
https://adwords.google.com/api/adwords/ReportDownload?t=AAAAACOvQ1YAAAEeA0ykEQEAAAACC5-26QMEfNNzBwREY2ZdPse-m-pr5a3E
to file /tmp/IgFStFB0HF/BdJGnNUukf.zip successful!
1204-134019 E se_download.pl/53 ERROR IN SE Download for:
--------------------------------------------------------------------------------
ERROR =
no element found at line 1, column 0, byte 0:
D
^
at /usr/local/lib/perl5/site_perl/5.8.3/i686-linux/XML/Parser.pm line
187

As you can see, we only waited 10 seconds until checking that the
report was complete, and it was at this point ( we got a url ) so we
downloaded it. It again was a valid zip file, but when unpacked the
report was a zero-byte file.

I logged into the web ui and found the report id, and when I clicked
on it, I got a single row of zeros. What is the behaviour in this
case? Should we expect a report structure, but with no data? Or does
the report structure only get output upon the 1st row of data?

Thanks.

Dan

On Dec 4, 9:02 am, AdWords API Advisor <adwordsapiadvi...@google.com>

AdWords API Advisor

unread,
Dec 5, 2008, 1:25:45 PM12/5/08
to AdWords API Forum
Okay, after following up with Pete a bit off-thread, I think I have
enough information to file an issue with the core engineering team.

Basically, the behavior he was seeing is that he'd call
getReportDownloadUrl() for a recently-completed report job id, get a
URL back, and then upon downloading the URL find that there was no
content. I asked Pete to try calling getReportDownloadUrl() a second
time for the same report job id, and upon downloading that new URL the
report content was there. Additionally, the report is properly
accessible via the web interface's Report Center (ignore my previous
message about not being able to find it there).

This is obviously going to be a bit more difficult to debug than if,
for example, there was something about a given report job id that
caused it to always lead to a download URL that pointed to nothing,
but we'll see what we can do. It actually sounds like it may have some
similarities to another open issue described at

http://groups.google.com/group/adwords-api/browse_thread/thread/c08c632b8d7d83f8#

I'll post updates with any information I get back from the core
engineering team. In the meantime, apologies for the inconvenience,
and putting in logic to call getReportDownloadUrl() again and get a
new URL when you encounter this failure seems to be a workaround.

Cheers,
-Jeff Posnick, AdWords API Team


On Dec 4, 6:46 pm, dkasak <daniel.ka...@247realmedia.com> wrote:
> HI Jeff. Here's another one for you.
>
> URL:https://adwords.google.com/api/adwords/ReportDownload?t=AAAAACOvQ1YAA...
>
> ReportID: 598688598
>
> And a bit of our log:
>
> 1204-133949 S Google.pm/412 Creative Report version:  Google API v12
> 1204-133950 S Base.pm/1404 Creating Service ReportService
> 1204-133950 S Base.pm/1620 Checking the report status for report
> 598688598
> 1204-133950 S Base.pm/1624 Waiting 10 seconds..
> 1204-134000 S Base.pm/1630 Current status for report 598688598 is
> Completed
> 1204-134000 S Base.pm/1634 Success: finished report(598688598)
> 1204-134000 S Base.pm/1545 Doing a file download from URL
> 1204-134019 S Base.pm/1716 Download URLhttps://adwords.google.com/api/adwords/ReportDownload?t=AAAAACOvQ1YAA...

dkasak

unread,
Jan 5, 2009, 5:32:02 PM1/5/09
to AdWords API Forum
Any word on a solution for this? I'm wondering whether I should bother
adding 'try again' logic as per Jeff Posnick's suggestion, or whether
the issue will be resolved sooner than I can get the fix into a
release.

AdWords API Advisor

unread,
Jan 5, 2009, 5:39:50 PM1/5/09
to AdWords API Forum
Hello Dan,

This was just brought up again at

http://groups.google.com/group/adwords-api/browse_thread/thread/3729f0b4a10e131d#

and as mentioned there, there are unfortunately no breakthroughs when
it comes to tracking down the root cause.

Cheers,
-Jeff Posnick, AdWords API Team


pedro

unread,
Jan 7, 2009, 4:35:01 AM1/7/09
to AdWords API Forum
Jeff

FYI
I am still getting this behaviour and await further news.

Peter


On Jan 5, 10:39 pm, AdWords API Advisor <adwordsapiadvi...@google.com>
wrote:
> Hello Dan,
>
>  This was just brought up again at
>
>  http://groups.google.com/group/adwords-api/browse_thread/thread/3729f...

tozor

unread,
Jan 8, 2009, 10:41:23 AM1/8/09
to AdWords API Forum
I have also been experiencing this error. I had two occurrences in
the reports I ran this morning. Initially I simply implemented a 5
second delay between the time the report status switched to completed
and the time I accessed the URL. I will implement the retry discussed
here.

Tim
Reply all
Reply to author
Forward
0 new messages