Reader 9.0 AcroRd32.exe caused Microsoft Visual C++ Runtime Library error

1341 views
Skip to first unread message

Andrew...@adobeforums.com

unread,
Jul 11, 2008, 8:56:14 AM7/11/08
to
A client has updated Adobe Reader 8.1 to 9.0 on several machines and now cannot use Adobe Reader.

The program start, the Adobe Reader window appears but no document and then an error message is displayed that says;

"Microsoft Visual C++ Runtime Library
Program: C:\Program Files\Adobe\Reader 9.0\Reader\AcroRd32.exe
This application has requested the runtime to terminate in an unusual
way.
Please contact the applications support team for mor information."

Adobe Reader has been removed, the computer restarted and then re-installed from a full installation package and the problem persists.

Does anyone have any ideas how to fix this?

Jim_V...@adobeforums.com

unread,
Jul 11, 2008, 4:40:03 PM7/11/08
to
Is this in an Active Directory environment with folder redirection?

Acrobat does not like "Application Data" to be in a UNC path (ie. \\server\share\username\Application Data)

Nathan_Pr...@adobeforums.com

unread,
Jul 12, 2008, 9:21:38 PM7/12/08
to
I have the same problem.

I am in an Active Directory environment with folder redirection. Is there a work around or fix?

Jim...@adobeforums.com

unread,
Jul 13, 2008, 4:29:01 AM7/13/08
to
This is the same or similar to the message I got. I have roaming Vista profiles and folder redirection on a Server 2003 domain. Administrator (non-roaming) has no problem. Roaming non-admins get message like (or same) as you get. How does your set-up compare with mine? I reverted to Adobe 8 -

Another irritation - I installed Adobe 8 from a thumb drive & whenever I update it wants the same thumb-drive letter in place. I have learned NOT to install from thumb drives. I am even leary of installing from a network location - in case I re-organize folders

Nathan_Pr...@adobeforums.com

unread,
Jul 13, 2008, 7:10:52 PM7/13/08
to
My workstations are XP but they are roaming with folder redirection on a Server 2003 domain. Local accounts work fine but the accounts with folder redirection get that error.

I still haven't found a solution. I reverted back to Adobe 8 until a fix is found.

Jim...@adobeforums.com

unread,
Jul 13, 2008, 8:27:19 PM7/13/08
to
I see you have roaming profiles too.
I have to check, but I think my user with folder redirection but not roaming was OK

Nathan_Pr...@adobeforums.com

unread,
Jul 13, 2008, 9:48:21 PM7/13/08
to
I think it has something to do with Adobe 9 not liking the path for "Application Data" being on the server instead of a local path.

Sami_S._A...@adobeforums.com

unread,
Jul 15, 2008, 6:13:31 AM7/15/08
to
I wish I had read this earlier, just rolled the update on 30computers yesterday and now when people tried to open pdfs the fun begun. Quite nice undocumented feature :/ -> rolling back to 8.1

C...@adobeforums.com

unread,
Jul 16, 2008, 10:18:16 AM7/16/08
to
Hey All,

Same problem here, seems to be directly related to folder redirection....

Tried filing this as a bug, but they don't allow more than 2000 characters.... my trace files are way bigger than that.... I'm going to file a bug and link them to this thread as I'm going to put some of my trace info in here.

This has been tested on multiple machines, with multiple users. It does not occur for users without folder re-direction.

In our tests, XP doesn't have the problem with Roaming Profiles, but Vista and folder redirections does.

Steps to re-produce (Vista):

Set the following policy settings (GPMC/Local Sec Policy) with adjustments for server, etc.

User Configuration (Enabled)hide
Policieshide
Windows Settingshide
Folder Redirectionhide
AppData(Roaming)hide
Setting: Advanced (Specify locations for various user groups)hide
Group Path
my_group_here \\server\users\dept\%USERNAME%\AppData\Roaming

Optionshide
Grant user exclusive rights to AppData(Roaming) Disabled
Move the contents of AppData(Roaming) to the new location Disabled
Also apply redirection policy to Windows 2000, Windows 2000 server, Windows XP, and Windows Server 2003 operating systems Disabled
Policy Removal Behavior Leave contents

2) Install Acrobat Reader 9.

3) Launch without admin priviliges

When debugging with ProcessMon (Sysinternals) on Vista SP1 x64 I see it calls \device\mup and then a createfile at the root of C:\ which fails with access denied (as it should in vista), and then the program calls the Windows Error Reporting.

This is lines 9378 to lines 9406 in the processmon trace, sanitized.

342417 01:10.7 AcroRd32.exe 460 CloseFile \\server\users\dept\username\AppData\Roaming\Adobe\Acrobat\9.0 SUCCESS
342419 01:10.7 AcroRd32.exe 460 SetEAFile C:\Windows\CSC\v2.0.6\namespace\server\users\dept\username\AppData\Roaming\Adobe\Acrobat\9.0 SUCCESS
342420 01:10.7 AcroRd32.exe 460 ReadFile C:\Windows\CSC\v2.0.6\pq SUCCESS Offset: 269,632, Length: 208
342421 01:10.7 AcroRd32.exe 460 WriteFile C:\Windows\CSC\v2.0.6\pq SUCCESS Offset: 269,632, Length: 208
342422 01:10.7 AcroRd32.exe 460 CloseFile C:\Windows\CSC\v2.0.6\namespace\server\users\dept\username\AppData\Roaming\Adobe\Acrobat\9.0 SUCCESS
342424 01:10.7 AcroRd32.exe 460 CloseFile C:\Windows\CSC\v2.0.6\namespace\server\users\dept\username\AppData\Roaming\Adobe\Acrobat\9.0 SUCCESS
342426 01:10.7 AcroRd32.exe 460 CreateFile C:\ SUCCESS Access: Read Data/List Directory, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a
342427 01:10.7 AcroRd32.exe 460 CloseFile C:\ SUCCESS
342429 01:10.7 AcroRd32.exe 460 CreateFile \Device\Mup\ NAME INVALID Access: Read Data/List Directory, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a
342430 01:10.7 AcroRd32.exe 460 CreateFile C:\ SUCCESS Access: Read Data/List Directory, Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a
342431 01:10.7 AcroRd32.exe 460 CloseFile C:\ SUCCESS
342433 01:10.7 AcroRd32.exe 460 CreateFile C:\ ACCESS DENIED Access: Read Data/List Directory, Synchronize, Disposition: Create, Options: Directory, Synchronous IO Non-Alert, Open Reparse Point, Attributes: N, ShareMode: Read, Write, AllocationSize: 0
342434 01:10.7 AcroRd32.exe 460 RegOpenKey HKU\S-1-5-21-1669273076-1836279104-1734353810-3328\Software\Adobe\Adobe Acrobat\9.0 SUCCESS Desired Access: Read
342435 01:10.7 AcroRd32.exe 460 RegQueryValue HKU\S-1-5-21-1669273076-1836279104-1734353810-3328\Software\Adobe\Adobe Acrobat\9.0\Crashlog NAME NOT FOUND Length: 144
342436 01:10.7 AcroRd32.exe 460 RegCloseKey HKU\S-1-5-21-1669273076-1836279104-1734353810-3328\Software\Adobe\Adobe Acrobat\9.0 SUCCESS
342437 01:10.7 AcroRd32.exe 460 QueryNameInformationFile C:\Program Files (x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe SUCCESS Name: \Program Files (x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe
342438 01:10.7 AcroRd32.exe 460 RegOpenKey HKLM\Software\Wow6432Node\Microsoft\Windows\Windows Error Reporting\Escalation NAME NOT FOUND Desired Access: Read
342448 01:10.7 AcroRd32.exe 460 QueryOpen C:\Program Files (x86)\Adobe\Reader 9.0\Reader\imageres.dll FAST IO DISALLOWED
342449 01:10.7 AcroRd32.exe 460 CreateFile C:\Program Files (x86)\Adobe\Reader 9.0\Reader\imageres.dll NAME NOT FOUND Access: Read Attributes, Disposition: Open, Options: Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a
342454 01:10.7 AcroRd32.exe 460 QueryOpen C:\Windows\SysWOW64\imageres.dll FAST IO DISALLOWED
342455 01:10.7 AcroRd32.exe 460 CreateFile C:\Windows\SysWOW64\imageres.dll SUCCESS Access: Read Attributes, Disposition: Open, Options: Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a
342457 01:10.7 AcroRd32.exe 460 QueryBasicInformationFile C:\Windows\SysWOW64\imageres.dll SUCCESS CreationTime: 11/2/2006 6:16:57 AM, LastAccessTime: 11/2/2006 7:03:20 AM, LastWriteTime: 11/2/2006 3:39:37 AM, ChangeTime: 11/17/2006 11:11:23 AM, FileAttributes: A
342459 01:10.7 AcroRd32.exe 460 CloseFile C:\Windows\SysWOW64\imageres.dll SUCCESS
342464 01:10.7 AcroRd32.exe 460 CreateFile C:\Windows\SysWOW64\imageres.dll SUCCESS Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Delete, AllocationSize: n/a
342466 01:10.7 AcroRd32.exe 460 QueryStandardInformationFile C:\Windows\SysWOW64\imageres.dll SUCCESS AllocationSize: 15,822,848, EndOfFile: 15,821,312, NumberOfLinks: 2, DeletePending: False, Directory: False
342470 01:10.7 AcroRd32.exe 460 CloseFile C:\Windows\SysWOW64\imageres.dll SUCCESS
342472 01:10.7 AcroRd32.exe 460 CreateFile C:\Windows\SysWOW64\en-US\imageres.dll.mui SUCCESS Access: Generic Read, Disposition: Open, Options: , Attributes: n/a, ShareMode: Read, Delete, AllocationSize: n/a
342474 01:10.7 AcroRd32.exe 460 QueryStandardInformationFile C:\Windows\SysWOW64\en-US\imageres.dll.mui SUCCESS AllocationSize: 12,288, EndOfFile: 12,288, NumberOfLinks: 2, DeletePending: False, Directory: False
345240 01:12.0 AcroRd32.exe 460 Thread Exit SUCCESS User Time: 0.0156001, Kernel Time: 0.0156001

James_Sc...@adobeforums.com

unread,
Jul 18, 2008, 8:52:58 AM7/18/08
to
I'm seeing the same problem with the full version of Adobe Acrobat 9.0 Professional, in what seems to be the same setup. We've just bought a site licence for Acrobat so at least I should be able to kick up a fuss with support, unlike anyone using Reader...

The exact error messages I'm getting are:

Microsoft Visual C++ Debug Library

Runtime Error!

Program: C:\Program Files\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe

The application has requested the Runtime to terminate it in an usual
way. Please contact the application's support team for more information.


and when viewing PDF files in Internet Explorer:

Microsoft Visual C++ Debug Library

Debug Error!

Program: C:\Program Files\Internet Explorer\iexplore.exe

abnormal program termination

(Press Retry to debug the application)


My Domain Admin account is not affected, even when I assigned it a roaming profile temporarily. I tried adding an affected user to the local Administrators group and this had no effect - the user still experienced crashes. I'm pretty sure it's to do with the AppData redirection, which my Domain Admin doesn't use but the affected user does.

The same user logging onto one of our laptops (which are set to always use local profiles and AppData even for domain users) does NOT experience crashes.

I've managed to generate a crash dump for this and from reading through the stack trace it appears the problem stems from the PDFLTerm() function in AdobePDFL.dll

ntdll!KiFastSystemCallRet ntdll!ZwWaitForMultipleObjects+0xc kernel32!WaitForMultipleObjectsEx+0x11d
kernel32!WaitForMultipleObjects+0x18 kernel32!WerpReportFaultInternal+0x16d
kernel32!WerpReportFault+0x70 kernel32!UnhandledExceptionFilter+0x1b5
msvcr80!abort+0xeb msvcr80!terminate+0x4d WARNING: Stack unwind information
not available. Following frames may be wrong. Acrobat+0x422e ntdll!__RtlUserThreadStart+0x6f
ntdll!_EH4_CallFilterFunc+0x12 ntdll!_except_handler4+0x8e ntdll!ExecuteHandler2+0x26
ntdll!ExecuteHandler+0x24 ntdll!KiUserExceptionDispatcher+0xf kernel32!RaiseException+0x58
msvcr80!_CxxThrowException+0x46 Acrobat_69630000!DllCanUnloadNow+0x68e27
Acrobat_69630000!PDFLTerm+0x645ce Acrobat_69630000!DllCanUnloadNow+0x663df
msvcr80!_NLG_Return


I too have run a ProcMon trace, this time on Vista Enterprise x64, and got similar output to CH! above, though in my case Acrobat issued a CreateFile on the root of the DFS share hosting the redirected AppData, with CreationDisposition set to CREATE_ALWAYS; in other words, trying to overwrite the share... Unsurprisingly this resulted in a NAME COLLISION since it already exists, and a call to WER immediately followed: and can't be overwritten.

98959 11:29:15.6155113 Acrobat.exe 972 CreateFile \Device\Mup\ NAME INVALID Desired


Access: Read Data/List Directory, Synchronize, Disposition: Open, Options:
Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read,

Write, Delete, AllocationSize: n/a 99021 11:29:15.6181294 Acrobat.exe 972 CreateFile \\mydomain\users\ SUCCESS Desired


Access: Read Data/List Directory, Synchronize, Disposition: Open, Options:
Directory, Synchronous IO Non-Alert, Attributes: n/a, ShareMode: Read,

Write, Delete, AllocationSize: n/a, OpenResult: Opened 99100 11:29:15.6219431 Acrobat.exe 972 QueryStandardInformationFile \\mydomain\users\ SUCCESS AllocationSize:
0, EndOfFile: 0, NumberOfLinks: 1, DeletePending: False, Directory: True
99111 11:29:15.6222464 Acrobat.exe 972 CloseFile \\mydomain\users\ SUCCESS
99182 11:29:15.6254897 Acrobat.exe 972 CreateFile \\mydomain\users\ NAME
COLLISION Desired Access: Read Data/List Directory, Synchronize, Disposition:


Create, Options: Directory, Synchronous IO Non-Alert, Open Reparse Point,

Attributes: N, ShareMode: Read, Write, AllocationSize: 0 99187 11:29:15.6257927 Acrobat.exe 972 RegOpenKey HKU\S-1-5-21-1708537768-2052111302-682003330-4640\Software\Adobe\Adobe
Acrobat\9.0 SUCCESS Desired Access: Read 99189 11:29:15.6258324 Acrobat.exe 972 RegQueryValue HKU\S-1-5-21-1708537768-2052111302-682003330-4640\Software\Adobe\Adobe
Acrobat\9.0\Crashlog NAME NOT FOUND Length: 144 99191 11:29:15.6258536 Acrobat.exe 972 RegCloseKey HKU\S-1-5-21-1708537768-2052111302-682003330-4640\Software\Adobe\Adobe
Acrobat\9.0 SUCCESS 99192 11:29:15.6259012 Acrobat.exe 972 QueryNameInformationFile C:\Program
Files (x86)\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe SUCCESS Name: \Program
Files (x86)\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe 99193 11:29:15.6260191 Acrobat.exe 972 RegOpenKey HKLM\Software\Wow6432Node\Microsoft\Windows\Windows

James_Sc...@adobeforums.com

unread,
Jul 18, 2008, 9:55:36 AM7/18/08
to
Well, I just got off the phone with Adobe UK Support where I have logged a case for this issue.

The agent told me that this is a known issue that he was notified of yesterday (17 July). He confirmed it is an issue with the AdobePDFL.dll and is specific to environments using Active Directory.

There is not yet an ETA for a fix.

He was not able to confirm that it is definitely linked to AppData redirection but it seems pretty clear that is what's causing it from the reports here.

C...@adobeforums.com

unread,
Jul 18, 2008, 12:59:15 PM7/18/08
to
Thanks for calling James, I'm still waiting on my VL media of pro 9 to arrive from the states to test, so that I'd have a "supported" edition, that they support to call in.

I went back through my trace, and I do see the same thing as you do creating the file at the root of the share, I didn't put too much pass on it originally because it was a success.

Ar...@adobeforums.com

unread,
Aug 1, 2008, 3:21:53 AM8/1/08
to
Hi
Any updates on this yet?

Pen...@adobeforums.com

unread,
Aug 1, 2008, 2:48:52 PM8/1/08
to
Nice post designingpatrick! Thanks for letting us know a workaround. We just rolled everyone back to 8.1.2 and it works fine with roaming profiles in vista as they are setup.

When Reader 9.1 comes around we will drop it in the test lab and see what is next.

Be safe and Be well,
Penrath

C...@adobeforums.com

unread,
Aug 1, 2008, 5:34:25 PM8/1/08
to
Classy... I'm with you there James.

I'm not rolling out Acrobat9 to those on folder redirection. While it is nice to have a work around, the better solution is to have a fix.

James_Sc...@adobeforums.com

unread,
Aug 1, 2008, 5:04:46 PM8/1/08
to
Adobe emailed me yesterday suggesting I change the registry keys, still not realising that the settings were Group Policy controlled, and therefore if I wanted to change the AppData folder I would have done so already.

I'd considered mapping a drive letter as designingpatrick suggested, but I don't consider changing Group Policy for 1500 users just to accommodate Adobe's buggy code a particularly appealing solution, so have decided to hold off the roll-out until Adobe fix it. I told Adobe the same and asked for an ETA on a proper fix, and can you believe that this is what I got in response?

We are not able to give you any date about this issue but the engineers
are working on it and this issue will probablty (sic) be solved with updates
of Acrobat 9.

I will close your Case


Close my case?! You can imagine the prompt and firm reply that elicited. I run a helpdesk. We don't close cases until they are actually fixed. This has never seemed like a bad approach to me. Your thoughts?

Pen...@adobeforums.com

unread,
Aug 1, 2008, 5:32:39 PM8/1/08
to
James,

I am in the same boat you are. My network users have a very strict permissions on the accounts...and I have a LOT of them. They can't even do their own updates for adobe..it's all handled through GP. I am not going to muck around with registry settings and so on for over 2000 user accounts in several OUs

The simple answer is to continue to use 8.1.2 or use something provided by open office or Foxit (just to name a few).

It really all boils down to what the users are doing with Adobe reader and what you can...and can not... put up with.

It comes as no surprise that an odd numbered release would be buggy anyway... right? **grin**

Be safe and Be well!
Penrath

designin...@adobeforums.com

unread,
Aug 1, 2008, 2:11:19 PM8/1/08
to
'Acrobat 9 doesn't like UNC-Paths(path beginning with \\) as AppData path.

Just change the following AppData registry entries to non-UNC paths and acrobat starts up correctly

[HKCR\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]

[HKCR\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]

to setup the profile path in the usersettings pane in the Active Directory user and computer mmc to connect the profile path with a drive letter instead of the UNC-Profile path.

So instead of \\server\profile\%USERNAME% we use U:\profile\%USERNAME%.

You can also setup the users to local profiles, than the path would be a default path like c:\Documents and Settings\%USERNAME%\AppData. '

<http://www.adobeforums.com/webx/.59b5d982>
"Acrobat 9 (reader and pro) do not play well with Redirected Folders in an Active Directory environment. More specifically... a redirected "Application Data" folder.

Any of my users which do NOT have roaming profiles (aka redirected folders) have no problems running acrobat 9. In other words, users who have their "Application Data" folder in "C:\Documents and Settings\username\Application Data" are fully functional and do not receive the C++ Runtime error. "

"==== THIS IS WITH ROAMING PROFILE CRASHES! ====

Adobe's program iterates the network path from left to right, skipping the first word: \\Server\Folder1\Folder2\Folder3\APPLICATION DATA as it searches a user's profile for the APPLICATION DATA folder.

So starting at FOLDER1 it checks to see if it can "create" a folder. It doesnt do it, but it tries to check its access. If your not in the users profile at this point, the program MOST LIKELY cannot because its a directory NOT owned by the user. THe previous folders is something you wouldn't give NORMAL users access to.

After the program FAILS to "create" its folder because it cannot -
The program Crashes:
*R6025 - Pure Virtual function call
* The exception unknown software exception (0x40000015) occurred in the application at location 0x2e80f5e3
* C++ runtime error
* WINDOWS NAME Collision error.
=== ITS ALL OF THESE! Same error, different points in the crashing ===

Solution?
I create a network drive DIRECTLY to the profile, then I update the registery to make that the WINDOWS APPDATA path. ALL of this is done on the user logon scripts. So it was just "solved" one day, except for a new drive letter appearing.

(Added to login script)
net use l: \\SERVER\USER PROFILE TREE\USER PROFILE
REG ADD "HKEY_CURRENT_USER\software\Microsoft\windows\CurrentVersion\Explorer\User Shell Folders" /v AppData /t REG_EXPAND_SZ /d "l:\Application Data" /f

For our work we use: \\SERVER\USER PROFILE TREE\%USERNAME%\%COMPUTERNAME% - so each user has SEPERATE data per computer they are on. "

Bernd_Le...@adobeforums.com

unread,
Aug 6, 2008, 7:54:08 AM8/6/08
to
Hello!

Does anybody know if there is some fix available somewhere at
adobe.com or at least a date they do think they will release
one?
Knowing that Adobe Software in Version x.0 tends to be buggy,
we waited until today to roll out Adobe Reader 9.0. We've even
checked right before if there is a newer (german) version
available on ftp.adobe.com.
Installing it as an administrator (without roaming profiles
etc.) we did not stumble upon this error. But now our users
did ...

By the way: We have had rather similar problems (but as far
as I remember not with that particular error message) with
other Adobe products (v 8 / CS3) with folder-redirections
and roaming profiles.

Bernd Leutenecker

James_Sc...@adobeforums.com

unread,
Aug 6, 2008, 8:14:18 AM8/6/08
to
This is what I heard from Adobe Support yesterday:

I will keep the case open and give you further notice when there is a
solution provided.


So, there is no fix at present, only the workaround provided above. For what it's worth, we use v.8.1.2 with Roaming Profiles and redirected Application Data without any problems, so sorry to hear you've had trouble with that too.

Steve...@adobeforums.com

unread,
Aug 7, 2008, 3:09:12 PM8/7/08
to
Here's how we solved this annoying problem:

0. You probably should start off by being logged in with your Domain Admin account.

1. Create a folder off the root of your C: drive. My username is skobb, so I created C:\skobb

2. Click on Run and type REGEDIT

3. Follow this path:
HKCURRENTUSER > Software > Microsoft > Windows > Explorer > Shell Folders

4. Create a backup of your registry by exporting and saving the file to some other part of your file structure. You can always go back to this by double-clicking on the file name

5. In the right-hand pane of the registry editor, find all paths with UNC references and change them to the local folder that you created in Step 1.

So, for example, I changed...
\\houfile1\skobb$
to
C:\skobb

6. Make the same sort of changes in another folder on this same path called "User Shell Folders".

That's all there is to it. Fire up Acrobat 9 and it will behave itself.

It did for me, anyway.

Good luck to all frustrated citizens of AcroWorld, wherever you may be.

Steve

C...@adobeforums.com

unread,
Aug 7, 2008, 4:27:11 PM8/7/08
to
Steve,

The easier way to do that, is to just disable folder re-direction from group policy. Your way will just get overwritten based on group policy anyway.

BTW, in the reg path, you missed current version.

Steve...@adobeforums.com

unread,
Aug 7, 2008, 4:39:51 PM8/7/08
to
Good points, CH! Thanks.

Mathew...@adobeforums.com

unread,
Aug 8, 2008, 12:13:35 PM8/8/08
to
The UNC path problem with programs is nothing new.... Flash, now Adobe flash, has exactly the same issue as the new version of Reader. Which would leave me to believe that Adobe might not care about it or isn't planning to fix either product. I had been told that flash would be fixed almost a year ago by a software company (Scholastic) that uses flash to create the learning software for kids that we use. I've yet to see any new versions that allow for Active Directory "App Data" folder redirection.

James_Sc...@adobeforums.com

unread,
Aug 8, 2008, 12:28:11 PM8/8/08
to
That's curious. We have Adobe Flash Player 9.0.124.0 deployed to almost every computer in our organisation, and none of our users have experienced any problems (including those that have AppData redirection). What symptoms are you seeing?

C...@adobeforums.com

unread,
Aug 8, 2008, 12:39:56 PM8/8/08
to
#$%^

is this flash, or flash player?

Our flash player isn't having the issue... but we have a few CS users and were planning on upgrading them soon.

Mathew...@adobeforums.com

unread,
Aug 8, 2008, 1:39:01 PM8/8/08
to
It is flash runtime... It's not that flash doesn't work, but if the software developer needs to have flash store setting for users, such as a server to connect to, the settings need to be saved in the users app data folder. But if you've redirected the app data the setting won't save as it is a UNC path and the user will have to re-imput the settings. I just tested this about a month ago and it was still not working. To get around this I have the users login as a generic AD user that has a non-redirected app data folder. Or I'll setup the specific shortcut to the application to do a "run as" and have the user us an account with out a redirected app data folder.

Derek_...@adobeforums.com

unread,
Aug 17, 2008, 2:56:44 PM8/17/08
to
FYI if you change your shell folder registry settings, you'll break vista. There's some documentation on this if you read MSDN about vista's folder virtualization.

Also, if you use the login script solution to map the drive, you'll lose your other apps user data, because they all understand UNC paths and will be looking in the original locations. So in my opinion, that's not a proper work around.

My company is simply going to NOT upgrade to 9. Perhaps when Adobe realizes the ramifications of thousands of unsold copies of Acrobat 9 this will outweigh the development costs associated with updating their code to support UNC.

Barry_...@adobeforums.com

unread,
Aug 22, 2008, 9:59:31 PM8/22/08
to
I am receiving this error message and was wondering if there is any solution to this problem yet?

Robert...@adobeforums.com

unread,
Sep 23, 2008, 1:31:04 PM9/23/08
to
It looks like this is a big snag for Citrix and RDP Terminal Servers as well.
<http://www.adobeforums.com/webx/.59b5f923?@@>

Mar...@adobeforums.com

unread,
Sep 26, 2008, 2:01:07 PM9/26/08
to
Why Doesn't adobe do anything about this?
I can't believe that Support is so... not supportive on this incident.
We spent about 45 minutes trying to figure out if there was a way to customize this in adobe customization wizard.

I would think that there should be a way to customize it in the registry..
like change the path of the application data folder?
or maybe statically map it always or somthing.

Has any one had any better response from support on this issue?

James_Sc...@adobeforums.com

unread,
Sep 26, 2008, 3:19:50 PM9/26/08
to
I've had my support case for this open for more than 2 months now. I emailed them last week asking for an update.

More than a week later, they haven't even bothered replying.

Martin...@adobeforums.com

unread,
Oct 9, 2008, 10:28:10 AM10/9/08
to
Has Adobe coming up with a scheduled date for a fix?

One of our customers stopped the rollout of Reader 9 and therefor stopped the complete Adobe Forms Project.
The described "workaround" is not accepted by our customer.

Regards

Martin

Ethan_...@adobeforums.com

unread,
Oct 9, 2008, 3:58:11 PM10/9/08
to
This fix does not work when you redirect the Application Data directory with Group Policy. The folder redirection happens as part of the logon processor before the script processes... You simply do not use a drive letter with this option in group policy - and you can't change it (to the same location) later as it resets back to the GP applied UNC path immediately.

In other words - Adobe needs to fix this, these work around solutions are not acceptable, nor functional in many situations.

My fix is to go back to Acrobat Pro 8.0, and copy the Objects, Templates and Samples directories from '%ProgramFiles%\Adobe\Acrobat 8.0\Designer 8.0\EN' to '%APPDATA%\Adobe\Designer\8.0\EN' for the user with %APPDATA% redirected to a UNC path... Which gets the LiveCycle Designer 8.0 to run with out the same basic error.

Edit: I've cross-posted this in a few of the threads so far... There should be a way for the 15 or so active threads on this to be brought together...

Scott_...@adobeforums.com

unread,
Oct 10, 2008, 5:09:26 PM10/10/08
to
I am wondering if there is a way to get adobe to use the application data in the all users profile stored on the local machine instead of the app data in the redirected folder. I have in the mean time decided to not redirect the app data folder. I am still able to redirect all other folders. This will require a little more time for users to log in, however it should not be too bad (I hope). If adobe would just use the AppData folder in the all users profile, then they would not need to worry about UNC paths, all though I don't know why a company today would not support UNC's.

If anyone has any ideas about how to make this work or if it would work, please let me know.

Ron...@adobeforums.com

unread,
Oct 13, 2008, 6:36:17 AM10/13/08
to
To change the AD GPO to use drive letter in folder redirection instead of UNC path is not possible, as it reverts to \\ unc path in the GPO...

So here is another company that is waiting for the fix for reader 9.0

Pascal_va...@adobeforums.com

unread,
Oct 14, 2008, 3:40:50 AM10/14/08
to
Hi all
After I finished the workarround with changing the APPDATA path to a hidden network drive, Adobe Acrobat 9 is now working.

BUT now when I would like to create an new link on the desktop, he don't refresh. I have to klick on F5 to refresh. Does anybody has the same or a simular problem?

its_p...@adobeforums.com

unread,
Oct 20, 2008, 5:50:10 AM10/20/08
to
I have created some Special GPO that links the Appdatafolder to %userprofile%\Appdata and applied the GPO only to the Users of Acroread/Acrobat. I'm very unhappy with this solution/wordaround, but it is working.

Still waiting for a Hotfix.

Robin_...@adobeforums.com

unread,
Oct 20, 2008, 5:04:57 PM10/20/08
to
Hello

I am very dissapointed to discover that in Adobe CS4 the acrobat reader bug still exists.

The only solution is to either map the share to a drive letter and modify the registry so the profile is directed there (as above) but I have found that this causes serious problems with other programs and can cause profiles to not be loaded properly due to the drive not getting mapped in time.

I then created a more elaborate shortcut script which would modify the profile path and then open the program and modify it back but this also caused problems with other programs.

This problem has occured ever since Acrobat Reader Pro/Standard were released. It is surprising how difficult it is for Adobe to create an application for viewing pdfs which does not instantly crash when you open it.
Surely a major bug like this should not take many months to fix and when you have to remorgage your house to buy the CS4 Master Collection I feel you should at least be able to view pdfs without getting "This application has requested the Runtime to terminate in an unusual way. Please contact the application's support team for more information". So can you give me more information and/or possibly fix this sometime?

My only real solution which was also the same in CS3 is to avoid installing the Acrobat program and use Foxit Reader or to install Acrobat 8 which does not suffer from this problem/or 6 Pro to edit pdfs which I still have a licence for.

Thanks
Robin

michaelkazlow

unread,
Oct 20, 2008, 7:59:45 PM10/20/08
to
Robin,

It naive to think that Acrobat and/or Reader would be changed with the
release of CS4 if it was not fixed before it was released. The version
in CS 4 includes the same version of Acrobat as was included in CS 3.3
and the technical suite interim update as well. When/If it is fixed it
will be distributed via the update mechanism for all running versions of
Acrobat and Reader 9.

Mike

Ron...@adobeforums.com

unread,
Oct 21, 2008, 2:21:42 AM10/21/08
to
To downgrade to acro reader 8 and install Foxit for those that get ver. 9 pdf documents is our best solution, and more and more people are liking foxit ... so we are contemplating to just start to use foxit for all our pdf needs since Adobe is not willing to fix this... Too bad really, they must be driving alot of customers away...

Robin_...@adobeforums.com

unread,
Oct 21, 2008, 2:48:01 AM10/21/08
to
It's just when it costs so much money you would think a major bug like this would be A, discovered by beta testers before the 9 release or B, fixed by now as it has been many months and when every other application was updated in CS4 I would have at least expected a ver 9.000001 that would just fix this very annoying bug as apart from this the program is quite good.

As I understand it, Acrobat looks at the root of the UNC share and then tries to create a folder which alredy exisits consisting of the name of the user. There is no error handling in the code so the program just crashes. The error seems to be in one dll file.

I had to give people log on locally rights just to use this program and this makes the machines less secure as it is harder to apply security.

James_Sc...@adobeforums.com

unread,
Oct 21, 2008, 1:37:35 PM10/21/08
to
I called Adobe again today to enquire on the status of my support case for this. It was raised 3 months ago on Saturday.

After 20 minutes on hold, here's how the conversation went after I gave him the case number:

"Oh, this is an old case."

- "Yup"

"Uh, it seems to have been closed for some reason."

- "OK, that's interesting as I specifically agreed with the last guy it would not be closed until a fix was available."

"... the person who closed it does not work here any more."

GREAT.

I then spent the next 10 minutes explaining to this poor guy (who was clearly not near the support level dealing with this kind of problem) why the workarounds that had been previously suggested were completely unsuitable for enterprise implementation. He admitted all he could do is pass that feedback back up as he had no further information. He said he would get back to me ASAP.

I'll keep you posted.

Mar...@adobeforums.com

unread,
Oct 21, 2008, 2:23:11 PM10/21/08
to
Thank you James,
My case on the issue was closed in a similar way and the work around is not working for us either.

James_Sc...@adobeforums.com

unread,
Oct 22, 2008, 1:23:49 PM10/22/08
to
I received an update earlier today:

There is no solution yet.

The issue will be fixed by the next Acrobat update. Please make sure your
auto updater is active and/or check the Adobe website for updates.

That's all I was given. I have enquired as to if there is an expected timeframe for said update.

James_Sc...@adobeforums.com

unread,
Oct 23, 2008, 8:36:10 AM10/23/08
to
Well, we have our answer.

"We don't know when the next update will be released.

I am very sorry for the inconveniance."

(sic)

I love being an Adobe customer.

Mar...@adobeforums.com

unread,
Oct 23, 2008, 10:30:39 AM10/23/08
to
Awesome?

Robin_...@adobeforums.com

unread,
Oct 25, 2008, 6:20:03 AM10/25/08
to
Oh well maybe it will be fixed in a few years.

Aless...@adobeforums.com

unread,
Oct 27, 2008, 2:45:52 PM10/27/08
to
It's incredible. Such a fatal bug in a final version... I wonder which kind of testing they have at Adobe...
I'm a "free version" Reader user, I haven't paid for Acrobat Reader so I cannot complain that much.. but I imagine how pleased should be Pro version users...
In this forum, I discovered the existence of Foxit. I've just installed it, I think this is definitely the best "fix" at the moment...

Mar...@adobeforums.com

unread,
Oct 27, 2008, 3:16:55 PM10/27/08
to
"In this forum, I discovered the existence of Foxit. I've just installed it, I think this is definitely the best "fix" at the moment..."

For the reader this is true, but acrobat pro still has the problem..

DDave_...@adobeforums.com

unread,
Oct 30, 2008, 11:15:32 PM10/30/08
to
You have been heard! In case your support rep hasn't contacted you, this bug "Crash on launch if domain user APPDATA folder has been redirected." has been fixed. It will go out in the first patch to 9.0.

Ethan_...@adobeforums.com

unread,
Oct 30, 2008, 11:23:08 PM10/30/08
to
When?!?!

James_Sc...@adobeforums.com

unread,
Oct 31, 2008, 4:10:57 AM10/31/08
to
That's the only question that matters, isn't it? (Along with "is it really fixed", I suppose).

Mar...@adobeforums.com

unread,
Oct 31, 2008, 8:54:09 AM10/31/08
to
And this aforementioned patch... its due to hit the stores... When?
and is it called "version 10"?

john_g...@adobeforums.com

unread,
Nov 11, 2008, 10:48:09 AM11/11/08
to
November 11th and the current download of reader V9 from Adobe is still unfixed.

How hard can it be, really?

Hurrah for Foxit.

John Galloway
University of York, UK

Scott_B...@adobeforums.com

unread,
Nov 11, 2008, 11:09:04 AM11/11/08
to
I gave up waiting... I have migrated the office to Foxit Reader... We just need to be able to view documents. I can not undertand why Adobe has not fixed this issue as I am sure there are many roaming profile user sites out there that would like to use Reader 9.0

Robin_...@adobeforums.com

unread,
Nov 11, 2008, 1:15:10 PM11/11/08
to
Yes give us the source code as I'm sure quite a few of us could fix it in our lunch breaks!

It was broken in CS3, CS3.3 and now CS4. Acrobat seems the only program that remains un-updated in CS releases and the one that most needed updating.

michaelkazlow

unread,
Nov 11, 2008, 11:04:20 PM11/11/08
to
As users with roaming profiles, it is a very important issue to you.
However, in the scheme of things, it may not be very important to the
overall user base. If this is a problem for your company, have everyone
in your company report the bug in the Adobe Bug report form. The more
users they know are effected, the more likely it will be fixed. Believe
me if IBM, ATT or the DOD had the problem, it would be fixed ASAP. Your
company needs to help make it an important issue to Adobe.


Mike

James_Sc...@adobeforums.com

unread,
Nov 19, 2008, 4:31:41 AM11/19/08
to
Adobe sent me an invite to their annual Adobe Customer Engagement Survey.

You had better believe I made my feelings on this known.

mema...@adobeforums.com

unread,
Dec 3, 2008, 8:04:14 PM12/3/08
to
For our 2008 terminal server my workaround was to disable browser integration. (So instead PDF's open in a separate window, which is actually wise if your running a terminal server, because when browser integration is enabled, each instance of adobe reader stays open until the browser is closed)

Anyway to achieve this I got a copy of the msi and reinstalled Adobe Reader 9 with the following MSI switch

msiexec.exe /i AcroRead.msi /qn DISABLE_BROWSER_INTEGRATION=YES

buffa...@adobeforums.com

unread,
Dec 10, 2008, 10:40:08 AM12/10/08
to
Well, I downloaded the latest version today (12/10/08) from the web site, and still having the same issue. We are using Folder Redirection, but only for My Documents and Application Data. Approx. 1800 users will be affected if we roll this out through the company.

Mar...@adobeforums.com

unread,
Dec 10, 2008, 11:04:47 AM12/10/08
to
msiexec.exe /i AcroRead.msi /qn DISABLE_BROWSER_INTEGRATION=YES

Disableing the browser integration does not resolve the issue of application data directory redirection.

Hunter...@adobeforums.com

unread,
Dec 17, 2008, 11:26:50 AM12/17/08
to
What a joke. We got burned by this today and the latest downloader does not have any fix that I am aware of. This is horrible Adobe, horrible.

Ethan_...@adobeforums.com

unread,
Dec 17, 2008, 1:29:32 PM12/17/08
to
I guess the question is... Will Acrobat 8 be the last Adobe version we will ever be able to use? And if so... What are your plans to support users once other websites start publishing documents that are incompatible with Acrobat 8?

Al...@adobeforums.com

unread,
Dec 21, 2008, 8:31:59 AM12/21/08
to
Same here - ADOBE WE NEED A FIX! - ADOBE ACROBAT 8 WORKED!!!
Grrrr - this post was started in July and it is now Dec!

jm...@adobeforums.com

unread,
Dec 23, 2008, 6:08:42 AM12/23/08
to
I have the same problem but with Photoshop CS4

"Microsoft Visual C++ Runtime Library
Program: C:\Program Files\Adobe\Adobe Photoshop CS4\Photoshop.exe
This application has requested the runtime to terminate in an unusual
way.
Please contact the applications support team for mor information."
It was working, i could open photoshop at least one time, after that,always the same error. CS3 worked well.
Is there any cure for this ?
Thanks

Mar...@adobeforums.com

unread,
Dec 23, 2008, 11:15:24 AM12/23/08
to
I wonder how hard it would be to get on the phone with developers?

C...@adobeforums.com

unread,
Dec 23, 2008, 11:33:01 AM12/23/08