Error = InvalidFileAccess - Adobe Prof V9 Distiller

165 views
Skip to first unread message

Selena...@adobeforums.com

unread,
Mar 22, 2009, 10:58:11 PM3/22/09
to
Hi,

I am testing an evaluation copy of Pro V9 running on XP Prof / windows 2007. The postscript file I am trying to run through distiller has been created in PReS.

I have no problems distilling the same file through distiller 4 and distiller 8 but it will not distill in V9 so I think my postscript files are fine and something is not functioning the same in distiller as per previous versions.

Please see error below:

%%[ Error: invalidfileaccess; OffendingCommand: file ]%%

Stack:
(w)
(PRES-SPECSAVERS_V1-2009323-135355-0.PS)

%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
%%[ Warning: PostScript error. No PDF file produced. ] %%

I have seen some discussion regarding a restriction on directory access beginning with Acrobat 8.1. Distiller restricts the directories that Postscript file operators can access. The new default behaviour limits directory access to the temp and font cache directories. Earlier versions of distiller allowed postscript file operators to have unlimited directory access.

I have seen a suggestion to allow unlimited access in Microsoft windows using -F command line.

Unfortunately I don't know what this means and I cannot find any further information on the subject.

I have noticed that very small postscript files distill fine i.e 300kb but 600kb and over bring up the error as above.

Can anybody help?

Thanks.

Selena...@adobeforums.com

unread,
Mar 22, 2009, 11:40:01 PM3/22/09
to
Another note: I have noticed that files without graphics distill fine? Those with graphics come up with the error?

Selena...@adobeforums.com

unread,
Mar 22, 2009, 11:38:53 PM3/22/09
to
Also note: I have tried suggestion of adding -F to target in shortcut and in folder options also distilling from temp directory none of these options worked.

Selena...@adobeforums.com

unread,
Mar 23, 2009, 4:24:01 PM3/23/09
to
FYI: I have found a solution to this problem.

When using PReS it is not a requirement to code the graphic file name extension when calling the graphic in a script (This is only if it is an eps or one of the other graphics listed within the PReS user guide)

In this case I am using eps. I decided to add the extension in the coding to see if it made a difference and it did. File is now distilling.

I don't understand why though as it is not required in previous versions and nor is it required for printing direct from the PReS script.

If there is anyone that can enlighten me it would be appreciated.

Thanks.

Reply all
Reply to author
Forward
0 new messages