Re: Acrobat Pro 9 crashes when opened on network accounts

481 views
Skip to first unread message

Joe_St...@adobeforums.com

unread,
Sep 18, 2008, 8:44:49 PM9/18/08
to
We are having the same problem with Reader 9 on our 10.4.11 macs. Local users have no problem, but network users all experience a stall that requires a force-quit. It's disheartening to see that you have no responses after 15 days.

We recently downloaded a parking permit from one of our local community colleges and normally we would just use the preview app, but this document requires reader 9. So much for PDF being a standard any more.

simon.f...@gmail.com

unread,
Sep 21, 2008, 4:01:15 AM9/21/08
to
On Sep 18, 5:44 pm, Joe_Styme...@adobeforums.com wrote:
> We are having the same problem with Reader 9 on our 10.4.11 macs. Local users have no problem, but network users all experience a stall that requires a force-quit. It's disheartening to see that you have no responses after 15 days.
>
> We recently downloaded a parking permit from one of our local community colleges and normally we would just use the preview app, but this document requires reader 9. So much for PDF being a standard any more.

We are having the same issue - and I have done the standard suite of
troubleshooting - repaired disk permissions, deleted all pref files,
disables modules (like the update module) to no avail. Oh well - back
to version 8.0...

Andrea...@adobeforums.com

unread,
Sep 22, 2008, 4:43:51 AM9/22/08
to
Hello, we also have the same Problem and there seems to be no solution.
So i started a call at Adobe.

But at the free technical support they cannot help me with this.
I should use this user to user forum.

Thanks Adobe for testing your software!

try67

unread,
Sep 22, 2008, 12:56:56 PM9/22/08
to
Do you mean that you're trying to open the application itself over a network, or is the application installed locally and the files are opened over a network?

Joe_St...@adobeforums.com

unread,
Sep 22, 2008, 8:07:35 PM9/22/08
to
the application is locally installed. The user's home directory is on the server.

Charles...@adobeforums.com

unread,
Sep 23, 2008, 5:21:04 PM9/23/08
to
We are having a similar problem.
I have tried various preferences/permissions/etc. with no luck.

It has also been documented/discussed on the Macintosh Management
list on Apple.

The only "solution" so far has been the suggestion to remove Acrobat Reader.

cpm

Tom_Tu...@adobeforums.com

unread,
Sep 26, 2008, 3:06:56 PM9/26/08
to
Has anyone tested this issue using a "Mobile" user account? All of the systems we set up are either AD or OD accounts but are always set up as a mobile user.

I will try to test this in one of our environments as soon as we get a copy of 9 installed.

Anthony_...@adobeforums.com

unread,
Oct 3, 2008, 10:21:22 AM10/3/08
to
I am having this problem with the plugin and the Acrobat application. The programs are local and the accounts and homes are on the network. I removed the Adobe pdf plugin and now Safari doesn't crash 10 seconds after opening a pdf. Acrobat Pro 9 does the same thing. So we are using Preview.

Jim_Patt...@adobeforums.com

unread,
Oct 24, 2008, 3:50:51 PM10/24/08
to
Late October and the problem still exists (at least for me) Anyone found a fix?
thanks
Jim Pattison

arlo_va...@adobeforums.com

unread,
Oct 27, 2008, 11:52:27 AM10/27/08
to
No Fix yet....
Adobe Still refuses to help over the phone,
or even send word to programmers.
They even were brazen enough to blamed it on the network,
which works for every other application I've installed. Curious.

Sanctus_...@adobeforums.com

unread,
Nov 5, 2008, 9:33:12 PM11/5/08
to
Since so many of you seem to be having this particular issue with remote user directories then this scenario was likely not tested by Adobe. The question to ask yourselves is "Did this ever work?" If it did, then what has changed? If not, then it may not be possible to get it to work at this time.

Sanctus

Tom_Tu...@adobeforums.com

unread,
Nov 6, 2008, 2:21:13 AM11/6/08
to
It has been working fine with Acrobat 8 and Domain accounts for a long time now.

Sanctus_...@adobeforums.com

unread,
Nov 6, 2008, 10:32:37 AM11/6/08
to
So, what has changed? If you are using Acrobat 9.0 and not version 8.0 then obviously the version of Acrobat, but has anything else changed? Server version? Did you previously use Tiger Server and move to Leopard server?

Sanctus

Gene_...@adobeforums.com

unread,
Nov 6, 2008, 1:48:08 PM11/6/08
to
To all concerned: This is a known issue with people using folder redirection software. To my knowledge Adobe is working on an update that will address this issue; however there is no release date as far as I have seen on the Internet. Acrobat 8 will not cause this issue.

Jim_Patt...@adobeforums.com

unread,
Nov 6, 2008, 1:58:43 PM11/6/08
to
Sanctus, to answer your question more fully, the version of server doesn't seem to make a difference, in that Reader 7 or 8 will work fine with accounts hosted on a OS10.4.x server or on a 10.5.x server. Reader 9 won't work with accounts hosted on a 10.5.x server ( I haven't tested it with a 10.4.x as it easier to roll back the Reader version than it is the server version)

Jim

Tom_Tu...@adobeforums.com

unread,
Nov 6, 2008, 4:56:03 PM11/6/08
to
Just to possibly further help Adobe:

In my cases the accounts are set up as Mobile Users. The controller can either be an Open Directory or an Active Directory server. I have seen the issue under both environments.

Tom

SCor...@adobeforums.com

unread,
Nov 7, 2008, 1:06:00 PM11/7/08
to
Can a few of you post the error message(s) and crash logs text? Just want to see if it's the same basic error.

~Steve

Jim_Patt...@adobeforums.com

unread,
Nov 10, 2008, 8:51:42 AM11/10/08
to
Here you go-there is no error message-Reader just locks up

Process: AdobeReader [1315]
Path: /Applications/Adobe Reader 9/Adobe Reader.app/Contents/MacOS/AdobeReader
Identifier: com.adobe.Reader
Version: 9.0.0 (9.0.0)
Code Type: X86 (Native)
Parent Process: launchd [192]

Date/Time: 2008-10-24 14:15:06.860 -0500
OS Version: Mac OS X 10.5.5 (9F33)
Report Version: 6

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread: 0

Thread 0 Crashed:
0 libSystem.B.dylib 0x92c0ab9e __kill + 10
1 libSystem.B.dylib 0x92c81ec2 raise + 26
2 libSystem.B.dylib 0x92c9147f abort + 73
3 libstdc++.6.dylib 0x95682005 0x9563a000 + 294917
4 libstdc++.6.dylib 0x9568010c __gxx_personality_v0 + 1108
5 libstdc++.6.dylib 0x9568014b std::terminate() + 29
6 libstdc++.6.dylib 0x95680261 __cxa_throw + 101
7 com.adobe.Acrobat.framework 0x806bb5bb CopiesPagesPDE_Open + 6632861
8 com.adobe.Acrobat.framework 0x8068c56a CopiesPagesPDE_Open + 6440268
9 com.adobe.Acrobat.framework 0x8068b7c9 CopiesPagesPDE_Open + 6436779
10 com.adobe.Acrobat.framework 0x8068cdb4 CopiesPagesPDE_Open + 6442390
11 com.adobe.Acrobat.framework 0x809bf41b 0x7feb8000 + 11564059
12 com.adobe.Acrobat.framework 0x809bf5c6 0x7feb8000 + 11564486
13 com.adobe.Acrobat.framework 0x8062bcf8 CopiesPagesPDE_Open + 6044890
14 com.adobe.Acrobat.framework 0x804c6fa0 CopiesPagesPDE_Open + 4583298
15 com.adobe.Acrobat.framework 0x804c718b CopiesPagesPDE_Open + 4583789
16 com.adobe.Acrobat.framework 0x7fff9285 RunAcrobat + 1304851
17 com.adobe.Acrobat.framework 0x7fff8fb8 RunAcrobat + 1304134
18 com.apple.CoreFoundation 0x93ae7b45 CFRunLoopRunSpecific + 4469
19 com.apple.CoreFoundation 0x93ae7cf8 CFRunLoopRunInMode + 88
20 com.apple.HIToolbox 0x95726480 RunCurrentEventLoopInMode + 283
21 com.apple.HIToolbox 0x95726299 ReceiveNextEventCommon + 374
22 com.apple.HIToolbox 0x9572610d BlockUntilNextEventMatchingListInMode + 106
23 com.apple.AppKit 0x90e6b3ed _DPSNextEvent + 657
24 com.apple.AppKit 0x90e6aca0 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
25 com.apple.AppKit 0x90e63cdb -[NSApplication run] + 795
26 com.adobe.Acrobat.framework 0x7febb36d RunAcrobat + 2555
27 com.adobe.Acrobat.framework 0x7febaab0 RunAcrobat + 318
28 com.adobe.Reader 0x00002e8b start + 2371
29 com.adobe.Reader 0x0000264a start + 258
30 com.adobe.Reader 0x00002571 start + 41

Thread 1:
0 libSystem.B.dylib 0x92ba368e __semwait_signal + 10
1 libSystem.B.dylib 0x92bce36d pthread_cond_wait$UNIX2003 + 73
2 com.apple.ColorSync 0x9175f460 pthreadSemaphoreWait(t_pthreadSemaphore*) + 42
3 com.apple.ColorSync 0x91771d92 CMMConvTask(void*) + 54
4 libSystem.B.dylib 0x92bcd6f5 _pthread_start + 321
5 libSystem.B.dylib 0x92bcd5b2 thread_start + 34

Thread 2:
0 libSystem.B.dylib 0x92b9c4a6 mach_msg_trap + 10
1 libSystem.B.dylib 0x92ba3c9c mach_msg + 72
2 com.apple.CoreFoundation 0x93ae70ce CFRunLoopRunSpecific + 1790
3 com.apple.CoreFoundation 0x93ae7cf8 CFRunLoopRunInMode + 88
4 com.apple.CFNetwork 0x91851eca CFURLCacheWorkerThread(void*) + 396
5 libSystem.B.dylib 0x92bcd6f5 _pthread_start + 321
6 libSystem.B.dylib 0x92bcd5b2 thread_start + 34

Thread 3:
0 libSystem.B.dylib 0x92ba368e __semwait_signal + 10
1 libSystem.B.dylib 0x92bce36d pthread_cond_wait$UNIX2003 + 73
2 ...ple.CoreServices.CarbonCore 0x9628c24f TSWaitOnCondition + 126
3 ...ple.CoreServices.CarbonCore 0x9626b18e TSWaitOnConditionTimedRelative + 202
4 ...ple.CoreServices.CarbonCore 0x9628becc MPWaitOnQueue + 208
5 AdobeACE 0x7fc1dd8d ACEMPThread::Task() + 133
6 AdobeACE 0x7fc1dd01 TaskGlue + 17
7 ...ple.CoreServices.CarbonCore 0x9628a463 PrivateMPEntryPoint + 56
8 libSystem.B.dylib 0x92bcd6f5 _pthread_start + 321
9 libSystem.B.dylib 0x92bcd5b2 thread_start + 34

Thread 4:
0 libSystem.B.dylib 0x92b9c4ee semaphore_wait_signal_trap + 10
1 libSystem.B.dylib 0x92bce866 _pthread_cond_wait + 1267
2 libSystem.B.dylib 0x92c14371 pthread_cond_wait + 48
3 AdobeAGM 0x7e574984 pthread_condition_base::Wait(pthread_scoped_lock_base&) + 26
4 AdobeAGM 0x7e5748b5 AGMMessageQueueImpl::Pull() + 65
5 AdobeAGM 0x7e963fc4 AGMWorkQueueTask::operator()() + 84
6 AdobeAGM 0x7e96524f boost::function0<void, std::allocator<boost::function_base> >::operator()() const + 75
7 AdobeAGM 0x7e57476d thread_proxy + 45
8 libSystem.B.dylib 0x92bcd6f5 _pthread_start + 321
9 libSystem.B.dylib 0x92bcd5b2 thread_start + 34

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x00000000 ebx: 0x92c9143f ecx: 0xbfffe49c edx: 0x92c0ab9e
edi: 0x80a296ec esi: 0xa03ae578 ebp: 0xbfffe4b8 esp: 0xbfffe49c
ss: 0x0000001f efl: 0x00000286 eip: 0x92c0ab9e cs: 0x00000007
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
cr2: 0xffe178e0

Jeremy...@adobeforums.com

unread,
Nov 12, 2008, 3:04:44 PM11/12/08
to
I have a client with the same problem, profiles are kept on an OSX server. Adobe Support said to monitor this forum for a solution. Here's the error log:

Date/Time: 2008-11-12 14:01:43 -0500
OS Version: 10.5.5 (Build 9F33)
Architecture: i386
Report Version: 4

Command: Acrobat
Path: /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/MacOS/AdobeAcrobat
Version: 9.0.0 (9.0.0)
Parent: launchd [126]

PID: 1418
Event: hang
Time: 9.17s
Steps: 66

Process: AdobeAcrobat [1418]
Path: /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/MacOS/AdobeAcrobat

ADDRESS BINARY
00001000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/MacOS/AdobeAcrobat
0059c000 /usr/lib/libmx.A.dylib
005b2000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/adobe_caps.framework/adobe_caps
007d7000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/asneu.framework/asneu
007e8000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/adobe_eula.framework/adobe_eula
15f7f000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/AMTLibWrapper.framework/AMTLibWrapper
160e3000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/adobe_epic.framework/adobe_epic
16128000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/MacOS/AdobeLM_libFNP.dylib
16d68000 /System/Library/TextEncodings/Unicode Encodings.bundle/Contents/MacOS/Unicode Encodings
16d7a000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/AcroSQLite.framework/AcroSQLite
75c6d000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Plug-ins/PPKLite.acroplugin/Contents/MacOS/PPKLite
7ac2b000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Plug-ins/Comments.acroplugin/Contents/MacOS/Comments
7d848000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/Acrobat.framework/../AdobeCoolType.framework/Versions/A/AdobeCoolType
7e4bb000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/Acrobat.framework/../AdobeBIB.framework/Versions/A/AdobeBIB
7e56c000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/Acrobat.framework/../AdobeAGM.framework/Versions/A/AdobeAGM
7fc1b000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/Acrobat.framework/../AdobeACE.framework/Versions/A/AdobeACE
7feb8000 /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/Acrobat.framework/Acrobat

Thread id: 10d13128
User stack:
66 start + 41 (in AdobeAcrobat) [0x2571]
66 start + 258 (in AdobeAcrobat) [0x264a]
66 start + 2371 (in AdobeAcrobat) [0x2e8b]
66 _RunAcrobat + 318 (in Acrobat) [0x7feba6b8]
66 _RunAcrobat + 3090 (in Acrobat) [0x7febb18c]
66 -[NSApplication run] + 795 (in AppKit) [0x9336dcdb]
66 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128 (in AppKit) [0x93374ca0]
66 __DPSNextEvent + 657 (in AppKit) [0x933753ed]
66 _BlockUntilNextEventMatchingListInMode + 106 (in HIToolbox) [0x90d8810d]
66 _ReceiveNextEventCommon + 374 (in HIToolbox) [0x90d88299]
66 _RunCurrentEventLoopInMode + 283 (in HIToolbox) [0x90d88480]
66 _CFRunLoopRunInMode + 88 (in CoreFoundation) [0x95ff4cf8]
66 _CFRunLoopRunSpecific + 4469 (in CoreFoundation) [0x95ff4b45]
66 _RunAcrobat + 1356870 (in Acrobat) [0x800059c0]
66 _RunAcrobat + 1357585 (in Acrobat) [0x80005c8b]
66 ??? [0x80770bbb]
66 ??? [0x807709d0]
66 ??? [0x808c7a88]
66 ??? [0x80d06172]
66 ??? [0x80d05ef4]
66 ??? [0x8093d336]
66 ??? [0x8093d228]
66 ??? [0x8093d17d]
66 ??? [0x8097b47e]
66 _sqlite3_open + 45746 (in AcroSQLite) [0x16da1ee5]
66 _sqlite3_open + 45003 (in AcroSQLite) [0x16da1bfe]
66 _sqlite3_get_table + 2851 (in AcroSQLite) [0x16daa1fa]
66 _sqlite3_open + 26121 (in AcroSQLite) [0x16d9d23c]
66 _sqlite3_mprintf + 14007 (in AcroSQLite) [0x16da6cbc]
66 _sqlite3_mprintf + 11140 (in AcroSQLite) [0x16da6189]
66 _sqlite3_mprintf + 8238 (in AcroSQLite) [0x16da5633]
66 ??? [0x16d85d0c]
66 _sqlite3_prepare_v2 + 1981 (in AcroSQLite) [0x16da2786]
66 _sqlite3_prepare_v2 + 1797 (in AcroSQLite) [0x16da26ce]
66 _sqlite3_prepare_v2 + 904 (in AcroSQLite) [0x16da2351]
66 ??? [0x16d83fce]
66 ??? [0x16d82998]
66 ??? [0x16d7df82]
66 _sqlite3_open + 17532 (in AcroSQLite) [0x16d9b0af]
66 _sqlite3_open + 7720 (in AcroSQLite) [0x16d98a5b]
66 _sqlite3_close + 1611 (in AcroSQLite) [0x16d95beb]
66 ??? [0x8093ba76]
66 ??? [0x8076aaa5]
66 _mach_wait_until + 10 (in libSystem.B.dylib) [0x964a05c6]
Kernel stack:
5 _dtrace_get_cpu_int_stack_top + 543 [0x1974c2]
5 _mach_wait_until_trap + 61 [0x12975d]
5 _thread_block + 33 [0x136ac0]
5 _thread_block_reason + 135 [0x136a1c]
5 _thread_setrun + 3173 [0x135f10]
5 _machine_idle + 278 [0x1a2aab]

Thread id: f7efc80
User stack:
66 _thread_start + 34 (in libSystem.B.dylib) [0x964d15b2]
66 __pthread_start + 321 (in libSystem.B.dylib) [0x964d16f5]
66 _PrivateMPEntryPoint + 56 (in CarbonCore) [0x95bb7463]
66 _TaskGlue + 17 (in AdobeACE) [0x7fc1dd01]
66 __ZN11ACEMPThread4TaskEv + 133 (in AdobeACE) [0x7fc1dd8d]
66 _MPWaitOnQueue + 208 (in CarbonCore) [0x95bb8ecc]
66 _TSWaitOnConditionTimedRelative + 202 (in CarbonCore) [0x95b9818e]
66 _TSWaitOnCondition + 126 (in CarbonCore) [0x95bb924f]
66 ___semwait_signal + 10 (in libSystem.B.dylib) [0x964a768e]

Thread id: fd29e40
User sta

Roger_...@adobeforums.com

unread,
Nov 17, 2008, 4:17:04 AM11/17/08
to
As was mentioned before a local user has no problem. With a networked user (home on a 10.5.4 server) we observe the same lockup as described above. However, when I create a mobile account whereby the user home is synched to the local harddisk Adobe Acrobat Pro 9 (and Adobe Reader 9 as well) work flawlessly.

Roger

David...@adobeforums.com

unread,
Dec 8, 2008, 9:29:06 PM12/8/08
to
Same problem here.
Tried disabling Acrobat plugins. No luck.
Tried copying user plist files from local admin account to remote user account. No luck.
Read something about acrobat 7 having this issue and solution being to alias cache to local computer's shared folder. I tried this unsuccessfully.

David...@adobeforums.com

unread,
Dec 9, 2008, 10:07:52 PM12/9/08
to
Downgraded to Acrobat 8 and now it works, but still gives an error that can APPARENTLY be ignored:
"Could not initialize Organizer database. Organizer features will not be available"

Philli...@adobeforums.com

unread,
Dec 11, 2008, 5:10:26 PM12/11/08
to
Has this been resolved?
I just started installing CS4 and Acrobat Pro 9 hangs when launched on a network home.

J_Pat...@adobeforums.com

unread,
Dec 11, 2008, 6:38:30 PM12/11/08
to
Phillip,
Not that I have heard-everyone that tries it gets the same results that you see
Jim

Philli...@adobeforums.com

unread,
Dec 14, 2008, 4:34:15 PM12/14/08
to
Thanks Jim
Interestingly if you drag and drop a document onto the app it opens that document then hangs.

Andrew...@adobeforums.com

unread,
Jan 21, 2009, 11:43:33 AM1/21/09
to
We have just installed Acrobat 9 and are having the same issue. We are running Mac on OS 10.5.6 with users on an Xserve with OS 10.4. Acrobat 8 works fine.

Philli...@adobeforums.com

unread,
Jan 27, 2009, 9:44:36 PM1/27/09
to
I gave up waiting for someone to even acknowledge there is a problem despite putting in a bug report.
I've downgraded to version 8.

elliott...@adobeforums.com

unread,
Jan 28, 2009, 6:41:14 PM1/28/09
to
I'm having the same problem.

a related question -- Does anyone know how to make a network user a local administrator?

Perhaps if the networked user is a local admin on the computer it could work...

Jim_Patt...@adobeforums.com

unread,
Jan 29, 2009, 8:33:46 AM1/29/09
to
Elliot, when logged in as the user, go to system preferences/accounts, click on the user's name, then click on (going from memory here as my Mac is elsewhere) allow user to manage this computer.

However, that doesn't solve this problem. All my users have that right.

Jim PAttison

Zeljko...@adobeforums.com

unread,
Feb 9, 2009, 2:59:43 AM2/9/09
to
I have 2 pofiles: One on my Macintosh (G5) and one on the XServe.
Acrobat 9 on the profile on the mac (admin), goes with no problems.
After switching on the user profile on the server, acrobat crashes on starting the app (endless spinball!). The same effect is, when i started a webbased pdf on my browser (safari or firefox).
The errors on my crashreporter:

Process: AdobeAcrobat [1902]


Path: /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/MacOS/AdobeAcrobat

Identifier: com.adobe.Acrobat.Pro
Version: 9.0.0 (9.0.0)
Code Type: PPC (Native)
Parent Process: launchd [87]

Date/Time: 2009-01-30 14:38:51.043 +0100
OS Version: Mac OS X 10.5.6 (9G55)
Report Version: 6

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread: 0

Thread 0 Crashed:
0 libSystem.B.dylib 0x9491caf0 __kill + 12
1 libSystem.B.dylib 0x949b7bac abort + 84
2 libstdc++.6.dylib 0x9094ce24 __gnu_cxx::__verbose_terminate_handler() + 400
3 libstdc++.6.dylib 0x9094a940 __gxx_personality_v0 + 1240
4 libstdc++.6.dylib 0x9094a9a4 std::terminate() + 68
5 libstdc++.6.dylib 0x9094abe4 __cxa_throw + 124
6 com.adobe.Acrobat.framework 0x81039208 CopiesPagesPDE_Open + 14244664
7 com.adobe.Acrobat.framework 0x80fe5f04 CopiesPagesPDE_Open + 13903924
8 com.adobe.Acrobat.framework 0x80fe44e8 CopiesPagesPDE_Open + 13897240
9 com.adobe.Acrobat.framework 0x80fe7268 CopiesPagesPDE_Open + 13908888
10 com.adobe.Acrobat.framework 0x8175bc40 0x7feb8000 + 25836608
11 com.adobe.Acrobat.framework 0x8175c1e0 0x7feb8000 + 25838048
12 com.adobe.Acrobat.framework 0x80f33860 CopiesPagesPDE_Open + 13173136
13 com.adobe.Acrobat.framework 0x80cf6120 CopiesPagesPDE_Open + 10824272
14 com.adobe.Acrobat.framework 0x80cf653c CopiesPagesPDE_Open + 10825324
15 com.adobe.Acrobat.framework 0x800db844 RunAcrobat + 2229524
16 com.adobe.Acrobat.framework 0x800db30c RunAcrobat + 2228188
17 com.apple.CoreFoundation 0x904759d8 CFRunLoopRunSpecific + 2968
18 com.apple.HIToolbox 0x9340dbc4 RunCurrentEventLoopInMode + 264
19 com.apple.HIToolbox 0x9340d9e8 ReceiveNextEventCommon + 412
20 com.apple.HIToolbox 0x9340d828 BlockUntilNextEventMatchingListInMode + 84
21 com.apple.AppKit 0x90ae6724 _DPSNextEvent + 596
22 com.apple.AppKit 0x90ae60dc -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 112
23 com.apple.AppKit 0x90adfd98 -[NSApplication run] + 736
24 com.adobe.Acrobat.framework 0x7febcb2c RunAcrobat + 6140
25 com.adobe.Acrobat.framework 0x7febb428 RunAcrobat + 248
26 com.adobe.Acrobat.Pro 0x00003b98 start + 5392
27 com.adobe.Acrobat.Pro 0x000029b0 start + 808
28 com.adobe.Acrobat.Pro 0x000026b4 start + 44

Thread 1:
0 libSystem.B.dylib 0x948a1b6c __semwait_signal + 12
1 libSystem.B.dylib 0x948de3cc _pthread_cond_wait + 1580
2 com.apple.ColorSync 0x903710b0 pthreadSemaphoreWait(t_pthreadSemaphore*) + 36
3 com.apple.ColorSync 0x90384bec CMMConvTask(void*) + 48
4 libSystem.B.dylib 0x948dd024 _pthread_start + 316

Thread 2:
0 libSystem.B.dylib 0x948a1b6c __semwait_signal + 12
1 libSystem.B.dylib 0x948de3cc _pthread_cond_wait + 1580
2 ...ple.CoreServices.CarbonCore 0x9240e688 TSWaitOnCondition + 132
3 ...ple.CoreServices.CarbonCore 0x923ecae4 TSWaitOnConditionTimedRelative + 204
4 ...ple.CoreServices.CarbonCore 0x9240e244 MPWaitOnQueue + 272
5 AdobeACE 0x7fc1dc5c ACEMPThread::Task() + 148
6 AdobeACE 0x7fc1dbb0 TaskGlue + 24
7 ...ple.CoreServices.CarbonCore 0x9240c478 PrivateMPEntryPoint + 76
8 libSystem.B.dylib 0x948dd024 _pthread_start + 316

Thread 3:
0 libSystem.B.dylib 0x9489b1b8 semaphore_wait_signal_trap + 8
1 AdobeAGM 0x7e5757b0 AGMMessageQueueImpl::Pull() + 72
2 AdobeAGM 0x7e9759f8 AGMWorkQueueTask::operator()() + 88
3 AdobeAGM 0x7e9761b4 boost::function0<void, std::allocator<boost::function_base> >::operator()() const + 96
4 AdobeAGM 0x7e57562c thread_proxy + 44
5 libSystem.B.dylib 0x948dd024 _pthread_start + 316

Thread 4:
0 libSystem.B.dylib 0x9489b1d8 semaphore_timedwait_signal_trap + 8
1 libSystem.B.dylib 0x948de2c8 _pthread_cond_wait + 1320
2 com.apple.Foundation 0x95532b24 -[NSCondition waitUntilDate:] + 384
3 com.apple.Foundation 0x95532950 -[NSConditionLock lockWhenCondition:beforeDate:] + 268
4 ...adobe.acrobat.amtlibwrapper 0x0de28a40 AVAMTForegroundUpdateCheckEnabled + 180820
5 ...adobe.acrobat.amtlibwrapper 0x0de170e4 AVAMTForegroundUpdateCheckEnabled + 108792
6 ...adobe.acrobat.amtlibwrapper 0x0de26f40 AVAMTForegroundUpdateCheckEnabled + 173908
7 com.apple.Foundation 0x954f5764 __NSThread__main__ + 1004
8 libSystem.B.dylib 0x948dd024 _pthread_start + 316

Thread 5:
0 libSystem.B.dylib 0x9489b1d8 semaphore_timedwait_signal_trap + 8
1 libSystem.B.dylib 0x948de2c8 _pthread_cond_wait + 1320
2 com.apple.Foundation 0x95532b24 -[NSCondition waitUntilDate:] + 384
3 com.apple.Foundation 0x95532950 -[NSConditionLock lockWhenCondition:beforeDate:] + 268
4 com.apple.AppKit 0x90b41eac -[NSUIHeartBeat _heartBeatThread:] + 664
5 com.apple.Foundation 0x954f5764 __NSThread__main__ + 1004
6 libSystem.B.dylib 0x948dd024 _pthread_start + 316

Thread 0 crashed with PPC Thread State 32:
srr0: 0x9491caf0 srr1: 0x0200f030 dar: 0xe0963088 dsisr: 0x40000000
r0: 0x00000025 r1: 0xbfffdc00 r2: 0x00001000 r3: 0x00000000
r4: 0x00000000 r5: 0x00000001 r6: 0x000049da r7: 0x00000840
r8: 0x9094cd8c r9: 0x0dc32bf0 r10: 0x948e5964 r11: 0xa0862530
r12: 0x9491cadc r13: 0x00000000 r14: 0xa0082478 r15: 0x7fffffff
r16: 0xffffffff r17: 0x00000001 r18: 0x00000000 r19: 0x00000000
r20: 0xbfffdf2c r21: 0xbfffde84 r22: 0xbfffde9c r23: 0x0d869024
r24: 0xbfffde6c r25: 0xbfffdefc r26: 0xbfffdeb4 r27: 0x0dc731a0
r28: 0xa018cca0 r29: 0xa08603a0 r30: 0x810faf88 r31: 0x949b7b64
cr: 0x44042202 xer: 0x00000000 lr: 0x949b7bb0 ctr: 0x9491cadc
vrsave: 0x00000fff

Binary Images:
0x1000 - 0x3fcf +com.adobe.Acrobat.Pro 9.0.0 (9.0.0) <40558512dee14e998d35a3a0bacb696b> /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/MacOS/AdobeAcrobat
0xcf97000 - 0xd149ff7 com.apple.RawCamera.bundle 2.0.10 (2.0.10) <385afe576f8fd60530711a5eab4ed182> /System/Library/CoreServices/RawCamera.bundle/Contents/MacOS/RawCamera
0xd53e000 - 0xd55cfe3 +com.adobe.selfhealer AdobeSelfHealing version 2.2.0 (2.2.0) <51d258fb243d450fbd639084d19aad11> /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/AdobeSelfHealing.framework/AdobeSelfHealing
0xdb83000 - 0xdbcbffb +com.adobe.adobe_caps adobe_caps 0.0.120.0 (0.0.120.0) /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/adobe_caps.framework/adobe_caps
0xdbd1000 - 0xdbf2ff1 libmx.A.dylib ??? (???) /usr/lib/libmx.A.dylib
0xddfa000 - 0xdf41fff +com.adobe.acrobat.amtlibwrapper 1.0 (1.0) <5063d34522494fe8adb6fdc3cd829e2c> /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/AMTLibWrapper.framework/AMTLibWrapper
0xdf6b000 - 0xdf7efef +com.adobe.asneu.framework asneu version 1.6.2f01 (1.6.2) /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat Pro.app/Contents/Frameworks/asneu.framework/asneu

José_F._Martínez@adobeforums.com

unread,
Feb 10, 2009, 10:02:59 AM2/10/09
to
ADOBE DOESN'T CARE. We spent money on Acrobat 7 and Acrobat 8 and were unable to run them unless the user had administrative privileges. With Acrobat 9 that seems to be fixed, however network users are still left in the cold. We are having the EXACT same issues. Mobile accounts work; network accounts do not. I'm TIRED of their arrogance.

José_F._Martínez@adobeforums.com

unread,
Feb 11, 2009, 12:44:05 PM2/11/09
to
Console report:

2/11/09 12:31:54 PM [0x0-0xa90a9].com.adobe.Acrobat.Pro[865] terminate called after throwing an instance of 'SQLiteUtils::SQLiteException'
2/11/09 12:32:01 PM com.apple.launchd[815] ([0x0-0xa90a9].com.adobe.Acrobat.Pro[865]) Exited abnormally: Abort trap
2/11/09 12:32:57 PM com.apple.launchd[815] ([0x0-0xae0ae].com.adobe.Acrobat.Pro[883]) Exited: Terminated

Jaso...@adobeforums.com

unread,
Feb 12, 2009, 4:30:29 PM2/12/09
to
My client computers are having the same problems with Acrobat 9 and Reader 9.

Setup is as follow:
Servers
1 - Apple Xserve G5 10.5.6 Server - Open Directory Authentication
1 - Apple Xserve G5 10.5.6 Server- Home Folder Share via AFP
Clients tested
1 - eMac G4 1.42 GHz 10.5.6
1 - PowerMac G5 2 GHz 10.5.6
1 - iMac Intel 2 GHz 10.5.6

Upon Login to a Network Home the following occurs if I try to open a PDF or open Acrobat/Reader 9
The PDF will open and the program will lock up
If I try to open the Application without a PDF it will lock up almost immediately

After a little trial and error I think I've isolated the problem file being
~/Library/Application Support/Adobe/Acrobat/9.0_x86 (9.0_ppc)/AdobeCMapFnt09.lst

I moved all files in
~/Library/Application Support/Adobe/Acrobat/9.0_x86/ to
/Users/Shared/ and then aliased them back to
~/Library/Application Support/Adobe/Acrobat/9.0_x86/
then relaunched Acrobat

Acrobat will launch and you can click through the menus but the moment you try to open something it will lock up again.

Interestingly, the AdobeCMapFnt09.lst file doesn't populate properly on a network account when you open it via TextEdit. If you open this file in TextEdit from a Mobile or local account.

Hope this helps someone find a solution to this issue plaguing all the network admins out there.

thomas_...@adobeforums.com

unread,
Feb 20, 2009, 7:47:19 AM2/20/09
to
Hi

I also have the exact same error. When I spoke to a techie they said that they are aware that windows has the problem and it would be fixed as soon as they release the update. They could also not inform me as to when the update would be released.

Has anyone in the meantime found a fix to the problem.

Jaso...@adobeforums.com

unread,
Feb 20, 2009, 11:02:49 AM2/20/09
to
I found a solution to this issue for Network Users running 10.5.6

1. Log in as a Network User
2. Go to /Users/Shared/
3. If you are on an Intel based Mac create a folder in /Users/Shared/ named 9.0_x86 if you are on a Mac that is a G5/G4 create a folder named 9.0_ppc

At this point you should have created either
/Users/Shared/9.0_x86/
/Users/Shared/9.0_ppc/

4. Go to ~/Library/Application Support/Adobe/Acrobat/ and trash the 9.0_x86 or 9.0_ppc folder contained within
5. Go to Applications/Utilities/ and open Terminal
6. Enter one of the following into the Terminal
If you are on an Intel based Mac enter
ln -s /Users/Shared/9.0_x86 ~/Library/Application\ Support/Adobe/Acrobat
If you are on a G5/G4 Mac enter
ln -s /Users/Shared/9.0_ppc ~/Library/Application\ Support/Adobe/Acrobat
7. Open up Acrobat 9 and it should work!

What this does is create a symbolic link on the network location to the folder we created in the Shared which resides on the hard disk so the Organizer90 file doesn't stall during creation.

This also fixes Reader 9.0

Orlando...@adobeforums.com

unread,
Feb 22, 2009, 2:08:15 PM2/22/09
to
I had the same problems as all you folks. Jason's solution works well with me. Amazing tht the Adobe folks were not able to give me the solution - this is a serious bug Adobe is carrying over since Acrobat 7 - previous versions did just not open the Organizer, but at least they did not crash.
I start having doubts about Adobe taking bugs very seriously... In any case, thanks to Jason.

Orlando...@adobeforums.com

unread,
Feb 23, 2009, 2:09:13 PM2/23/09
to
You'll find the solution at
<http://www.adobeforums.com/webx/.59b660c2/34?@@>
At least, it worked flawlessly for me.

Joachi...@adobeforums.com

unread,
Feb 25, 2009, 6:59:38 AM2/25/09
to
I have 800+ Design-Students on 100+ Intel and PPC-Networked Mac's.

I can not tell them all to do this stuff every Time they log in and want to use Acrobat 9.

Does anyone have an Idea how to make it work for all ??

Thanks, Achim

Tom_Tu...@adobeforums.com

unread,
Feb 25, 2009, 3:21:43 PM2/25/09
to
Achim, how are your user accounts managed (AD, OD)? I'm thinking you could use ARD to push out the folders into the Shared User on all the machines. You could either do it in two batches, one for Intel and one for PPC or send both folders to all machines.

The second part is the tricky part. Could you add a login script to each user that creates the symbolic link when they log into a machine? The issue then would be separating the users by machine type and creating different scripts.

This assumes that you have no classrooms with a mix of PPC and Intel boxes.

Hope this has been of some help.

I am currently telling all of my corporate clients not to buy Acrobat 9 until this issue is resolved by Adobe.

W_John...@adobeforums.com

unread,
Mar 4, 2009, 5:50:55 PM3/4/09
to
This workaround still failed for me. I'm part of the support team at a school.

With Open Directory services / mounted NFS shares for home directory, Adobe Acrobat Pro 9 has yet to open. OSX 10.5.6, Intel Imac.

However, Acrobat Reader in the same version has no issue. As always, local user has no problems. The last output before every crash is:

3/3/09 12:33:27 PM authexec[1565] executing /Applications/Adobe Acrobat 9 Pro/Adobe Acrobat
Pro.app/Contents/Frameworks/AdobeSelfHealing.framework/Resources/MoverTool

3/3/09 12:33:27 PM [0x0-0x7b07b].com.adobe.Acrobat.Pro[1561] terminate
called without an active exception

Acrobat 8 Pro reveals no such issue. Same machine, same network user, different OS partition...

Rene_...@adobeforums.com

unread,
Mar 4, 2009, 8:15:59 PM3/4/09
to
Heya everyone, i had the same issue with network home directories with hundreds of users, and i i had to get them up pretty quick smart, here is how i did it, it gets around the launch issue and also the authenticate issue most of the time as long as you have launched both programs as the default admin user on your gold image.....

in short I already have Network Home Redirection running to reduce the load on the servers for things like office and cache files... so basically I added a redirect for the appropriate application support for acrobat as well... but here is step buy step from scratch..

firstly install NHR on your main gold image - <http://www.jochsner.dyndns.org/scripts/NHR.html>
then log in as root and navigate to /etc/hooks
Open LIclean.hook with Xcode or something similar and modify the script in the following places....

#This section will delete the Fonts etc....

Add line
'i' rm -rf "$home_loc"/Library/Application\ Support/Adobe/Acrobat/9.0_x86

#This will copy several Microsoft folders of the local admin user.... etc

add line
'i' cp -R /Users/$LocalAdminUser/Library/Application\ Support/Adobe/Acrobat /tmp/$1/Adobe/

#This last section will set up symbolic links for the current user.....

Add lines
'i' ln -s /tmp/$1/Adobe/9.0_x86 "$home_loc"/Library/Application\ Support/Adobe/Acrobat/
'i' ln -s /tmp/$1/Adobe/9.0 "$home_loc"/Library/Application\ Support/Adobe/Acrobat/

and this should sort the issue out.... basically you are simply copying the default admin app support for acrobat to a tmp directory and then creating a symbolic link, but this is happening as a login that runs when a network user logs in.

Most important thing is that the main admin user (UID 501) has launched these apps so that the application support files are there.... otherwise this will not work...

If you get really stuck then i guess you can email me and i will try to help seeing as support is not playing ball and it is start of semester.... any...@me.com

Rene

Rene_...@adobeforums.com

unread,
Mar 6, 2009, 7:21:47 PM3/6/09
to
Just noticed a slight typo in these, none of the lines should have 'i' at the beginning - not sure where they came from, and there should also be a a line

rm -rf "$home_loc"/Library/Application\ Support/Adobe/Acrobat/9.0
if you are running ppc machines

so to be nice and clear for Intel machines do the following

#This section will delete the Fonts etc....

Add line


rm -rf "$home_loc"/Library/Application\ Support/Adobe/Acrobat/9.0_x86

#This will copy several Microsoft folders of the local admin user.... etc

add line


cp -R /Users/$LocalAdminUser/Library/Application\ Support/Adobe/Acrobat /tmp/$1/Adobe/

#This last section will set up symbolic links for the current user.....

Add lines


ln -s /tmp/$1/Adobe/9.0_x86 "$home_loc"/Library/Application\ Support/Adobe/Acrobat/

============

for PPC machines do the following

#This section will delete the Fonts etc....

Add line
rm -rf "$home_loc"/Library/Application\ Support/Adobe/Acrobat/9.0

#This will copy several Microsoft folders of the local admin user.... etc

add line


cp -R /Users/$LocalAdminUser/Library/Application\ Support/Adobe/Acrobat /tmp/$1/Adobe/

#This last section will set up symbolic links for the current user.....

Add lines

Tom_Tu...@adobeforums.com

unread,
Mar 11, 2009, 1:00:18 PM3/11/09
to
Has anyone had a chance to test with the new Acrobat 9.1 patch?

Tom

M._Zörkler@adobeforums.com

unread,
Mar 12, 2009, 4:34:49 AM3/12/09
to
Yes, I installed Acrobat 9.1 yesterday on our Test-Network-Mac and it doesnt work.

John_Le...@adobeforums.com

unread,
Mar 26, 2009, 5:05:53 AM3/26/09
to
Sam problem here Is there another patch for this comming out soon? ________________________________________________________________
movie phim online <http://coiphimhay.com> media... music nhac online <http://coiphimhay.com/phimonline.action?tab=3> the world of wholesale fashion <http://fashion4us.com> and models wholesale clothing <http://fashion4us.com> and lovely phim han quoc <http://phimhanquoc.us> film..?!!

shado...@adobeforums.com

unread,
Mar 27, 2009, 5:49:06 AM3/27/09
to
confirmed 9.1 push didn't fix the problem. wondering if we plan any near future patch for this? thanks in advance.

movie phim <http://coiphimhay.com> media music nhac online <http://coiphimhay.com/phimonline.action?tab=3> sound model of wholesale fashion <http://fashion4us.com> and lovely korean phim han quoc <http://phimhanquoc.us> film movie

trav...@gmail.com

unread,
Apr 14, 2009, 10:08:07 AM4/14/09
to
Hi, I had the same issue with acrobat Pro and Reader 9 and network
accounts. I followed the solution of Rene with NRH and i added few
lines in the file "LIclean.hook" to resolve the crash.

then log in as root and navigate to /etc/hooks

Open LIclean.hook:

Add lines:

# acrobat Pro and reader 9 crashes

cp -f /Users/$LocalAdminUser/Library/Preferences/com.adobe.
118.registration "$home_loc"/Library/Preferences
cp -f /Users/$LocalAdminUser/Library/Preferences/com.adobe.acrobat.
90.sh.plist "$home_loc"/Library/Preferences
cp -f /Users/$LocalAdminUser/Library/Preferences/
com.adobe.Acrobat.Pro_x86_9.0.plist "$home_loc"/Library/Preferences
cp -f /Users/$LocalAdminUser/Library/Preferences/
com.adobe.Reader_x86_9.0.plist "$home_loc"/Library/Preferences

Most important thing is that the main admin user (UID 501) has

launched these apps and so that files are there.... otherwise this
will not work... and be sure, when you launch acrobat pro or Reader
with the main admin user, that the registration's window doesn't
appear.

Fred

Reply all
Reply to author
Forward
0 new messages