RTLD_DEEPBIND incompatibe with sanitizer runtime

67 views
Skip to first unread message

xfan

unread,
Aug 20, 2020, 12:16:19 PM8/20/20
to address-sanitizer
We got the following error when using address sanitizer. 
--------
You are trying to dlopen a libssl.so.1.1 shared library with RTLD_DEEPBIND flag which is incompatibe with sanitizer runtime (see https://github.com/google/sanitizers/issues/611 for details)

--------
Unfortunately we don't have control over the dlopen.   
Is there a way to workaround this? 

Thanks
Xingyan
Reply all
Reply to author
Forward
0 new messages