can't edit config in adagios due to git repository problem

46 views
Skip to first unread message

arthur sherman

unread,
Jul 16, 2015, 6:18:42 PM7/16/15
to ada...@googlegroups.com
i'm getting the "***please tell me who you are..."
i try creating a git repository and per the instruction at:
# Create git repo which adagios uses for version control
cd /etc/nagios3/
git init
git add .
git commit -a -m "Initial commit"
i did this in the adagios config dir, /etc/adagios.
i also did it where the nagios config files are, /usr/local/nagios/etc/objects.
same error:
Warning! *** Please tell me who you are. Run git config --global user.email "y...@example.com" git config --global user.name "Your Name" to set your account's default identity. Omit --global to set the identity only in this repository. fatal: empty ident name (for <nagios@qbox-0-214.(none)>) not allowed

i also issued the 2 git-config commands above. didn't help either.
i tried disabling the git handler in /etc/adagios/adagios.conf
enable_githandler = True
#enable_githandler = False

any additional ideas appreciated.

tnx
ams
Reply all
Reply to author
Forward
0 new messages