Problems accessing https://test.salesforce.com/

173 views
Skip to first unread message

CSMaggie

unread,
Nov 21, 2011, 11:51:04 AM11/21/11
to ActiveSalesforce
Using the databasedotcom gem, I am able to successfully connect to my
personal dev Salesforce account and my client's production Salesforce
account. However, I am unable to connect to their QA sandbox account.
I did notice the url was different when I logged in through the web
browser. (https://test.salesforce.com/ vs. https://login.salesforce.com/)
Is there a url setting I need to provide or something?

The error I get is:
..... /lib/databasedotcom/client.rb:112:in `authenticate': expired
access/refresh token (Databasedotcom::SalesForceError)

I am positive the security token is correct.

Any advice?

Thanks! K

Jeff Douglas

unread,
Nov 21, 2011, 11:58:01 AM11/21/11
to activesa...@googlegroups.com
I'm actually running off of a sandbox org right now. In your databasedotcom.yml file just specify the host to connect to:

client_id: my-client
client_secret: my-secret

Thanks!

Jeff Douglas
google voice: (941) 227-4843
mobile: (941) 809-3455
email: je...@appirio.com
blog: http://blog.jeffdouglas.com



Appirio, Inc. 
Accelerating On-Demand in the Enterprise
http://www.appirio.com





--
You received this message because you are subscribed to the Google Groups "ActiveSalesforce" group.
To post to this group, send email to activesa...@googlegroups.com.
To unsubscribe from this group, send email to activesalesfor...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/activesalesforce?hl=en.


Reply all
Reply to author
Forward
0 new messages