Rails 2.2.2 compatibility

85 views
Skip to first unread message

Tony Payne

unread,
Apr 30, 2009, 12:45:53 PM4/30/09
to Active Merchant
What is the recommend version to use with Rails 2.2.2? I installed
1.4.2 and it seems to have a dependency on active_support 2.3.2:

tony-paynes-computer:~/Desktop/projects/fitplanet/trunk/fitplanet
tpayne$ script/console
Loading development environment (Rails 2.2.2)
/opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:149:in
`activate':Gem::Exception: can't activate activesupport (>= 2.3.2,
runtime), already activated activesupport-2.2.2
/opt/local/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/
active_support/testing/setup_and_teardown.rb:14:in
`included':NameError: uninitialized constant ActiveSupport::Callbacks
/opt/local/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/
console_with_helpers.rb:19:NoMethodError: undefined method
`require_dependency' for main:Object

Cody Fauser

unread,
Apr 30, 2009, 1:14:24 PM4/30/09
to activem...@googlegroups.com
Tony,

I want to remove dependence on ActiveSupport completely for the next
release of ActiveMerchant. For now, I think version 1.4.0 should work.
--
Cody Fauser
http://shopify.com - e-commerce done right
http://www.codyfauser.com - blog
http://peepcode.com/products/activemerchant-pdf - ActiveMerchant PeepCode
http://www.oreilly.com/catalog/rjsrails - RJS Templates for Rails
Reply all
Reply to author
Forward
0 new messages