We've also run into this and a relatively easy way to deal with this
problem is to start using bundler. It will sort out all these
load/dependency problems for you and in Rails3 it's used by default.
Setting it up in Rails 2.3 is as easy as following this guide:
> Hi Matt,
> We've also run into this and a relatively easy way to deal with this problem is to start using bundler. It will sort out all these load/dependency problems for you and in Rails3 it's used by default.
> Setting it up in Rails 2.3 is as easy as following this guide:
I mentioned this in another post but even with Bundler, I had problems with the 1.11.0 release of ActiveMerchant in Rails 2.3. The release notes indicate that it should be compatible but..
<paste [Active Merchant] Re: ActiveMerchant 1.11.0 released>
I don't think 1.11.0 works with Rails 2.3 at all.
activemerchant-1.11.0/lib/active_merchant.rb" line 35 of 51
active_support/core_ext/module/deprecation doesn't exist in Rails
2.3(at least not in 2.3.8 or 2.3.11). In Rails 3, that file adds
Module#deprecate but I don't see any references to that method in the
active merchant code anyway. Can that require safely be removed?
A potential workaround is to create an empty active_support/core_ext/module/deprecation.rb in your app's lib directory. Although, I'd like to confirm that it doesn't serve any purpose.
> On 21/02/11 03:41, MattS wrote:
>> Hi all,
>> I can't find the answer to this. I have an existing Rails 2.3.10 app
>> that now needs credit card processing. I've installed the latest
>> version of the ActiveMerchant (AM) repo from github. However when I
>> startup the app it complains because AM has activesupport 3.0.3
>> dependencies in it. So, how do I force the plugin installation to an
>> older version that is compatible with my version of rails? I've
>> searched all over the net, have found nothing about dealing with
>> versioning for AM, and am mystified by how to do this. Any help is
>> much appreciated. Thank you.
>> Error message when starting my server:
>> rubygems.rb:233:in `activate': can't activate activesupport (= 3.0.3,
>> runtime) for , already activated activesupport-2.3.10 for
>> ["rails-2.3.10"] (Gem::LoadError)
> You received this message because you are subscribed to the Google Groups "Active Merchant" group.
> To post to this group, send email to activem...@googlegroups.com.
> To unsubscribe from this group, send email to activemerchan...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/activemerchant?hl=en.