Error installing Abjad on Google Colab

208 views
Skip to first unread message

Pedro Faria

unread,
Jul 18, 2022, 11:21:05 AM7/18/22
to abjad-user
I'd like to use abjad on google colab, away from my home computer.
I'm not interested in showing the results as images, I'm content in generating the lilypond code and using hacklily

But whenever I try to install abjad on colab, the following error appears:

Looking in indexes: https://pypi.org/simple, https://us-python.pkg.dev/colab-wheels/public/simple/ Collecting abjad Downloading abjad-3.10.tar.gz (419 kB) |████████████████████████████████| 419 kB 24.3 MB/s WARNING: Discarding https://files.pythonhosted.org/packages/8e/04/cd4736e8ad35b9f633ab9477b8f4f8608de73ab9d77d1ce9bf1e8086053c/abjad-3.10.tar.gz#sha256=cda76470b7cd922ddd03b91e6312ac0d7a8d3481e802a43014d847a71cf8106a (from https://pypi.org/simple/abjad/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. Downloading abjad-3.9.tar.gz (422 kB) |████████████████████████████████| 422 kB 51.0 MB/s WARNING: Discarding https://files.pythonhosted.org/packages/19/df/a83cacb70ae0afaba74496c115622250c93e6e3e3890e9724e61360a4ef5/abjad-3.9.tar.gz#sha256=6ca90c7182cbfbb17099c0a6461fc5204ea7ba4420ca6aeec25b0c25fb1f9e7b (from https://pypi.org/simple/abjad/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. Downloading abjad-3.8.tar.gz (420 kB) |████████████████████████████████| 420 kB 52.1 MB/s WARNING: Discarding https://files.pythonhosted.org/packages/fd/3e/0f1c49c17898179f010ac4d0a0c6d543dfe6da314e117b31abca4a20bd62/abjad-3.8.tar.gz#sha256=2716ea041965e993789316f2d54591b42fe90b07c44a11d43a8628c4f15c92ed (from https://pypi.org/simple/abjad/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. Downloading abjad-3.7.tar.gz (420 kB) |████████████████████████████████| 420 kB 38.5 MB/s WARNING: Discarding https://files.pythonhosted.org/packages/64/9a/aba04208002e57c8753f818151ac64d93bcfe0efec4adb0191714f239bd7/abjad-3.7.tar.gz#sha256=dcdfd9e948011bc5a2fa158abee056b2ce36ae5c1a8afb261e5adfafe63cfeeb (from https://pypi.org/simple/abjad/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. Downloading abjad-3.6.tar.gz (442 kB) |████████████████████████████████| 442 kB 53.1 MB/s WARNING: Discarding https://files.pythonhosted.org/packages/02/cf/a5dab7d0e8fcc576ec00711782c56457984de7a6942a55dd2aadef28e71e/abjad-3.6.tar.gz#sha256=a8f2da5c7bb569f55532d74f41c4d9dc64b104fbf1253bafb5144f11d13d6e6a (from https://pypi.org/simple/abjad/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. Downloading abjad-3.5.tar.gz (476 kB) |████████████████████████████████| 476 kB 52.6 MB/s WARNING: Discarding https://files.pythonhosted.org/packages/7c/cf/0f655ee245ed4abad50817c5b10ad91cf0f65866b1055c28f3dff88b4687/abjad-3.5.tar.gz#sha256=43c27caae8044d7e2d305e6d7a6a74cb76ede097efe542a73449a8bf1f92eaad (from https://pypi.org/simple/abjad/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. Downloading abjad-3.4.tar.gz (515 kB) |████████████████████████████████| 515 kB 50.3 MB/s



And it ends up installing abjad 3.4 instead of the latest version. 

Pedro Faria

unread,
Jul 18, 2022, 12:21:56 PM7/18/22
to abjad-user
Even after updating the Python interpreter on colab to 3.10, the error persists, now looking like this:


Keyring is skipped due to an exception: module 'collections' has no attribute 'MutableMapping' Looking in indexes: https://pypi.org/simple, https://us-python.pkg.dev/colab-wheels/public/simple/ Collecting abjad Using cached abjad-3.10.tar.gz (419 kB) error: subprocess-exited-with-error × python setup.py egg_info did not run successfully. │ exit code: 1 ╰─> See above for output. note: This error originates from a subprocess, and is likely not a problem with pip. Preparing metadata (setup.py) ... error error: metadata-generation-failed × Encountered error while generating package metadata. ╰─> See above for output. note: This is an issue with the package mentioned above, not pip. hint: See above for details.

Trevor Bača

unread,
Jul 18, 2022, 1:18:38 PM7/18/22
to abjad...@googlegroups.com
Hi,

Abjad is definitely not tested for install on Google Colab.

Trevor.


--
You received this message because you are subscribed to the Google Groups "abjad-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to abjad-user+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/abjad-user/bd3d8f85-c4ff-4b35-abd1-0d2398cdea61n%40googlegroups.com.


--

Pedro Faria

unread,
Jul 18, 2022, 1:24:47 PM7/18/22
to abjad-user
Ok Trevor, thank you!
Reply all
Reply to author
Forward
0 new messages