Android 11

8 views
Skip to first unread message

MHBraun

unread,
May 28, 2021, 7:43:01 PMMay 28
to aarddict
After 5 years I migrated to a new phone. 
Used to Android 8 and earlier, it was easy to just store the *.slob files in a directory of the SDCard.
With my Galaxy S21+ I can not even find the folder where the apk Aard2 is residing using Total Commander. Usually I just had a folder /WikiAard to store the dictionaries.
Now I find all those possibilities blocked by the system and I did not find a quick way to resolve this.
Any hints where to put the dictionaries for Aard2 0.45?
I do not like to use the Download folder for this as this is a place for temporary files.

Igor Tkach

unread,
Jun 11, 2021, 10:07:26 AM (yesterday) Jun 11
to aarddict
Hi Markus,

sorry to hear this stopped working for you. I thought 0.45 fixed finding/opening dictionaries from sd card, and it works for me on Galaxy S10 with Android 11 (the issue was detecting the correct path for removable sd card). Aard 2 targets the lowest Android API level allowed by the Play store, which still allows it unfettered access to most of the file system, so in theory everything should have worked as before.

--
You received this message because you are subscribed to the Google Groups "aarddict" group.
To unsubscribe from this group and stop receiving emails from it, send an email to aarddict+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/aarddict/742fc033-5404-49fd-95fb-38fa1d86a0b9n%40googlegroups.com.

MHBraun

unread,
12:11 PM (3 hours ago) 12:11 PM
to aarddict
Hi Igor,
this is not related to Aard 2. The problem is Android 11 which is far more locked down than earlier versions. And I am unable to change permissions to see some folders as the phone is not rooted.
Actually I found a workaround. The integrated app Smart Switch for transferring the data is not smart at all. It did not really transfer the data and accounts but some of the apps only. So you need to regenerate all that stuff manually. But it did one nice thing which was the creation of a folder called SdCardBackUp where it stored the Download folder of the (former) SDCard and some other stuff. This directory is accessible and rw. My Wikiaard folder just went there and Aard 2 does find the dictionaries.
Problem solved.
Reply all
Reply to author
Forward
0 new messages