Running SE with Google Chrome Issue

965 views
Skip to first unread message

Bozidar Dangubic

unread,
Dec 28, 2010, 4:03:51 PM12/28/10
to Selenium Users
All,

I am hoping someone can shed some light with the problem I am trying
to resolve. When running suite of tests with googlechrome it appears
as if Chrome is being launched in Incognito mode. The history is not
being tracked and looks like cookies are not accessible. The
application I am running against uses Google Gears and each time test
hits the page that uses Gears a popup comes up asking for trust
confirmation to allow Gears to run (on localhost). This has all the
symptoms of Chrome running in Incognito mode but from the look of the
browser it does not appear to be so.

Thanks!

Simon Stewart

unread,
Dec 30, 2010, 4:08:03 PM12/30/10
to seleniu...@googlegroups.com
Selenium is starting Chrome with a new clean profile each and every
time you use it. Selenium 1 does not offer a mechanism for overriding
this. Selenium 2's ChromeDriver, however, can use an example profile.
Assuming you know where your Chrome profile is located on disk and
you're using Java:

File profileDir = new File("location/on/disk");
ChromeProfile profile =
new ChromeProfile(profileDir);
WebDriver driver = new ChromeDriver(
profile, new ChromeExtension());

We should probably make it easier to create a ChromeDriver without
needing to know about the ChromeExtension, but that's the gist of it.

Simon

> --
> You received this message because you are subscribed to the Google Groups "Selenium Users" group.
> To post to this group, send email to seleniu...@googlegroups.com.
> To unsubscribe from this group, send email to selenium-user...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/selenium-users?hl=en.
>
>

Reply all
Reply to author
Forward
0 new messages