Add-in get error when start revit.

107 views
Skip to first unread message

Tran Ngoc Hien

unread,
May 23, 2016, 10:28:55 AM5/23/16
to RevitPythonShell
Hi @Daren, i deploy add-in by RPS, but when i start revit, the add-in get error through the add-in run good in Revit. Please see image below for detail


Daren Thomas

unread,
May 24, 2016, 8:26:47 AM5/24/16
to revitpyt...@googlegroups.com
this sounds like it could be a bug in how you deployed the script. i am very sorry: the error message really doesn't help you out here!

i wonder how we could better debug this... so... the error is going to be in the startup script somewhere... check all script dependencies?

On Mon, May 23, 2016 at 4:28 PM, Tran Ngoc Hien <hienng...@gmail.com> wrote:
Hi @Daren, i deploy add-in by RPS, but when i start revit, the add-in get error through the add-in run good in Revit. Please see image below for detail


--
You received this message because you are subscribed to the Google Groups "RevitPythonShell" group.
To unsubscribe from this group and stop receiving emails from it, send an email to revitpythonshe...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Callum

unread,
May 25, 2016, 7:13:49 AM5/25/16
to RevitPythonShell
Hi Tran - it would help if you could post 
- your code. Not the actual functions (in guessing you wont want to share those!), but the Revit + import lines etc. 
- how you deployed the script (xml file?)

Tran Ngoc Hien

unread,
May 25, 2016, 9:40:29 AM5/25/16
to RevitPythonShell
Hi Callum and Daren.
Actually i deploy this script with Revit python shell 2017 base on Daren source code, but maybe it doesn't work perfect.
I want to ask one question : the source file RevitApi.dll and RevitAPIUI.dll, we just get it from revit 2017 version ? And we build base on two *.dll files ?
Thanks.

Vào 18:13:49 UTC+7 Thứ Tư, ngày 25 tháng 5 năm 2016, Callum đã viết:

Daren Thomas

unread,
May 25, 2016, 10:24:55 AM5/25/16
to revitpyt...@googlegroups.com
Hi Tran,

so I gather you are using this in Revit 2017? Hm... I haven't tested that yet... You did a port? Would you like to send me a pull request?

Also, you never need to deploy RevitAPI.dll and RevitAPIUI.dll - they are part of Revit and will just be there when your script needs them!

"And we build base on two *.dll files?" - I don't understand what you mean.

Best, Daren

Tran Ngoc Hien

unread,
May 25, 2016, 12:44:19 PM5/25/16
to RevitPythonShell
I mean i build version Revit python shell 2017 base on your source . I just copy two dll : RevitAPI.dll and RevitAPIUI.dll 2017 and build them with Visual Studio.
So how i make port for Revit 2017.
Thanks.


Vào 21:24:55 UTC+7 Thứ Tư, ngày 25 tháng 5 năm 2016, Daren Thomas đã viết:

Daren Thomas

unread,
May 25, 2016, 2:58:09 PM5/25/16
to revitpyt...@googlegroups.com
did the same addin work when deployed with revit 2016?

Tran Ngoc Hien

unread,
May 25, 2016, 10:27:37 PM5/25/16
to RevitPythonShell
Yes, my add-in work perfect in revit 2016. I don't know the way i build revit python shell 2017 is right or not ?
I copy two dll from revit 2017 version and add to references to build for revit python shell 2017.
What does mean "port" ? I'm not clear about that.
Thanks


Vào 01:58:09 UTC+7 Thứ Năm, ngày 26 tháng 5 năm 2016, Daren Thomas đã viết:
To unsubscribe from this group and stop receiving emails from it, send an email to revitpythonshell+unsubscribe@googlegroups.com.

Daren Thomas

unread,
May 26, 2016, 3:01:00 AM5/26/16
to revitpyt...@googlegroups.com
Hi Tran,

basically, the program is tested to run on 2016 - the "port" means moving the codebase to a new system (either OS or, in this case, new host application)

we still have some testing to do, i guess!

Best,
Daren

alessand...@gmail.com

unread,
Jan 16, 2018, 8:17:13 AM1/16/18
to RevitPythonShell
Hi there, I was reading all those posts about deploying a revit addin from RPS but still without success.
I have an addin for 2017 (as far as I understood, deploying does not work in 2017 because I run into this error?). So I installed the RPS in 2016 (adjusting dll and addin file) now I can deploy the addin but once I start it the following error occurs



I deinstalled RPS addin but does not change anything.
Any help would be great, thanks in advance!
To unsubscribe from this group and stop receiving emails from it, send an email to revitpythonshell+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages