RSWAT pyrenees queries

47 views
Skip to first unread message

Arantxa Ortiz Elorza

unread,
Feb 27, 2024, 11:10:29 AMFeb 27
to R-SWAT
Dear Dr. Nguyen:

I am Arantxa Ortiz PhD candidate at IPE - CSIC (Spanish national research council). I have read carefully your useful articles on hydrological modeling using SWAT.

As part of my thesis, I am also using SWAT+ in catchments located in the Spanish Pyrenees. I have already created my hydrological model and now I am trying to calibrate it using R-SWAT. Given your expertise in this matter and being the main developer of this tool, I have a number of queries I would like to discuss with you:


+ I cannot declare individual HRUs, in the parameter sampling section. I followed the tutorial and so on, but after running the model, all the objective function values remain constant. I had the same problem when I tried to do with all the HRUs, but after reading the R-SWAT google group, I figured out that it was because in the file.cio file was not prompted the calibration.cal file (there was a Null value). I have changed it that and it worked for all the HRUs, but when trying to select independent HRUs it is not working anymore. Any help on this point?. I attach you some screenshots (Figure 1 and 2).



+ Regardless previous point, if I run the model using all HRUs I get extremely low NSE values (in the order of -1). However, if I open the channel_sd_mon file with a text editor and I compute/plot NSE values, I can compare the observed and computed NSE values and they are much better (NSE values c.a. 0.77). Any help on this matter?. See attached, the output from RSWAT with extremely NSE low values and resulting plot with the computed NSE by myself (Figure 3 and 4).


Thanks a lot and hope to keep posted.

Kind regards,

Arantxa

Tam Nguyen

unread,
Feb 28, 2024, 10:48:27 AMFeb 28
to R-SWAT
SWAT+ cannot run with parameters that you define even when I change to object to "All". Here the issue is about SWAT+ because when I run SWAT+ directly (without using RSWAT) in the txtinout folder with the attached parameter file there is an issue (attached figure). Might be you can post this question in SWAT+
Unbenannt.png
calibration.cal
Reply all
Reply to author
Forward
0 new messages