Issue with NetMapper installation on MacOS 12.1

Skip to first unread message

Yurun Tian

Jan 31, 2022, 4:48:26 PM1/31/22
to ORA Google Group

I am trying to install this version of NetMapper

I followed commands from a document (PDF attached): 
$chmod +x*
$sudo xattr -rds
$sudo spctl --master-disable

However, I got an error with log file attached.

Anyone has any idea how to solve this issue?

Thanks a lot!

Eric Malloy

Jan 31, 2022, 5:19:44 PM1/31/22
There has recently been a change the mac installer that will hopefully will fix this issue.  Rick has it available. 

Computational Analysis of Social and Organizational Systems (CASOS)
The Institute for Software Research, Department of Computer Science
Carnegie Mellon University, Pittsburgh, PA, USA
You received this message because you are subscribed to the Google Groups "ORA Google Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit

Yurun Tian

Jan 31, 2022, 6:39:02 PM1/31/22
to ORA Google Group
Thank you very much for replying, Eric.

I think this one that I have is the one you are talking about. 
Rick sent it to me on Jan 25. But it still doesn't work for me.
Still got the error as the log.

I also have tried all the previous versions from this link:
Unfortunately, none of them work for me.

Not sure anything else that I can try?

Eric Malloy

Jan 31, 2022, 7:11:48 PM1/31/22
The latest one should  not require you to change anything from the command line if I am not mistake.  You should be able to double click, it will give you a warning but install.  If that doesn't work then try...

chmod -R 777 on
xattr -rd ./
codesign --force --deep --sign - ./

Yurun Tian

Feb 1, 2022, 3:25:34 PM2/1/22
Hi Eric,

Thanks for the tips. 

However, it is still not working.

I tried rm -r everything in my Download folder, redownloaded, then double clicked to unzip the, then double clicked NetMapper, it gives me the error in log1.txt (attached).

Then I removed everything and re-downloaded the zip file from dropbox again, unzip, and I used the command lines you sent, then double clicked on the NetMapper again, it gives me the error in log2.txt(attached).

Not sure what the problem is.
Do you have any other suggestions?
Or would it be possible that I have a zoom call?


Yurun Tian
Graduate Student
Carnegie Mellon University

Reply all
Reply to author
0 new messages