Toaststunt

5 views
Skip to first unread message

Shan Hollen

unread,
Dec 12, 2019, 8:39:07 AM12/12/19
to MOO-...@googlegroups.com
I upgraded to the newest version of toaststunt server and when I run it I get this...

Dec 12 08:33:36: LISTEN: #0 now listening on 0.0.0.0 [0.0.0.0], port 6777
Dec 12 08:33:36: LISTEN: #0 now listening on :: [::], port 6777

...and can't connect.

Any idea what's going on?

Thanks!

-Shan

Tristan Bussiere

unread,
Dec 12, 2019, 8:54:31 AM12/12/19
to MOO-...@googlegroups.com
Hello,

Some obvious questions to get out of the way:

Are you attempting to connect via IPv6?

Is it possible the connection is being established, but you aren't receiving any output?

Have you tried to manually specify a listening address using the -4 or -6 switches for IPv4 and IPv6, respectively?

If you'd like some live discussion regarding issues with ToastStunt, the best place to reach developers (and Lisdude himself...) is often to use the 'toaststunt' channel on ChatMUD (chatmud.com 7777).

Sorry I can't be more helpful! Hopefully we can figure it out.



--
You received this message because you are subscribed to the Google Groups "MOO Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to MOO-talk+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/MOO-talk/FAACD2F7-6B2B-4DDB-B3E8-16FC22A204ED%40comcast.net.

Todd Sundsted

unread,
Dec 12, 2019, 9:13:39 AM12/12/19
to MOO Talk
Unrelated to the thread, but I just discovered toaststunt. This is brilliant!

Todd

Shan Hollen

unread,
Dec 12, 2019, 3:19:11 PM12/12/19
to MOO-...@googlegroups.com
Not trying to use iPv6.

Previous versions don't give th IP when you start a db, just the port....

Dec 12 15:07:18: LISTEN: #0 now listening on port 6777

The new version provides the IP as well...

Dec 12 14:57:35: LISTEN: #0 now listening on 0.0.0.0 [0.0.0.0], port 7777
Dec 12 14:57:35: LISTEN: #0 now listening on :: [::], port 7777

Not sure why it does it twice, but the second time it's like the IP doesn't exist.

I emailed listdude.

Thanks!

-Shan

PS: My db runs fine on the older version of the serverr.

lisdude

unread,
Dec 12, 2019, 3:42:28 PM12/12/19
to MOO Talk
It's showing twice because the first time it's attempting to resolve the hostname and the second time is the numeric IP. Depending on your configuration, it could show something like:

Dec 12 14:26:51: LISTEN: #0 now listening on chewy.toastsoft.net [127.0.0.1], port 8888

The second line is IPv6. "::" is the "0.0.0.0" of the IPv6 world. It's essentially saying that it will listen on any IPv6 interface.

I replied to your other e-mail with some wild ramblings that probably aren't very helpful, but I'm sure eventually we'll figure it out!

Tristan Bussiere

unread,
Dec 12, 2019, 3:57:46 PM12/12/19
to MOO Talk
IPv6 support was added in the last month and the network stack was overhauled in a few key areas. The second listen line you're seeing is the MOO listening with IPv6. :: Is the IPv6 version of 0.0.0.0. 0.0.0.0 typically translates to "any (or all) IP addresses available".

Have you reviewed netstat -tulpn | grep <port>? Does your MOO appear there? What operating system are you running the server on, and does telnet localhost port from the serving machine work?

Finally, you might try:
./moo yourmoodatabase.db yourmoodatabase.db -4 <your public IP> <yourport>
And see if that yields differing results. 

Tristan Bussiere

unread,
Dec 12, 2019, 4:07:12 PM12/12/19
to lisdude, MOO Talk
...oh. That's what I get for leaving my half-written message open for half an hour. Carry on.

Shan Hollen

unread,
Dec 12, 2019, 4:40:59 PM12/12/19
to MOO-...@googlegroups.com
I started my db explicitly using iPv4...

Dec 12 15:58:17: LISTEN: #0 now listening on localhost [127.0.0.1], port 7777
Dec 12 15:58:17: LISTEN: #0 now listening on :: [::], port 7777
Dec 12 15:58:56: ACCEPT: #-2 on :: [::], port 7777 from localhost [::1], port 53442

...but it looks like it's defaulting to iPv6.

I was connecting via Savitar to a server running macOS High Sierra. I tried connecting via telnet from the terminal and it connected but that's it from the client side...

    Shans-MacBook-Pro:sf shanhollen$ telnet -4 localhost 7777
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.

...but that's it, like $do_login_command never gets run.

The log shows that I connect from both Savitar and telnet, and then when I disconnect...

    Dec 12 15:58:56: ACCEPT: #-2 on :: [::], port 7777 from localhost [::1], port 53442
    Dec 12 15:59:00: CLIENT DISCONNECTED: #-2 on localhost

I don't know if this means anything  but when I make the makefile I get...

    -- Looking for accept4 - not found

Thanks for all your help! I learn a ton from you guys.

-Shan

Tristan Bussiere

unread,
Dec 12, 2019, 5:30:08 PM12/12/19
to Shan Hollen, MOO Talk
Aha! Due to the way proxy detection works, if you're connecting to your MOO from localhost, you won't see the login screen at all unless you press enter, type 'welcome', etc. This is in the event that a proxied IP might be redlisted from your MOO; displaying the login screen prior to taking action against a proxied IP is inconvenient at best, and a bad experience all around at worst. If it bothers you, you can disable HAProxy rewriting once you've logged into your MOO as a wizard with:

@prop $server_options.proxy_rewrite 0
;load_server_options()

Otherwise, as long as you're connecting from localhost, the login screen will be suppressed (but regular commands will work as expected).

The -4 switch only adjusts the v4 interface that your MOO listens on. You can force the MOO to not listen on IPv6 at all by doing something like: ./moo yourmoodatabase.db yourmoodatabase.db -6 0 7777

Littlefield, Tyler

unread,
Dec 14, 2019, 7:47:43 PM12/14/19
to Tristan Bussiere, MOO-...@googlegroups.com
Does netstat or lsof show the port in a listening state? Do you have a firewall preventing inbound connections?

Shan Hollen

unread,
Dec 14, 2019, 9:26:07 PM12/14/19
to MOO-...@googlegroups.com
Actually, the proxy filter is the problem. Setting server_options_proxy_rewrite = 0 doesn't turn it off, so I set my IP manually and use that instead of locaalhost. I forwarded a couple of ports and looked up my public IP. That works too, both iPv4 and iPv6.

Reply all
Reply to author
Forward
0 new messages