Issue when compiling gamma moo

15 views
Skip to first unread message

Haily Merry

unread,
Nov 26, 2021, 3:02:39 PM11/26/21
to moo-...@googlegroups.com
Hey,

I have no idea what any of this means, but I was wondering if anyone
here might. I get this after typing make. Could I possibly be missing
some dependancy or other? I've tried a few different versions with the
same result, so I don't think this is a problem with a specific version.

collect2: error: ld returned 1 exit status
 make: *** [Makefile:96: moo] Error 1

Thanks in advance.

Wolfgang Faust

unread,
Nov 26, 2021, 8:48:12 PM11/26/21
to Haily Merry, MOO Talk
No idea about gamma specifically, but as a general troubleshooting step: are those two lines the *only* output from make? I'd expect them to be symptomatic of some other error that would appear a bit earlier in the output. (Running make a second time usually produces a lot less output than the first run, since it doesn't redo all of the successful steps, which may make the problem easier to see.)

--
You received this message because you are subscribed to the Google Groups "MOO Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to MOO-talk+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/MOO-talk/9ebbe5f6-12f3-c0d7-4434-918842bdb49c%40aol.com.

Littlefield, Tyler

unread,
Nov 26, 2021, 10:54:48 PM11/26/21
to Haily Merry, moo-...@googlegroups.com
Hello:

Is there a reason you're compiling gamma specifically? There are newer
less bug-ridden versions of the MOO server out there:

https://github.com/lisdude/toaststunt

for example.

If you want help with your compilation issue, you'll need to scroll
farther up. that means that a library or symbol couldn't be found. We
will need a few lines above that to help.

Also it would help to include which Linux distro you're running.

Luke Dashjr

unread,
Nov 26, 2021, 11:23:56 PM11/26/21
to MOO-...@googlegroups.com, Littlefield, Tyler, Haily Merry
Why the FUD? GammaMOO is stable, and has no reported open bugs.

I'd even bet anything stunt-based has more bugs.
Reply all
Reply to author
Forward
0 new messages