Re: JCVSReport on Windows: ScmAccessException

0 views
Skip to first unread message

David James

unread,
Apr 2, 2005, 10:30:21 PM4/2/05
to Qian Zhu, JCVSR...@googlegroups.com
Hi Qian,

On Apr 2, 2005 8:54 PM, Qian Zhu <mszh...@gmail.com> wrote:
> Good job!
Thanks! Good to hear from you.

> We have a question. We were trying to develop locally without direct
> access to cvs repository. As you mentioned in your installation
> instruction, we can specify a local copy of the RAW cvs repo in the
> config file. we tried this but still failed to run. (We were able to
> run on cdf machines).
>
> The error msg is:
> net.sf.bloof.scm.ScmAccessException: Could not access SCM system.
> Please check cvs repository location and cvsmodule in the configuration file.
>
> the config variables are:
> cvsroot=/Volumes/Data/Eclipse/workspace/408project
> cvsmodule=test_cvsrepository

You're using Windows, right? If so, you'll need to specify a full
cygwin-style path. If your CVS repository is installed on your "C"
drive, then you should specify the path as
"/cygdrive/c/Volumes/Data/Eclipse/workspace/408project".

If it's still not working, then try accessing your repository from the
command prompt using Cygwin CVS. On Windows, JCVSReport will only work
if Cygwin CVS is installed and is on your path.

NOTE: Bloof uses colons as a record separator in paths, so it does not
accept paths that contain colons. Thus, JCVSReport will only work with
the paths that use the "/cygdrive/c" syntax.

Cheers,

David

P.S. Thanks for including your config file in this email -- it made it
really easy to diagnose your problem.

--
http://www.cs.toronto.edu/~james
Reply all
Reply to author
Forward
0 new messages