Re: CSC408 Group 11: Using pmd 3.0

1 view
Skip to first unread message

David James

unread,
Mar 29, 2005, 12:19:28 PM3/29/05
to Matthew D'Andrea, JCVSR...@googlegroups.com
On Tue, 29 Mar 2005 12:07:33 -0500, Matthew D'Andrea
<matt.d...@gmail.com> wrote:
> I want to replace pmd 2.3 with the new version that was released
> (quite recently) pmd 3.0.
> I have replaced the pmd-2.3.jar with pmd-3.0.jar in the lib directory
> under 408project
> as well as all the other jars that pmd 3.0 requires.
> However, it still seems like it's running pmd 2.3 (I know this because
> they use different syntax for the Java Syntax Tree and nothing is
> showing up with the new syntax).
> Any ideas what's going on?
The JCVSReport.jar file contains PMD 2.3. If you want to use PMD 3.0
instead, then you will need to put the PMD 3.0 JAR *before* the
JCVSReport.jar file in your classpath.

If you are using the JCVSReport shell script to launch JCVSReport,
then you'll want to edit the classpath contained in that file to
contain your new JAR file.

Cheers,

David

--
http://www.cs.toronto.edu/~james
Reply all
Reply to author
Forward
0 new messages