Drag and Drop with Active groups not working

39 views
Skip to first unread message

Gary Marston

unread,
Dec 2, 2016, 11:15:08 AM12/2/16
to InterSystems: Zen Community
Hi,

   I'm trying to use drag and drop from a dynaTree to a dynaGrid that are buried in layers of active groups, (VH and plain groups as well). I have tried calling a client method using onbeforedrag, onafterdrag & ondrag wihtout success. It seems my event handler is not called regardless of what I do or how I have the XData contents configured. I have been able to do this in ZEN pages that DO NOT use active groups.

   I have dragAndDrop = true in the page element and dragEnabled = true on the tree control and the appropriate ZLM functions setup in onloadHandler and onlayoutHandler as recommended for active groups

Here is what I have tried so far;
  •    I have tried dragEnabled and dropEnabled set to true in all active group parent nodes of my tree control of the page without success
  •    I have tried not setting dragEnabled and dropEnabled in all of my parent active groups again with out success
  •    The onclick event for the tree control works fine and my event handler for it gets called as expected.
  •    In my event handler for the drag operation I have a console.log to tell me the method was called and a return value of true and nothing else. Even tried calling some of the ZLM functions without success in the event handler.
  •    I never see the console.log message in my handler regardless of what I try. So it appears the handler method is not being called at all

   I'm sure I have missed some setup or configuration on the ZEN page that allows this to work. I have other pages that do not use active groups and they work as expected and I can drag data from a tree control all day long without issue. I am also able to get the drag and drop examples in the Sample namespace to work, but here again they do not use active groups.

   I would appreciate it if anyone has any ides/suggestions or examples on how to make drag and drop work with active groups.

Thanks
Gary Marston


Gary Marston

unread,
Dec 5, 2016, 8:42:11 AM12/5/16
to InterSystems: Zen Community
Update on this issue,

   I found the reason this was not working for me. I had a misplaced zenPage.refreshContents() call in the onlayoutHandler method for the page. Once that was removed drag and drop began working as expected.

Gary Marston
Reply all
Reply to author
Forward
0 new messages