Error: Malformed HTTP header: empty content

35 views
Skip to first unread message

KM

unread,
Sep 1, 2009, 12:57:33 PM9/1/09
to Google Search Appliance/Google Mini - Google Search Appliance/Google Mini
Hello,

I am seeing this error after an upgrade to version 5.x.G32P1:

Error: Malformed HTTP header: empty content.

For this and its sub URLs http://www.gwu.edu/~psycdept/

Any ideas what might be causing it? Or how I can go about trouble
shooting it? Firefox's Live HTTP Header plugin appears to have no
trouble with the page's headers. Also, under "Network Settings" the
appliance returns an "OK" for this and its sub URLs. I looked in the
web server logs, and see "200" responses for these pages.

I looked at this thread:
http://groups.google.com/group/Google-Search-Appliance-Help/browse_thread/thread/123115bac1e8c5d1
but I am unsure if the problem is the same or related.

Thanks!

KM

KM

unread,
Sep 1, 2009, 1:58:15 PM9/1/09
to Google Search Appliance/Google Mini - Google Search Appliance/Google Mini
Was able to resolve this issue by following directions here:

https://support.google.com/enterprise/doc/gsa/relnotes/relnotes_600G32_O_S.html
which said:

"1397670 - URLs that are served with gzip compression will show in
Crawl Diagnostics as "Error: Malformed HTTP header: empty content.".
Workaround: insert a header 'Accept-Encoding: identity' under Crawl
and Index > HTTP Headers."

KM

JMarkham

unread,
Sep 1, 2009, 2:28:43 PM9/1/09
to Google Search Appliance/Google Mini - Google Search Appliance/Google Mini
We just ran into this on 6.0. I have found that the more rigorous
"Accept-Encoding: *;q=0" also works quite well.

Since this has been an issue for a while, judging from this thread
from March, http://groups.google.com/group/Google-Search-Appliance-Help/browse_thread/thread/123115bac1e8c5d1,
any clues on when this might be dealt with?

Jeff

Reply all
Reply to author
Forward
0 new messages