[Core-iSCSI]: Fixed <= v2.6.24 support in SVN

22 views
Skip to first unread message

Nicholas A. Bellinger

unread,
Oct 15, 2008, 4:45:58 AM10/15/08
to Core-iSCSI, Linux-iSCSI.org Target Dev
After attempting to run Core-iSCSI Initiator (iscsi_initiator_mod)
recently on the v2.6.24, and started running into problems with the
recently changes for making struct class_device legacy in >= v2.6.25.

There ended up being a couple of missing kobject_put()s for <= v2.6.24
support in iscsi_initiator_sysfs.c. The patch has been commited as r401
in http://linux-iscsi.org/svn/branches/coreiscsi-1.6.2/ and is working
on v2.6.26.x, v2.6.25.x, v2.6.24.x and v2.6.21.

Thanks!

--nab

Reply all
Reply to author
Forward
0 new messages