Problem with barcode api

Showing 1-22 of 22 messages
Problem with barcode api Jagannadh 8/23/10 2:25 AM
Hello,

I have created a simple barcode recognizer application by modifying
the api you have provided.
It runs fine on the blackberry 8900 simulator. But when I installed it
on the device(tried on 9000 and 8310), it is giving the error
"uninitialized constant BarcodeRecognizerController::Barcode" in the
log.
It is also not running on android and wm simulators.

Plz help me with this.

Thank You.
RE: [rhomobile] Problem with barcode api evgenyv 8/23/10 1:25 PM
Post your build.yml pls

About blackberry: you should build app using jde for your device, so if
device is 4.6.1 you should specify it in build.yml

Uinstall app from device
Run 'rake clean:bb'
rake device:bb:production

And install again

Try system-api-samples - it does work on my device

 

Hello,

Thank You.

--
You received this message because you are subscribed to the Google Groups
"rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to
rhomobile+...@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/rhomobile?hl=en.

unk...@googlegroups.com 8/23/10 10:12 PM <This message has been deleted.>
Re: Problem with barcode api Jagannadh 8/23/10 10:26 PM
sdk: "D:\mobility\rhomobile2.0\rhodes"
sdkversion: 2.0.3
name: barcoderecognizer
version: 1.0
vendor: rhomobile
build: debug
bbver: 4.6
wmsdk: Windows Mobile 6 Professional SDK (ARMV4I)
applog: rholog.txt
iphone:
  provisionprofile:
  sdk: iphonesimulator3.0
  entitlements:
  codesignidentity:
  configuration: Debug
wm:
  extensions: ["barcode"]
bb:
  extensions: ["barcode"]
android:
  extensions: ["barcode"]

extensions: ["barcode"]

capabilities:
- camera

Thanks for the reply.This is my build.yml file.
where should i specify 4.6.1??
RE: [rhomobile] Re: Problem with barcode api evgenyv 8/24/10 1:46 AM
What is your device OS version?

-----Original Message-----
From: rhom...@googlegroups.com [mailto:rhom...@googlegroups.com] On
Behalf Of Jagannadh

extensions: ["barcode"]

capabilities:
- camera

--


You received this message because you are subscribed to the Google Groups
"rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to
rhomobile+...@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/rhomobile?hl=en.

Re: Problem with barcode api Jagannadh 8/24/10 3:32 AM
4.6.0.303 (blackberry 9000)
RE: [rhomobile] Re: Problem with barcode api evgenyv 8/24/10 3:51 AM
So you have to use 4.6
Try run rake clean:bb
rake device:bb:production

And uninstall old app from phone

If it will not helo, post me RhoBundle.jar from rhobundle folder

-----Original Message-----
From: rhom...@googlegroups.com [mailto:rhom...@googlegroups.com] On
Behalf Of Jagannadh
Sent: Tuesday, August 24, 2010 2:33 PM
To: rhomobile
Subject: [rhomobile] Re: Problem with barcode api

4.6.0.303 (blackberry 9000)

--
You received this message because you are subscribed to the Google Groups
"rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to
rhomobile+...@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/rhomobile?hl=en.

Re: Problem with barcode api Jagannadh 8/24/10 4:49 AM

I have sent you the rrhobundle.jar file through mail
Re: Problem with barcode api Jagannadh 8/25/10 4:00 AM
Hello,

It's working fine on my 8900 after doing rake clean:bb and
reinstalling the app.
But when I run the same app on wm simulator it is giving the following
error

5>Build started: Project: sqlite3, Configuration: Release|Windows
Mobile 6 Profe
ssional SDK (ARMV4I)
5>sqlite3 - up-to-date
7>Build started: Project: tcmalloc, Configuration: Release|Windows
Mobile 6 Prof
essional SDK (ARMV4I)
7>tcmalloc - up-to-date
2>Build started: Project: syncengine, Configuration: Release|Windows
Mobile 6 Pr
ofessional SDK (ARMV4I)
2>syncengine - up-to-date
9>Build started: Project: RhoLib, Configuration: Release|Windows
Mobile 6 Profes
sional SDK (ARMV4I)
9>RhoLib - up-to-date
1>Build started: Project: rubylib, Configuration: Release|Windows
Mobile 6 Profe
ssional SDK (ARMV4I)
1>Compiling...
1>extensions.c
1>Creating library...
1>Build log was saved at "file://d:\mobility\rhomobile2.0\rhodes
\platform\wm\bin
\Windows Mobile 6 Professional SDK (ARMV4I)\rubylib\Release
\BuildLog.htm"
1>rubylib - 0 error(s), 0 warning(s)
11>Build started: Project: rhodes, Configuration: Release|Windows
Mobile 6 Profe
ssional SDK (ARMV4I)
11>Linking...
11>rubylib.lib(extensions.obj) : error LNK2019: unresolved external
symbol Init_
Barcode referenced in function Init_Extensions
11>..\bin\Windows Mobile 6 Professional SDK (ARMV4I)\rhodes\Release/
rhodes.exe :
 fatal error LNK1120: 1 unresolved externals
11>Build log was saved at "file://d:\mobility\rhomobile2.0\rhodes
\platform\wm\bi
n\Windows Mobile 6 Professional SDK (ARMV4I)\rhodes\Release
\BuildLog.htm"
11>rhodes - 2 error(s), 0 warning(s)

Build complete: 5 Projects succeeded, 1 Projects failed, 0 Projects
skipped

Error building

When i tried to run it on android simulator, it is giving the error
Error compiling java code
RE: [rhomobile] Re: Problem with barcode api evgenyv 8/25/10 9:47 AM
Try call rake clean:wm

-----Original Message-----
From: rhom...@googlegroups.com [mailto:rhom...@googlegroups.com] On
Behalf Of Jagannadh
Sent: Wednesday, August 25, 2010 3:00 PM
To: rhomobile
Subject: [rhomobile] Re: Problem with barcode api

Hello,

Error building

--


You received this message because you are subscribed to the Google Groups
"rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to
rhomobile+...@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/rhomobile?hl=en.

Re: Problem with barcode api Jagannadh 8/25/10 9:35 PM
Hello,

I have tried that both with wm and android it is giving the same
error.

Thank you.
Re: Problem with barcode api Jagannadh 8/26/10 12:22 AM
Hello,

I have another doubt. after reading the bar code, if we close the
application, then the device gives a screen showing the picture taken
and then if we press back button,
it goes back to the camera. It is the same case with the image and
barcode apps in the sample api provided.

Is there anyway to close the camera as soon as we take a picture
return to the index page?

And also is it possible not to save the images taken in the db folder
and memory card?

My camera_callback doesnot include Image.new() or image.save. Still
for every image taken, 2 copies are stored, one in memory card and one
in db folder.

Thank you.
RE: [rhomobile] Re: Problem with barcode api evgenyv 8/26/10 5:45 AM
Just tested rhodes master branch with system-api-samples on wm and android
Both works fine

Edit build.yml:
Move
extensions: ["barcode"]

To iphone section, so each platform has this extension

Or delete extension from platforms and keep common one at the end of file

-----Original Message-----
From: rhom...@googlegroups.com [mailto:rhom...@googlegroups.com] On
Behalf Of Jagannadh
Sent: Thursday, August 26, 2010 8:35 AM
To: rhomobile
Subject: [rhomobile] Re: Problem with barcode api

Hello,

Thank you.

--


You received this message because you are subscribed to the Google Groups
"rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to
rhomobile+...@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/rhomobile?hl=en.

Re: Problem with barcode api Jagannadh 8/26/10 6:32 AM
Hello,

Thanks for the reply. I'll try that.
Please look at my next post regarding the files being saved even if
iam not asking it to.
Is there anyway we can delete the files from db-files and images
folder on memory card?

Thank you.
Re: Problem with barcode api Jagannadh 9/13/10 11:42 PM
Hello,

My barcode application is now running on BB and android but not on wm.
It is giving the following error.

11>Build started: Project: rhodes, Configuration: Release|Windows
Mobile 6 Profe
ssional SDK (ARMV4I)
11>Linking...
11>LINK : fatal error LNK1104: cannot open file 'Barcode.lib'
11>Build log was saved at "file://d:\rhodes_30Aug10\platform\wm\bin
Re: [rhomobile] Re: Problem with barcode api MOHUS (dmitrys@rhomobile.com) 9/14/10 5:20 AM
Are you added "barcode" to you extensions list in build.yml ?
Please send to me your build.yml file.

--
You received this message because you are subscribed to the Google Groups "rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to rhomobile+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rhomobile?hl=en.




--

Best regards,
  Dmitry A. Soldatenkov
  E-mail: dmi...@mail.com
  Skype: soldatenkoff


Re: Problem with barcode api Jagannadh 9/14/10 9:10 PM
This is my build.yml

sdk: "D:\rhodes_30Aug2010\rhodes"
sdkversion: 2.0.3
name: barcoderecognizer
version: 1.0
vendor: rhomobile
build: debug
bbver: 4.6
wmsdk: Windows Mobile 6 Professional SDK (ARMV4I)
applog: rholog.txt
iphone:
  provisionprofile:
  sdk: iphonesimulator3.0
  entitlements:
  codesignidentity:
  configuration: Debug

capabilities:
- camera

extensions: ["Barcode"]

wm:
  extensions: ["Barcode"]


First i tried without seperate extension for wm. Later i added it.
Re: [rhomobile] Re: Problem with barcode api MOHUS (dmitrys@rhomobile.com) 9/15/10 6:19 PM

I tryed your build.yml and do not have any problem.
Try to "rake clean:wm" and rebuild again



--
You received this message because you are subscribed to the Google Groups "rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to rhomobile+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rhomobile?hl=en.




--

Best regards,
  Dmitry A. Soldatenkov
  E-mail: dmi...@mail.com
  Skype: soldatenkoff


Re: Problem with barcode api Jagannadh 9/15/10 9:08 PM
I have tried that but getting the same error.

where can i find this barcode.lib file?
Re: [rhomobile] Re: Problem with barcode api MOHUS (dmitrys@rhomobile.com) 9/16/10 9:18 AM
During compilation Barcode lib file created in
rhodes\platform\wm\bin\Windows Mobile 6 Professional SDK (ARMV4I)\extensions\Barcode\Release\

And placed into main folder :
rhodes\platform\wm\bin\Windows Mobile 6 Professional SDK (ARMV4I)\rhodes\Release\

You can find Barcode build script (Rakefile) in  
rhodes\lib\extensions\barcode\ext\barcode\platform\wm\


On Thu, Sep 16, 2010 at 8:08 AM, Jagannadh <jagann...@gmail.com> wrote:
I have tried that but getting the same error.

where can i find this barcode.lib file?

--
You received this message because you are subscribed to the Google Groups "rhomobile" group.
To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to rhomobile+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rhomobile?hl=en.




--

Best regards,
  Dmitry A. Soldatenkov
  E-mail: dmi...@mail.com
  Skype: soldatenkoff


Re: Problem with barcode api Kawal 6/7/12 3:59 AM
Sorry for opening such a old post,I am working with rhodes3.2.2 and i am facing the same problem.
Can it be because of the any error in the modification of zbar library?
Can you send me that modified zbar-library that is working for you?
 
 
Thanks,
Kawal
RE: [rhomobile] Re: Problem with barcode api evgenyv 6/8/12 1:08 AM

Send me application sample to reproduce the issue.

Where you try to use Barcode ?

 

From: rhom...@googlegroups.com [mailto:rhom...@googlegroups.com] On Behalf Of Kawal
Sent: Thursday, June 07, 2012 3:00 PM
To: rhom...@googlegroups.com


Subject: [rhomobile] Re: Problem with barcode api

 

Sorry for opening such a old post,I am working with rhodes3.2.2 and i am facing the same problem.

--

You received this message because you are subscribed to the Google Groups "rhomobile" group.
To view this discussion on the web visit https://groups.google.com/d/msg/rhomobile/-/4HBLXd8syuwJ.

To post to this group, send email to rhom...@googlegroups.com.
To unsubscribe from this group, send email to rhomobile+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rhomobile?hl=en.

More topics »