ruby-2.0.0-preview1

Showing 1-2 of 2 messages
ruby-2.0.0-preview1 Jabari Zakiya 11/11/12 10:03 AM
I've seen announcements on release of Ruby 2.0.0-preview1

http://www.ruby-lang.org/en/community/ruby-core/
http://www.infoq.com/news/2012/11/ruby-20-preview1
https://blog.heroku.com/archives/2012/11/5/ruby-2-preview-on-heroku/

and even benchmarks on OS X using rvm to install it:

http://igor-alexandrov.github.com/blog/2012/11/05/yet-another-ruby-shootout/

but when I do  "rvm list known" on my Linux distro it doesn't show up and
won't install if I try to do it.

Is Ruby-2.0.0-preview1 available on rvm yet, and it so how do I install it on Linux?






Re: [rvm] ruby-2.0.0-preview1 D. Deryl Downey 11/11/12 10:07 AM

> but when I do  "rvm list known" on my Linux distro it doesn't show up and
> won't install if I try to do it.

A) did you rvm get stable && rvm list known

B) If you are using one of the packaged versions of rvm? If so, uninstall it and run:

curl -L https://get.rvm.io | bash -s stable

The distributions don't generally tend to keep the RVM packages up to date, and the RVM project does not support them, just an fyi.

> Is Ruby-2.0.0-preview1 available on rvm yet, and it so how do I install it on Linux?

RVM has supported installing 2.0.0-preview1 since the day it was released. The fact you don't' see it generally means you're either not keeping your dvm up to date, or you installed a package from your Linux distribution, something RVM does not support.