Installing rubies failes retrieving rubygems-1.8.25

Showing 1-5 of 5 messages
Installing rubies failes retrieving rubygems-1.8.25 Brendan Miller 1/24/13 10:34 PM
I get this error installing ruby via RVM:

"
Retrieving rubygems-1.8.25
There is no checksum for 'http://production.cf.rubygems.org/rubygems/rubygems-1.8.25.tgz' or 'rubygems-1.8.25.tgz', it's not possible to validate it.
If you wish to continue with unverified download add '--verify-downloads 1' after the command.

There has been an error while trying to fetch the source. 
Halting the installation.
"

If I go to the rubygems website, the most recent version they mention is 1.8.24. Why is RVM trying to install a version of a package that doesn't exist?

I'm doing a fresh install on Ubuntu 12.04. Running "rvm rubygems current" retriggers the same error.

Brendan
Re: Installing rubies failes retrieving rubygems-1.8.25 Ryan Hattam 1/25/13 1:19 AM
I'm getting the same "error"!

Since I first started looking, its now appearing here: http://rubygems.org/gems/rubygems-update/versions/1.8.25, but it wasn't earlier. The 404 continues though, its not available as the tgz RVM is looking for.

Did RVM jump the gun? How can I force it to install with 1.8.24??

Would seem I picked a bad time for 'rvm implode'...

Ryans-MacBook-Pro-2:~ ryan$ rvm reinstall 1.9.3 --verify-downloads 1
Removing /Users/ryan/.rvm/src/ruby-1.9.3-p374...
Removing /Users/ryan/.rvm/rubies/ruby-1.9.3-p374...
Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.8/x86_64/ruby-1.9.3-p374.
Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies.
Fetching yaml-0.1.4.tar.gz to /Users/ryan/.rvm/archives
Extracting yaml to /Users/ryan/.rvm/src/yaml-0.1.4
Configuring yaml in /Users/ryan/.rvm/src/yaml-0.1.4.
Compiling yaml in /Users/ryan/.rvm/src/yaml-0.1.4.
Installing yaml to /Users/ryan/.rvm/usr
Installing Ruby from source to: /Users/ryan/.rvm/rubies/ruby-1.9.3-p374, this may take a while depending on your cpu(s)...
ruby-1.9.3-p374 - #downloading ruby-1.9.3-p374, this may take a while depending on your connection...
ruby-1.9.3-p374 - #extracting ruby-1.9.3-p374 to /Users/ryan/.rvm/src/ruby-1.9.3-p374
ruby-1.9.3-p374 - #extracted to /Users/ryan/.rvm/src/ruby-1.9.3-p374
ruby-1.9.3-p374 - #configuring
ruby-1.9.3-p374 - #compiling
ruby-1.9.3-p374 - #installing 
Retrieving rubygems-1.8.25

curl: (22) The requested URL returned error: 404
Trying ftp:// URL instead.

curl: (7) couldn't connect to host
There was an error(7), please check /Users/ryan/.rvm/log//*.log
There has been an error while trying to fetch the source. 
Halting the installation.


Re: Installing rubies failes retrieving rubygems-1.8.25 mpapis 1/25/13 3:25 AM
A temporary fix is to:

     echo rubygems_version=1.8.24 >> $rvm_path/user/db

For permament fix please open a ticket for rvm:

- https://github.com/wayneeseguin/rvm/issues
Re: Installing rubies failes retrieving rubygems-1.8.25 Johannes Jacubeit 1/25/13 10:59 AM
following also works:
rvm_rubygems_version=1.8.24 rvm install ruby
Re: Installing rubies failes retrieving rubygems-1.8.25 Keating Wang 2/19/13 9:40 PM
Great....with this command, I reinstall ruby2.0.0-rc1 successfully.

在 2013年1月26日星期六UTC+8上午2时59分53秒,Johannes Jacubeit写道: