Install Redis 2.6.0-rc1 meet a error

Showing 1-5 of 5 messages
Install Redis 2.6.0-rc1 meet a error alex 4/30/12 9:11 PM
Hi all, I met a problem when I'm try to install Redis 2.6.0-rc1 .


make PREFIX=/home/alex/src/redis-2.6.0-rc1/release install
zmalloc.o: In function `zmalloc_used_memory':
/home/alex/src/redis-2.6.0-rc1/src/zmalloc.c:221: undefined reference to `__sync_add_and_fetch_4'

Re: Install Redis 2.6.0-rc1 meet a error Pieter Noordhuis 4/30/12 9:42 PM
Which OS are you trying to compile it on?

Thanks,
Pieter
> --
> You received this message because you are subscribed to the Google Groups
> "Redis DB" group.
> To view this discussion on the web visit
> https://groups.google.com/d/msg/redis-db/-/9MxvnhTW_yEJ.
> To post to this group, send email to redi...@googlegroups.com.
> To unsubscribe from this group, send email to
> redis-db+u...@googlegroups.com.
> For more options, visit this group at
> http://groups.google.com/group/redis-db?hl=en.
Re: Install Redis 2.6.0-rc1 meet a error Pieter Noordhuis 4/30/12 9:43 PM
I almost forgot: also other environment information such as compiler
version (gcc --version) and machine architecture are relevant.

Thanks,
Pieter
Re: Install Redis 2.6.0-rc1 meet a error alex 4/30/12 10:14 PM
Sorry, here is the environment information :

gcc --version
gcc (GCC) 4.1.2 20070115 (prerelease) (SUSE Linux)
Copyright (C) 2006 Free Software Foundation, Inc.

uname -a
Linux app_platform_dev 2.6.16.60-0.21-domU-101126 #1 SMP Fri Nov 26 11:56:53 CST 2010 i686 i686 i386 GNU/Linux
Re: Install Redis 2.6.0-rc1 meet a error alex 5/1/12 12:30 AM
I think I got the problem, add this 
OPT=-O2 -march=i686
to file src/.make-settings.

Here is a article about this question

thanks Pieter

在 2012年5月1日星期二UTC+8下午12时11分43秒,alex写道: