Ruby Driver 1.7.0.rc0 Released

Showing 1-3 of 3 messages
Ruby Driver 1.7.0.rc0 Released Tyler Brock 8/20/12 4:06 PM
The MongoDB Ruby driver version 1.7.0.rc0 has been released.

***
This is a release candidate for 1.7.0, has significant changes, and should only only be used for testing at this point in time.
***

It can be installed via rubygems:
"gem install mongo"
"gem install bson_ext" (for the optional extensions)

Or updated via "gem update"

Highlights:
* Added testing and full support for MongoDB 2.1 & 2.2
* Added Aggregation Framework helper method
* Added support for Mongos high availability
* Modified and added new read preferences (details in documentation)
* Added support for data center awareness (tag_sets)
* Fixed bug which attempted to close cursors on wrong replica set member

Please Note: Behavior of some read preference modes have changed for version 1.7.0:

:secondary_preferred mode is now used to prefer reads from secondary members (before this was the behavior of :secondary).
:secondary_only mode (which only allowed reads from secondaries) is now called :secondary.

As always, please report any and all issues on Jira.

Re: Ruby Driver 1.7.0.rc0 Released Tyler Brock 8/20/12 5:20 PM
It should be noted that the latest stable release gem is still installed when running "gem install mongo" and that the pre-release gems are installed via the following commands:

"gem install mongo --pre"
"gem install bson --pre"
"gem install bson_ext --pre"

-Tyler

Re: Ruby Driver 1.7.0.rc0 Released Tyler Brock 8/20/12 5:22 PM
It should be noted that the latest stable release gem is still installed when running "gem install mongo" and that the pre-release gems are installed via the following commands:

"gem install mongo --pre"
"gem install bson --pre"
"gem install bson_ext --pre"

-Tyler

On Monday, August 20, 2012 7:06:39 PM UTC-4, Tyler Brock wrote: