Multiple Images Problem

Showing 1-3 of 3 messages
Multiple Images Problem Tyler 2/4/10 8:18 AM
My website is this http://www.berman.tylerstefanich.com/
and I get all these errors

Warning: Invalid argument supplied for foreach() in /home/tilar/
berman.tylerstefanich.com/wp-content/plugins/magic-fields/get-
custom.php
on line 193

Warning: array_reverse() [function.array-reverse]: The argument should
be an array in /home/tilar/berman.tylerstefanich.com/wp-content/
plugins/magic-fields/get-custom.php
on line 197

Warning: sort() expects parameter 1 to be array, null given in /home/
tilar/berman.tylerstefanich.com/wp-content/plugins/magic-fields/get-
custom.php
on line 198

Warning: Invalid argument supplied for foreach() in /home/tilar/
berman.tylerstefanich.com/wp-content/themes/clean-home/index.php on
line 13

and I used this code

<?php
$images = getFieldOrder('Images');
foreach($images as $image){
        echo "<a href='" .get('Images',1,$image). "'rel='lightbox'>";
        echo get_image('Images',1,$image);
        echo "</a>";
}
?>


i was wondering what is wrong

Re: Multiple Images Problem Tyler 2/4/10 8:42 AM
Ok I figured it out. That it only throws errors on posts that have no
images. How do I stop that from happening.

On Feb 4, 10:18 am, Tyler <tyler.stefan...@gmail.com> wrote:
> My website is thishttp://www.berman.tylerstefanich.com/

Re: Multiple Images Problem Hunk 2/4/10 5:46 PM
<?php
$images = getFieldOrder('Images');
if(is_array($images)){

  foreach($images as $image){
        echo "<a href='" .get('Images',1,$image). "'rel='lightbox'>";
        echo get_image('Images',1,$image);
        echo "</a>";
  }
}

?>