error: 403.4 SSL required

Showing 1-12 of 12 messages
error: 403.4 SSL required Rupert 10/28/11 8:08 AM
Hi, guys.
First-time user here with an SSL error while trying to "google docs list":

Failed to get entries: Server responded with: 403, <errors xmlns='http://schemas.google.com/g/2005'><error><domain>GData</domain><code>ServiceForbiddenException</code><internalReason>403.4 SSL required</internalReason></error></errors>

Short version: I've tried some stuff and am stuck.  Any help?
In case there's a better way to achieve my goal, aim is to download a periodically-populated-by-form spreadsheet to process locally.

Setup:
I'm on Ubuntu Natty Narwhal, GoogleCL 0.9.13-1 (from this project's deb), python-gdata 2.0.8-1.1 (from default Ubuntu repos), Python 2.7.1+.
I have a regular public Google account (using new Google Docs appearance, etc if relevant).  I generally access everything via SSL but I can't find a setting anywhere other than GMail to say to do so by default.

Tried...
I authenticated successfully (after hitting ELinks having problems, I blasted the config and re-did with Firefox).  I then ran into this problem.
I searched the forum and tried Tom Miller's suggestion to edit servicec.py but no luck. (merely edited then retried command.  Couldn't find any .pyc files.)
I then tried installing python-gdata from source (without uninstalling the Debian version) and got this error:

$ google -v -v docs list
Gdata will be imported from /usr/local/lib/python2.7/dist-packages/gdata/__init__.pyc
Your pythonpath: None
Reading configuration from /home/arkade/.config/googlecl/config
determine_terminal_encoding(): UTF-8
Traceback (most recent call last):
  File "/usr/bin/google", line 849, in <module>
    main()
  File "/usr/bin/google", line 835, in main
    run_once(options, args)
  File "/usr/bin/google", line 540, in run_once
    options.config)
  File "/usr/bin/google", line 373, in import_service
    service_module = import_at_runtime('googlecl.' + service + '.client')
  File "/usr/bin/google", line 332, in import_at_runtime
    return __import__(module, globals(), fromlist=['0'])
  File "/usr/local/lib/python2.7/dist-packages/googlecl/docs/client.py", line 47, in <module>
    googlecl.client.BaseClientCL):
  File "/usr/local/lib/python2.7/dist-packages/googlecl/docs/client.py", line 55, in DocsClientCL
    DOCLIST_FEED_URI = gdata.docs.client.DOCLIST_FEED_URI
AttributeError: 'module' object has no attribute 'DOCLIST_FEED_URI'

So I uninstalled Debian version, uninstalled GoogleCL Deb, reinstalled gdata from source (didn't uninstall first), instsalled GoogleCL from source and tried again.  Same error.
Since this seems less approachable than the original error, I uninstalled all the stuff from source (by deleting atom, gdata*, googlecl* under "/usr/local/lib/python2.7") and reinstalled per original (above).  Back to same error.

All thoughts (including blatantly obvious stuff that I'm being blind to!) welcome!
Many thanks in advance, Rupert

p.s. sorry if I'm being Python n00b ;-) -- I'm a Java + UNIX guy if that helps pace answers!
Re: error: 403.4 SSL required jholt 11/7/11 3:14 PM
We saw that DOCLIST_FEED_URI bug last night when we tried gdata 2.0.15, so that version of gdata seems to be at least partly broken with googlecl.  We're working on that.  2.0.14 worked better, but I can't reproduce the SSL error, so I can't say whether it'll make that problem go away.
Re: error: 403.4 SSL required JackLeo 11/18/11 2:56 AM
Hi, I can confirm the problem.

I'm running
    3.1.1-1.fc16.i686 kernel,
    googlecl-0.9.13 from svn
    gdata-2.0.15
    Python 2.7.2
    Fedora 16 with xfce

Problem appears at any point when trying to connect to google.

Any hot fixes for source?


On 8 Lap, 01:14, Jason Holt <jh...@google.com> wrote:
> We saw that DOCLIST_FEED_URI bug last night when we tried gdata 2.0.15, so
> that version of gdata seems to be at least partly broken with googlecl.
>  We're working on that.  2.0.14 worked better, but I can't reproduce the
> SSL error, so I can't say whether it'll make that problem go away.
>
>
>
>
>
>
>
> On Fri, Oct 28, 2011 at 8:08 AM, Rupert <rupert....@gmail.com> wrote:
> > Hi, guys.
> > First-time user here with an SSL error while trying to "google docs list":
>
> > Failed to get entries: Server responded with: 403, <errors xmlns='
> >>http://schemas.google.com/g/2005'><error><domain>GData</domain><code>ServiceForbiddenException</code><intern alReason>403.4
> >> SSL required</internalReason></error></errors>
>
> > Short version: I've tried some stuff and am stuck.  Any help?
> > In case there's a better way to achieve my goal, aim is to download a
> > periodically-populated-by-form spreadsheet to process locally.
>
> > *Setup:*
> > I'm on Ubuntu Natty Narwhal, GoogleCL 0.9.13-1 (from this project's deb),
> > python-gdata 2.0.8-1.1 (from default Ubuntu repos), Python 2.7.1+.
> > I have a regular public Google account (using new Google Docs appearance,
> > etc if relevant).  I generally access everything via SSL but I can't find a
> > setting anywhere other than GMail to say to do so by default.
>
> > *Tried...*
> > I authenticated successfully (after hitting ELinks having problems, I
> > blasted the config and re-did with Firefox).  I then ran into this problem.
> > I searched<https://groups.google.com/forum/#%21searchin/googlecl-discuss/SSL>the forum and tried Tom
> > Miller's suggestion<https://groups.google.com/d/msg/googlecl-discuss/vkyGS4grd6g/u1qAOPkk...>to edit servicec.py but no luck. (merely edited then retried command.
Re: error: 403.4 SSL required Coila 11/20/11 2:18 PM
Jason and I made some disappointing discoveries about how gdata is working with googlecl. If possible, I recommend using gdata 2.0.12, 2.0.13, or 2.0.14 for now. We're going to continue working on compatibility with 2.0.15, but don't yet have a working solution for uploading all document types.

-Coila


Here are our blog posts on the matter:


Re: error: 403.4 SSL required Chen Liang 11/21/11 2:31 AM
Hi Coila:

    The table you guys come up with is awesome, i am trying to use googlecl to export data from google doc to xls files and then to xml, the command

    google docs get "aSpreadSheetFile" .

    fails from time to time for different spreadsheets, tried different versions, googcl and gdata, still not working, have you guys by any chance tested the download
method and the api compatibility ?  

2011/11/21 Coila Graham <coi...@gmail.com>



--
---------------------------------------------------------
Chen Liang
Playfish Beijing Engineer

Re: error: 403.4 SSL required Hari 11/22/11 3:03 PM
When I uninstalled gdata 2.0.15 and installed 2.0.14, I got a different error "ImportError: No module named gdata.docs.service". I tried downgrading googlecl as well to 0.9.12 and still got the same error. Could someone share the versions that are compatible right now?

Traceback (most recent call last):
  File "/home/hdara/bin/python/bin/google", line 849, in <module>
    main()
  File "/home/hdara/bin/python/bin/google", line 835, in main
    run_once(options, args)
  File "/home/hdara/bin/python/bin/google", line 540, in run_once
    options.config)
  File "/home/hdara/bin/python/bin/google", line 375, in import_service
    service_module = import_at_runtime('googlecl.' + service + '.service')
  File "/home/hdara/bin/python/bin/google", line 332, in import_at_runtime

    return __import__(module, globals(), fromlist=['0'])
  File "/home/hdara/bin/python/lib/python2.6/site-packages/googlecl/docs/service.py", line 32, in <module>
    import gdata.docs.service
ImportError: No module named gdata.docs.service

Re: error: 403.4 SSL required jholt 11/23/11 9:22 AM

That error is most likely caused by an incorrect PYTHONPATH.  Make sure it includes the lib/python part of the full pathname.

Sent from my Android

Re: error: 403.4 SSL required Hari 11/23/11 9:48 AM
I don't even have a PYTHONPATH set. I have gdata and googlecl installed into a virtualenv and have the path to the virtualenv's bin added to PATH. I don't think you need PYTHONPATH in this setup, and I have been able to use it this way before the upgrade broke.
Re: error: 403.4 SSL required jholt 11/23/11 9:59 AM

Hm, well that error looks like it can't find the gdata library at all.

Sent from my Android

Re: error: 403.4 SSL required Hari 11/23/11 4:37 PM
I think it is finding the library, but the attribute is truly not there.

$ python
Python 2.6.5 (r265:79063, Apr 16 2010, 13:57:41)
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gdata; import gdata.docs; import gdata.docs.client
>>> gdata.docs.client.DOCLIST_FEED_URI

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>

AttributeError: 'module' object has no attribute 'DOCLIST_FEED_URI'



Re: error: 403.4 SSL required jholt 11/23/11 11:03 PM

That error relates to 2.0.15:

http://code.google.com/p/googlecl/source/diff?spec=svn575&r=575&format=side&path=/trunk/src/googlecl/docs/client.py

However, 2.0.15 is not known to work with GoogleCL.  2.0.14 is the version we recommend.

Sent from my Android

Re: error: 403.4 SSL required Hari 11/24/11 5:47 PM
I think you lost the context. I am aware of the compatibility issues with 2.0.15 (in deed that is the subject of this thread). I did try with 2.0.14 and report the issue earlier but I upgraded back to 2.0.15 in the meanwhile. The version doesn't matter, all that I was trying to point out is that it is able to find the module. I just tried to downgrade again to 2.0.14, but for some reason it can't be found anymore:

$ pip install gdata==2.0.14
Downloading/unpacking gdata==2.0.14
  Could not find a version that satisfies the requirement gdata==2.0.14 (from versions: )
No distributions matching the version for gdata==2.0.14