Cant start scm windows service

Showing 1-9 of 9 messages
Cant start scm windows service Andrey Kozhyn 5/23/12 4:34 AM
Hi, I'm trying to configure to run SCM server as windows service, but it fails to start and event log contains such error:

EventData
param1 scm-server
param2 %%0


Logs are empty, what could be the source of this error? 
Thanks
Re: Cant start scm windows service Sebastian Sdorra 5/23/12 5:07 AM
How do you installed the server? Have you used the following command?

scm-server install

Sebastian

2012/5/23 Andrey Kozhyn <hed...@gmail.com>

Re: Cant start scm windows service Andrey Kozhyn 5/23/12 5:12 AM
Yes, I used command scm-server install to do it

2012/5/23 Sebastian Sdorra <s.sd...@gmail.com>

Re: Cant start scm windows service Andrey Kozhyn 5/23/12 5:13 AM
And it created a service with following path to executable 
C:\Scm\Server\scm-server\libexec\prunsrv-amd64.exe //RS//scm-server

2012/5/23 Andrey Kozhyn <hed...@gmail.com>

Re: Cant start scm windows service Sebastian Sdorra 5/23/12 5:20 AM
There is another user with the same problem, have a look at  https://bitbucket.org/sdorra/scm-manager/issue/74/windows-service. The problem is i can't reproduce the problem, it works without a problem on my windows vms. I will try to reproduce the error, but i need some informations for that.

Which version of windows do you use? 32 bit or 64 bit? Could you start the server without the service (scm-server.bat)? 
Re: Cant start scm windows service Andrey Kozhyn 5/23/12 5:30 AM
Yes, I'm able to start SCM by just running scm-server.bat. 
I'm using x64 windows2008 R2 standard

2012/5/23 Sebastian Sdorra <s.sd...@gmail.com>

Re: Cant start scm windows service Andrey Kozhyn 5/23/12 5:34 AM
Seems my issue is a bit different. Log file called commons-daemon.2012-05-23 has following:

[2012-05-23 14:33:36] [error] Failed creating java 
[2012-05-23 14:33:36] [error] The filename, directory name, or volume label syntax is incorrect.
[2012-05-23 14:33:36] [error] ServiceStart returned 1
[2012-05-23 14:33:36] [error] The filename, directory name, or volume label syntax is incorrect.
[2012-05-23 14:33:36] [info]  Run service finished.
[2012-05-23 14:33:36] [info]  Commons Daemon procrun finished
Re: Cant start scm windows service Andrey Kozhyn 5/23/12 5:46 AM
The problem was that my Path variable contained path to x86 java version on x64 machine. Installed x64 java and changed PATH and it works now.
Thanks for your time and great software!

2012/5/23 Andrey Kozhyn <hed...@gmail.com>

Re: Cant start scm windows service schaibaa 5/30/12 12:57 PM
I had the same issue.. thanks for this.  The default Java download was
x86 on my system probably running a 32 bit browser by default).

Thanks

On May 23, 8:46 am, Andrey Kozhyn <hed...@gmail.com> wrote:
> The problem was that my Path variable contained path to x86 java version on
> x64 machine. Installed x64 java and changed PATH and it works now.
> Thanks for your time and great software!
>
> 2012/5/23 Andrey Kozhyn <hed...@gmail.com>
>
>
>
>
>
>
>
> > Seems my issue is a bit different. Log file
> > called commons-daemon.2012-05-23 has following:
>
> > [2012-05-23 14:33:36] [error] Failed creating java
> > [2012-05-23 14:33:36] [error] The filename, directory name, or volume
> > label syntax is incorrect.
> > [2012-05-23 14:33:36] [error] ServiceStart returned 1
> > [2012-05-23 14:33:36] [error] The filename, directory name, or volume
> > label syntax is incorrect.
> > [2012-05-23 14:33:36] [info]  Run service finished.
> > [2012-05-23 14:33:36] [info]  Commons Daemon procrun finished
>
> > 2012/5/23 Andrey Kozhyn <hed...@gmail.com>
>
> >> Yes, I'm able to start SCM by just running scm-server.bat.
> >> I'm using x64 windows2008 R2 standard
>
> >> 2012/5/23 Sebastian Sdorra <s.sdo...@gmail.com>
>
> >>> There is another user with the same problem, have a look at
> >>>https://bitbucket.org/sdorra/scm-manager/issue/74/windows-service. The
> >>> problem is i can't reproduce the problem, it works without a problem on my
> >>> windows vms. I will try to reproduce the error, but i need some
> >>> informations for that.
>
> >>> Which version of windows do you use? 32 bit or 64 bit? Could you start
> >>> the server without the service (scm-server.bat)?
>
> >>> Sebastian
>
> >>> 2012/5/23 Andrey Kozhyn <hed...@gmail.com>
>
> >>>> And it created a service with following path to executable
> >>>> C:\Scm\Server\scm-server\libexec\prunsrv-amd64.exe //RS//scm-server
>
> >>>> 2012/5/23 Andrey Kozhyn <hed...@gmail.com>
>
> >>>>> Yes, I used command scm-server install to do it
>
> >>>>> 2012/5/23 Sebastian Sdorra <s.sdo...@gmail.com>
>
> >>>>>> How do you installed the server? Have you used the following command?
>
> >>>>>> scm-server install
>
> >>>>>> Sebastian
>
> >>>>>> 2012/5/23 Andrey Kozhyn <hed...@gmail.com>
>
> >>>>>>> Hi, I'm trying to configure to run SCM server as windows service,
> >>>>>>> but it fails to start and event log contains such error:
>
> >>>>>>>   *EventData*
> >>>>>>>    *param1* scm-server   *param2* %%0