Fiddler Composer Not Sending Request

Showing 1-3 of 3 messages
Fiddler Composer Not Sending Request gr...@estesfam.net 2/7/13 1:21 PM

I'm developing several REST APIs using MVC4 Web APIs and using Fiddler to test them. I'm using the Composer to create HTTP request for testing. Everything is working correctly on my development machine.

I deployed the web APIs to a test IIS server (Windows 2008 RC2) and tested again using the Fiddler on my dev box hitting the test server using same commands, just changing the URL in Fiddler. When I do this, the requests in hang for a while and then get a "504 [Fiddler] ReadResponse() failed: The server did not return a response for this request" message. This happens on both GET and POST requests. However, if I hit a static htm page (API Documentation page), it works fine.

I then installed Fiddler on the test server and ran the exact same commands from there and the worked successfully. Then on the test server, I let Fiddler capture traffic and tried running the commands again from my develop machine. Nothing. Then to verify, I ran wireshark on the test machine, filtered to port 80, and tried running the commands from my dev machine using Fiddler again. Wireshark never receives the request. But running the same commands using Fiddler on the test server works and shows up in both Fiddler and Wireshark.

If I use JQuery or a simple .Net app to send HTTP request from my dev machine to the test server, the requests work fine. So it appears everything is set up on the test machine correctly and Fiddler is the issue.

Has anyone ever experienced this issue before? Any thing else I can try? Unfortunately these are internal APIs so I can't post URL for anyone to test with.

Thanks, Greg

Re: Fiddler Composer Not Sending Request EricLaw 2/7/13 1:25 PM
1. Can you post a copy of the request you're trying to send?
2. When you "use Jquery or a simple .NET app to send HTTP request" through Fiddler, does the request work properly? If you use the Replay command on the toolbar or context menu, does the replayed request work properly?
Re: Fiddler Composer Not Sending Request gr...@estesfam.net 2/8/13 5:36 AM
I'm really confused now.  I came in this morning to get copies of the requests for you, Eric, and things are working correctly.  Nothing has changed which is very strange.  I'm going to have to do more digging to see if I can figure out what is going on.  It's challenging when things don't consistently fail the same way!!