Something changed with SSL on .appspot.com -- proxy dead

Showing 1-7 of 7 messages
Something changed with SSL on .appspot.com -- proxy dead Jesse Lovelace 5/11/11 1:16 PM
Hi Google Team:

Something seems to have changed with the SSL on the *.appspot.com domains, nginx can no longer proxy_pass to them, I'm getting this error:

2011/05/11 20:02:34 [error] 14307#0: *1 SSL_do_handshake() failed (SSL: error:1408E0F4:SSL routines:SSL3_GET_MESSAGE:unexpected message) while SSL handshaking to upstream...

This was working for years until about an hour ago.

Any ideas?
Re: Something changed with SSL on .appspot.com -- proxy dead chrisfarms 5/19/11 2:46 AM

I've also starting seeing this (First noticed May 12th) and has been
getting worse. MUCH worse today.

Not sure if it's an issue with nginx or something at AppEngine side.

Did you manage to resolve anything?
Re: Something changed with SSL on .appspot.com -- proxy dead stevep 5/19/11 1:24 PM
My https: calls stopped working Friday morning, May 19. No code
changes prior to when I first noticed it probably around 9 or 9:30am
PDT. Calls were just never getting to handler.

Starting working again a bit after noon. At least this is when I
noticed it changed back -- was feverishly trying to figure out what
went wrong. Was about to decide to move everything to http, but
problem disappeared before I made this change.

Any comments from GAE?? It's a bit disconcerting when something goes
off/on. Recalling forum history https seems prone to this.

thx, stevep
Re: Something changed with SSL on .appspot.com -- proxy dead Calvin 5/19/11 1:45 PM
You should bring this up on the main group (https://groups.google.com/forum/#!forum/google-appengine) to get it more visibility (also Java developers may have experienced the same thing).
Re: [appengine-python] Re: Something changed with SSL on .appspot.com -- proxy dead Jesse Lovelace 5/19/11 3:11 PM
Our is still broke too.  My conspiracy theory is that Google has
swapped out their SSL frontends in prep for the SSL on custom domain
and that the new SSL proxy doesn't handshake correctly with nginx.

jl

> --
> You received this message because you are subscribed to the Google Groups
> "google-appengine-python" group.
> To post to this group, send email to
> google-appe...@googlegroups.com.
> To unsubscribe from this group, send email to
> google-appengine-python+unsubscribe@googlegroups.com.
> For more options, visit this group at
> http://groups.google.com/group/google-appengine-python?hl=en.
>

Re: [appengine-python] Re: Something changed with SSL on .appspot.com -- proxy dead Erick Fleming 5/19/11 3:43 PM
I hope this is true :-)
Re: [appengine-python] Re: Something changed with SSL on .appspot.com -- proxy dead Jesse Lovelace 5/20/11 12:17 PM
Looks like someone started a ticket:


Please star it if you are in the same boat.

jll