EHCI host stops working after rebuild kernel

Showing 1-7 of 7 messages
EHCI host stops working after rebuild kernel beyounn 6/24/09 3:57 PM
All,
I have a Rev C board. I built a new kernel for BB by following
instructions from http://elinux.org/BeagleBoardLinuxKernel. After I
loaded the new uImage, none of the usb devices works. I have two self
powered USB hubs connected to the EHCI host connector. And I'm using
OTG to provide power to the BB.  After boot up the linux kernel, the
LED on the hubs ports are all off. I tried to plug and unplug the USB
cable, nothing shows up in the dmesg. It more likes that the BB does
not detect the EHCI host at all. Is there something specical I need to
do to make EHCI host to work?

BTW--the USB works perfectly, when use the kernel from
http://elinux.org/BeagleBoardUbuntu.
Thanks
Yi
Re: [beagleboard] EHCI host stops working after rebuild kernel RobertCNelson 6/29/09 4:53 PM

Hello,

Due to the issue you are seeing, you are probably missing this patch:

http://cgit.openembedded.net/cgit.cgi/openembedded/tree/recipes/linux/linux-omap-2.6.29/beagleboard/ehci.patch

ehci.patch is a zero length file in "./linux-omap-2.6.29" the overo
and beagleboard have different variations of it in their respected
directories, bitbake correctly understands this..

PS.  You should really subscribe, otherwise there can be a slight
delay: "On Wed, Jun 24, 2009 at 5:57 PM, beyounn<bey...@gmail.com>
wrote"

Regards,
--
Robert Nelson
http://www.rcn-ee.com/

Re: [beagleboard] Re: EHCI host stops working after rebuild kernel Yi Sun 6/29/09 5:16 PM
Ok, thanks. 
Yi
Re: [beagleboard] Re: EHCI host stops working after rebuild kernel Favor Tang 6/29/09 6:43 PM
hi,

   I have a Rev B5 board,  after I build a new kernel for BB, I can't
use mouse and keyboard via OTG, I used a powered USB hub connected to
the OTG host connector.

and when I  tried to plug and unplug the USB cable, no response
happened on the terminal console, nothing shows up in the dmesg.

so, do I needed extra patches to fix this issue?

thanks
--
~~~~~~~~~~~~~~~~~
 /favor
~~~~~~~~~~~~~~~~~
Re: [beagleboard] Re: EHCI host stops working after rebuild kernel RobertCNelson 6/29/09 7:15 PM
On Mon, Jun 29, 2009 at 8:43 PM, Favor Tang<tan...@gmail.com> wrote:
>
> hi,
>
>   I have a Rev B5 board,  after I build a new kernel for BB, I can't
> use mouse and keyboard via OTG, I used a powered USB hub connected to
> the OTG host connector.
>
> and when I  tried to plug and unplug the USB cable, no response
> happened on the terminal console, nothing shows up in the dmesg.
>
> so, do I needed extra patches to fix this issue?
>
> thanks
>

As a quick test, if this uImage (1) fixes your usb issue, then
probably yes. (Assuming your using 2.6.29 as a base from omap git...)

1: http://www.rcn-ee.com/deb/kernel/CC-beagle-v2.6.29-58cf2f1-oer32

Regards,

--
Robert Nelson
http://www.rcn-ee.com/

Re: [beagleboard] Re: EHCI host stops working after rebuild kernel Favor Tang 6/29/09 10:05 PM
hi,

  just cool, it fixes my usb issue ;),

why does the kernel you gave me fix my usb issue?

do you know which patches I missed?

thanks for your kindly help.
--
~~~~~~~~~~~~~~~~~
 /favor
~~~~~~~~~~~~~~~~~
Re: [beagleboard] Re: EHCI host stops working after rebuild kernel RobertCNelson 6/30/09 6:25 AM
On Tue, Jun 30, 2009 at 12:05 AM, Favor Tang<tan...@gmail.com> wrote:
>
> hi,
>
>  just cool, it fixes my usb issue ;),
>
> why does the kernel you gave me fix my usb issue?
>
> do you know which patches I missed?
>
> thanks for your kindly help.

I'm going to guess your also missing the ehci.patch.  I do have a
kernel patch & build writeup here:
http://elinux.org/BeagleBoardDebian#Normal_Kernel_Build  (not much
difference between oer34 and oer32)..

Regards,

--
Robert Nelson
http://www.rcn-ee.com/