Problem with internal Browser, MOZILLA_FIVE_HOME not set

Showing 1-20 of 20 messages
Problem with internal Browser, MOZILLA_FIVE_HOME not set jgutsche 6/7/12 3:36 PM
Hi all!

I just saw that problems with internal browsers are not new. I have
the same problem. With 3.2.1 on kubuntu 12.04 I am UNABLE to select
internal browser on the preferences tab and if I select e.g. the help
pages I get the MOZILLA_FIVE_HOME not set:


No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path
(MOZILLA_FIVE_HOME not set)]
        at org.eclipse.swt.SWT.error(SWT.java:3910)
        at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:484)
        at org.eclipse.swt.browser.Browser.<init>(Browser.java:119)
        at
org.xmind.ui.internal.browser.BrowserViewer.createBrowser(BrowserViewer.java:
675)
        at
org.xmind.ui.internal.browser.BrowserViewer.createBrowser(BrowserViewer.java:
591)
        at
org.xmind.ui.internal.browser.BrowserViewer.createContents(BrowserViewer.java:
471)
        at
org.xmind.ui.internal.browser.BrowserViewer.<init>(BrowserViewer.java:
449)
        at
org.xmind.ui.internal.browser.InternalBrowserEditor.createPartControl(InternalBrowserEditor.java:
133)
        at
org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:
662)
        at
org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:
462)
        at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:
595)
        at
org.eclipse.ui.internal.EditorReference.getEditor(EditorReference.java:
286)
        at
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:
2857)
        at
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:
2762)
        at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:
2754)
        at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:
2705)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:
70)
        at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:
2701)
        at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:
2685)
        at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:
2668)
        at
org.xmind.ui.internal.browser.InternalBrowser.doOpenURL(InternalBrowser.java:
89)
        at
org.xmind.ui.internal.browser.InternalBrowser.openURL(InternalBrowser.java:
68)
        at net.xmind.signin.internal.XMindNetNavigator
$1.run(XMindNetNavigator.java:39)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at
net.xmind.signin.internal.XMindNetNavigator.gotoURL(XMindNetNavigator.java:
37)
        at net.xmind.signin.XMindNet.gotoURL(XMindNet.java:51)
        at
net.xmind.workbench.internal.actions.XMindNetActionDelegate.gotoURL(XMindNetActionDelegate.java:
54)
        at
net.xmind.workbench.internal.actions.XMindNetActionDelegate.gotoURL(XMindNetActionDelegate.java:
46)
        at
net.xmind.workbench.internal.actions.WelcomeActionDelegate.run(WelcomeActionDelegate.java:
53)
        at
org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:
251)
        at
org.eclipse.ui.internal.WWinPluginAction.runWithEvent(WWinPluginAction.java:
229)
        at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:
584)
        at org.eclipse.jface.action.ActionContributionItem.access
$2(ActionContributionItem.java:501)
        at org.eclipse.jface.action.ActionContributionItem
$5.handleEvent(ActionContributionItem.java:411)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1176)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:
3493)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3112)
        at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:
2405)
        at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
        at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
        at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
        at
org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:
332)
        at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:
493)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:
149)
        at
org.xmind.cathy.internal.CathyApplication.start(CathyApplication.java:
46)
        at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:
194)
        at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:
110)
        at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:
79)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
368)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:
57)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:
43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1287)


Even if I set the evironment var in my bash.
Any solution to this problem would be welcome, since I have paid for
this on the other hand nice product.

btw: It worked fine on ubuntu 11.x
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set glen.s...@gmail.com 6/14/12 3:04 PM
Same problem here. No solution as yet.
unk...@googlegroups.com 6/15/12 4:04 AM <This message has been deleted.>
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set glen.s...@gmail.com 6/19/12 1:05 AM
You know, there's this amazing new thing called "polite and helpful." Have you heard of it?

I've tried every solution and solution combination that I can find, including your amazing Google result, and a few more besides. None of them work for the Lubuntu 12.04, so far as I can tell, and I'm not the only one.

On Friday, 15 June 2012 21:04:30 UTC+10, phill...@gmail.com wrote:
You know, there's amazing new thing called "Google". Have you heard of it?

https://www.google.co.uk/#hl=en&sclient=psy-ab&q=swt+browser+mozilla_five_home&oq=mozilla_five_home+browser&aq=0bK&aqi=g-bK1&aql=1&gs_l=hp.3.0.0i8i30.0.0.1.17.0.0.0.0.0.0.0.0..0.0.eish.1.0.0.G-UG_3V-kNs&pbx=1&bav=on.2,or.r_gc.r_pw.r_qf.,cf.osb&fp=e9480e5dabc46925&biw=1174&bih=705
unk...@googlegroups.com 6/20/12 3:26 PM <This message has been deleted.>
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set glen.s...@gmail.com 6/24/12 10:22 PM
Oh, wow, what an idea! Why didn't I think of that? Fix the problem? Jeez, I'm glad you're around mate, I just don't think I'd cope without you. First a Google search, and then fixing problems. You're an ideas man, aren't you? Tell you what you should do, get on more message boards and just start helping out, 'cause the world needs talent like yours. I'll bet you've had to practice a lot, skillz like those don't just appear.




On Friday, 8 June 2012 08:36:53 UTC+10, jgutsche wrote:
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set alte...@gmail.com 10/9/12 11:28 AM
I had the same problem in eclipse and this worked for me:

sudo apt-get install libwebkitgtk-1.0-0

I hope this works also for you, and stop fighting guys and try to help each others
;)
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set denis....@lamoda.ru 10/23/12 1:31 AM
Many thx install of libwebkitgtk remove problem
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set jan.l...@gmail.com 11/18/12 6:37 AM
Try this:
It works for me.
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set tonya...@gmail.com 12/12/12 1:08 PM
Yes! This worked for me on Xubuntu 12.10 with Springsource Tools Suite 3.2.0.M1 running on Eclipse 3.8.1. Much cleaner than the other XulRunner approaches.
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set rakesh.itat...@gmail.com 12/29/12 12:22 AM
sudo apt-get install libwebkitgtk-1.0-0

solved the problem on my system (ubuntu 12.04 LTS, Eclipse-PHP 3.02). Thanks
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set thisr...@gmail.com 1/3/13 10:07 AM
sudo apt-get install libwebkitgtk-1.0-0

solved the problem on my system (ubuntu 12.04 LTS, Eclipse-PHP 3.02). Thanks


Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set niranj...@gmail.com 4/19/13 1:41 AM
Thanks, This is so helpful to me!
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set bun...@gmail.com 5/1/13 9:11 AM
Installing libwebkitgtk worked perfectly. Thank you!

System: Ubuntu 13.04 (32 bit), Vuze 4.3.0.6
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set don...@gmail.com 5/15/13 12:24 PM
Thank you very very much!!! problem solved!!!
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set rbruce...@gmail.com 6/10/13 10:45 PM
This worked for me as well. I am using 13.04 raring and it fixed the issue!
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set mcven...@gmail.com 11/30/13 4:09 AM
To confirm, it solved my problem also. Thanks.
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set desch...@gmail.com 4/24/14 4:12 PM
Out of all the solutions - this was the one that worked for me!


On Tuesday, October 9, 2012 2:28:49 PM UTC-4, alte...@gmail.com wrote:
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set mapaviole...@gmail.com 4/26/14 8:38 AM
thanks!
Re: Problem with internal Browser, MOZILLA_FIVE_HOME not set kks....@gmail.com 12/3/14 12:36 AM
Thanks, Thats Really Work


On Friday, June 8, 2012 4:06:53 AM UTC+5:30, jgutsche wrote: