/blog/posts/queue Only Returning 10 Posts

Showing 1-11 of 11 messages
/blog/posts/queue Only Returning 10 Posts Felix Bonkoski 6/8/12 12:08 PM
Hello, the "grab the blog's queue" command is only returning 10 posts.

This is not expected behavior according to the API Docs, which state:
"The complete set of queued posts is returned (no pagination)."

So I expect the 21 posts in the queue to be returned. 

Is this just a bug, or is this a limitation?  Anyone else experience this as well?

Thanks,
Felix
Re: /blog/posts/queue Only Returning 10 Posts A. C. 6/9/12 6:27 AM
I've gotten this too.  

I've been able to get additional ones using something using the offset: blog/{blog-name}/posts/queue?offset=20

But definitely not working as API docs stated.
Re: /blog/posts/queue Only Returning 10 Posts John Bunting 6/9/12 10:21 AM
You guys are correct. I just noticed this difference in the documentation. When I get a chance today, I'll update the docs and push them to the site. I'm working on a way for the code to become the documentation for the site so we don't ever have this problem.  

Thanks again for the heads up! My apologies for the inconvenience.

-- 
John Bunting

Simplicity is a prerequisite for reliability
   --Edsger W. Dijkstra

Re: /blog/posts/queue Only Returning 10 Posts Felix Bonkoski 6/10/12 2:29 AM
Thanks for the reply!

I tried changing the 'limit' parameter, which had no affect. Didn't think to try using the offset.

Thanks,
Felix
Re: /blog/posts/queue Only Returning 10 Posts Felix Bonkoski 6/10/12 2:30 AM

You guys are correct. I just noticed this difference in the documentation. When I get a chance today, I'll update the docs and push them to the site. I'm working on a way for the code to become the documentation for the site so we don't ever have this problem.  

Yes, having the code generate the documentation is often the best way to create accurate documentation! Good luck with that.

Felix
Re: /blog/posts/queue Only Returning 10 Posts Felix Bonkoski 6/10/12 3:18 AM
Errr. Well, I thought this was going to work, but it still isn't.

On the first call to blog/posts/queue,  I get 10 posts.

I set the offset to 10, call again.

Second call, I get None back.

The are currently 14 posts in the queue of the Tumblr in question, so the second call should have returned 4 posts.

Thoughts?

Felix
Re: /blog/posts/queue Only Returning 10 Posts John Bunting 6/11/12 9:55 AM
Hum. I'm currently out of town but once I get a sec to sit down and test this, I'll figure it out and update you guys. 

-- 
John Bunting

Simplicity is a prerequisite for reliability
   --Edsger W. Dijkstra

Re: /blog/posts/queue Only Returning 10 Posts Felix Bonkoski 6/13/12 1:00 AM
Any news?  :)

Felix
Re: /blog/posts/queue Only Returning 10 Posts John Bunting 6/13/12 6:43 AM

Still out of town. :) I'll see if I can get another dev to verify the bug & fix it.

Re: /blog/posts/queue Only Returning 10 Posts Matthew Tom-Wolverton 6/13/12 9:34 AM
Hey Felix,

Just pushed a change that should fix what you described.  Can you give it a try and let me know if things work as expected?

Thanks,
--
Matt Tom-Wolverton
m...@tumblr.com
Re: /blog/posts/queue Only Returning 10 Posts Felix Bonkoski 6/14/12 1:34 AM
Great! Thanks for fixing that.

Now all you need to do is update your documentation  ; )

Felix