Fresh Installation

Showing 1-5 of 5 messages
Fresh Installation Richard Genthner 5/1/12 6:08 AM
[rgenthner@aaron:~/spf13-vim] vim ~/.vimrc 
CSApprox needs gui support - not loading.
  See :help |csapprox-+gui| for possible workarounds.
Error detected while processing /gpfs/gpfs0/devshare/home/rgenthner/.spf13-vim-3/.vim/bundle/python-mode/plugin/pymode.vim:
line  220:
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/gpfs/gpfs0/devshare/home/rgenthner/.spf13-vim-3/.vim/bundle/python-mode/pylibs/ropevim.py", line 296
    arg = 'None' if prefix else ''
                  ^
SyntaxError: invalid syntax
Press ENTER or type command to continue

Ideas on why I would be getting this after a fresh install ? Box is running Centos 5.6. VIM version 7.2.148
Re: Fresh Installation Spf13 5/1/12 6:14 AM
What version of python do you have?

Steve Francia
@spf13
Re: Fresh Installation Henning Glatter-Gotz 5/1/12 6:25 AM
This happened to me too after initial installation.
It turned out that the installation of the bundles did not complete during the installation.

To fix this I ran :BundleInstall, that reran the installation of all the bundles.

Henning--
Henning Glatter-Gotz
(727) 804-3841

Re: Fresh Installation sreeneel sreeneel 10/11/12 1:29 PM
I am running into this same problem.
Here's my python version:
>> python --version
Python 2.7.3
[~]
Re: Fresh Installation sreeneel sreeneel 10/11/12 1:38 PM
Little bit more info:

Running on OSX 10.8.2, snowleaopard

Here's the error that I got after running the curl command:

[~]
>> curl http://j.mp/spf13-vim3 -L -o - | sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   147  100   147    0     0    560      0 --:--:-- --:--:-- --:--:--  1245
100  1107  100  1107    0     0   1476      0 --:--:-- --:--:-- --:--:--  1476
Thanks for installing spf13-vim

backing up current vim config

updating spf13-vim

Already up-to-date.
setting up symlinks
update/install plugins using Vundle
Error detected while processing /Users/smaddika/.spf13-vim-3/.vim/bundle/python-mode/plugin/pymode.vim:
line  119:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/Users/smaddika/.spf13-vim-3/.vim/bundle/python-mode/pylibs/pymode/auto.py", line 2, in <module>
    from pylibs.autopep8 import fix_file, PEP8_PASSES_MAX
  File "/Users/smaddika/.spf13-vim-3/.vim/bundle/python-mode/pylibs/autopep8.py", line 41, in <module>
    import tempfile
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/tempfile.py", line 34, in <module>
    from random import Random as _Random
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/random.py", line 47, in <module>
    from os import urandom as _urandom
ImportError: cannot import name urandom
line  230:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/Users/smaddika/.spf13-vim-3/.vim/bundle/python-mode/pylibs/ropevim.py", line 3, in <module>
    import tempfile
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/tempfile.py", line 34, in <module>
    from random import Random as _Random
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/random.py", line 47, in <module>
    from os import urandom as _urandom
ImportError: cannot import name urandomVim: Reading from stdin...


Looks like it cannot find urandom; Is there somehting I need to do to get this for python?