sbt 0.13.5 is released

Showing 1-9 of 9 messages
sbt 0.13.5 is released Josh Suereth 5/27/14 1:52 PM
sbt 0.13.5 is now available. sbt 0.13.5 is a technology preview of what's to come to sbt 1.0 with enhancements like
[auto plugins][1] and the necessary APIs changes and launcher[6] for "sbt as a server.", defined in the sbt-remote-control project[2].

See the Changes page[3] and the GitHub compare 0.13.2b...0.13.5[4] or release notes [5] for full release details.

This release is intended to be binary and source compatible with 0.13.{0,1,2}. Use it in an existing 0.13.x project by setting project/build.properties as follows:

    sbt.version=0.13.5

No changes should be necessary to your project definition and all plugins published for 0.13.{0,1,2} should still work. Please report if this is not the case. 

sbt team

Re: sbt 0.13.5 is released Grzegorz Slowikowski 5/28/14 3:57 AM
Thanks

Tested with my SBT Compiler Plugin for Maven on Java, Scala and Play! projects. Now waiting for Zinc 0.3.5.

Kind regards
Grzegorz Slowikowski
Re: [sbt-dev] Re: sbt 0.13.5 is released Grzegorz Kossakowski 5/28/14 4:14 AM
I'm about to cut the release of zinc.


--
You received this message because you are subscribed to the Google Groups "sbt-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sbt-dev+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sbt-dev/7202580e-2f0b-4ae5-b10d-801e205b7e34%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--
Grzegorz Kossakowski
Scalac hacker at Typesafe
twitter: @gkossakowski
Re: [sbt-dev] Re: sbt 0.13.5 is released Grzegorz Kossakowski 5/28/14 7:25 AM
Re: sbt 0.13.5 is released Grzegorz Slowikowski 5/28/14 8:01 AM
Hi

I found something strange. SBT 0.13.5 depends on Scala 2.10.4, but there is 2.10.3 version in incremental compiler artifacts generated for Maven,
for example here: http://central.maven.org/maven2/com/typesafe/sbt/incremental-compiler/0.13.5/incremental-compiler-0.13.5.pom
Why?

When using Zinc 0.3.5 I have version mix.
Output from "mvn dependency:tree":
+- com.typesafe.zinc:zinc:jar:0.3.5:compile
|  +- org.scala-lang:scala-library:jar:2.10.4:compile
|  +- com.typesafe.sbt:incremental-compiler:jar:0.13.5:compile
|  |  +- org.scala-lang:scala-compiler:jar:2.10.3:compile
|  |  |  \- org.scala-lang:scala-reflect:jar:2.10.3:compile
|  |  \- com.typesafe.sbt:sbt-interface:jar:0.13.5:compile
|  \- com.typesafe.sbt:compiler-interface:jar:sources:0.13.5:compile

It works for me, but I don't understand why there are "2.10.3" versions of Scala dependencies.

Regards
Grzegorz


On Tuesday, May 27, 2014 10:52:59 PM UTC+2, Josh Suereth wrote:
Re: [sbt-dev] Re: sbt 0.13.5 is released Grzegorz Kossakowski 5/28/14 9:52 AM


--
You received this message because you are subscribed to the Google Groups "sbt-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to sbt-dev+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/sbt-dev/b811f8d4-dbb9-4390-8370-ff5d7ee195b4%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--
Grzegorz Kossakowski
Scalac hacker at Typesafe
twitter: @gkossakowski
Re: [sbt-dev] Re: sbt 0.13.5 is released Josh Suereth 5/28/14 10:03 AM
Yeah, that's my bad. It *shoudl* be an innocuous bug, but one I'll correct on the republishing
Re: [sbt-dev] Re: sbt 0.13.5 is released Grzegorz Slowikowski 5/28/14 1:19 PM
OK, so I can consider this being a bug, and Scala version should be 2.10.4 everywhere.

I've excluded Scala "2.10.3" artifacts and added "2.10.4":

https://oss.sonatype.org/content/repositories/snapshots/com/google/code/sbt-compiler-maven-plugin/sbt-compiler-sbt0135/1.0.0-beta4-SNAPSHOT/sbt-compiler-sbt0135-1.0.0-beta4-20140528.200846-3.pom

and now my dependency tree looks like:


+- com.typesafe.zinc:zinc:jar:0.3.5:compile
|  +- com.typesafe.sbt:incremental-compiler:jar:0.13.5:compile
|  |  \- com.typesafe.sbt:sbt-interface:jar:0.13.5:compile
|  \- com.typesafe.sbt:compiler-interface:jar:sources:0.13.5:compile
+- org.scala-lang:scala-compiler:jar:2.10.4:compile

|  +- org.scala-lang:scala-library:jar:2.10.4:compile
|  \- org.scala-lang:scala-reflect:jar:2.10.4:compile

It is, what it should be, right?

Grzegorz
Re: [sbt-dev] Re: sbt 0.13.5 is released Josh Suereth 5/28/14 1:28 PM
Yep.  I've already corrected this in the republishing, but you'll have to wait for the next sbt release/RC for the fix.