Re: [sage-support] Can't run notebook for new Sage 5.3 install.

Showing 1-6 of 6 messages
Re: [sage-support] Can't run notebook for new Sage 5.3 install. yomcat 10/1/12 10:37 PM
On 2/10/2012, at 12:41 PM, AHaensch <annah...@gmail.com> wrote:
> Just did a clean install of Sage 5.3 on newly upgraded OS X 10.8,
From source or just a binary?
> and I can't get my notebook to run.  It's been years since I've tried to initialize a new notebook, and I can't tell if I'm forgetting a step.
There's only one step: notebook()
> I also know that 10.8 isn't fully supported yet, so I imagine there might be some special steps necessary.  Any tips?
> I get the following error:
>
> OSError: [Errno 2] No such file or directory: '/Users/.../.sage/sage_notebook.sagenb/home/pub
It should be looking in Users/<shortusername>/.sage/sage_notebook.sagenb/home/pub. What is <shortusername>?
>
>
> Thanks so much!
>
> -Anna



Re: [sage-support] Can't run notebook for new Sage 5.3 install. AHaensch 10/2/12 6:22 PM
Installed from source.  I do run notebook() and then I get the error I mentioned.  To get to that "pub" file I go through Users/annahaensch/.sage/sage_notebook.sagenb/home/pub, but then it says the file type of "pub" is an alias, and I'm not sure where the original file is.  

Thanks! 
Re: [sage-support] Can't run notebook for new Sage 5.3 install. yomcat 10/2/12 6:27 PM
On 3/10/2012, at 2:22 PM, AHaensch <annah...@gmail.com> wrote:
> Installed from source.

How? Installing from source is broken on 10.8, unless you change the scipy package as in #13541 - http://trac.sagemath.org/sage_trac/ticket/13541, with the command line tools installed by XCode 4.5 (the latest version, released the same time as 10.8.2)

Michael
Re: [sage-support] Can't run notebook for new Sage 5.3 install. AHaensch 10/2/12 6:44 PM
Ah, yes, I didn't mention that, I did enable command line tools in Xcode 4.5, and changed the scipy package using that very trac ticket. 
Re: [sage-support] Can't run notebook for new Sage 5.3 install. yomcat 10/2/12 8:17 PM
On 3/10/2012, at 2:22 PM, AHaensch <annah...@gmail.com> wrote:
>
> To get to that "pub" file I go through
> Users/annahaensch/.sage/sage_notebook.sagenb/home/pub, but then it says the
> file type of "pub" is an alias, and I'm not sure where the original file
> is.  

Open the folder ~/.sage/sage_notebook.sagenb/home and select pub, then press cmd-R (it'll take you to the other end of the alias), and then cmd-click on the folder name in the title bar. It should be in some weird folder like 3a21.

Try this: remove the .sage folder from your home folder, either by trashing it or moving it someplace else.
Re: [sage-support] Can't run notebook for new Sage 5.3 install. AHaensch 10/3/12 3:28 AM
That worked!  Thanks so much!