fixed Rmagic in IPython Notebook

Showing 1-3 of 3 messages
fixed Rmagic in IPython Notebook erin clausing 6/18/13 9:10 PM

I finally got Rmagic to work.  One might be able to skip to step 5 if you have rpy2 working in Ipython but are still having problems with Rmagic.  It appears to be working correctly although the cell showing the [correct] results of the %R cell is unusually large for some reason.  Haven't tracked down why yet.  If you have any ideas, please let me know.


1.  I installed Python(x,y)-

2.  I had already installed R-2.15.3-win.exe

3.  I installed Rtools.  Exact filename: Rtools30.exe

4.  I installed rpy2-2.3.0dev.win32-py2.7.exe which I got from


following the instructions here for setting up Rhome, Ruser, and path variable changes


I tried the regular non dev version of rpy2 but it didn't work for me.


5. Then I went to my IPython extention folder which for me is:  C:\Python27\Lib\site-packages\IPython\extensions

and opened for editing.  Found the line


self.r('png("%s/Rplots%%03d.png",%s)' % (tmpd, png_args))


and replaced it with the line:


self.r('png("%s/Rplots%%03d.png",%s)' % (tmpd.replace('\\', '/'), png_args))


The reason you do this is described here:


Supposedly this issue was fixed.  See here:


So I'm not quite sure why my still had the problem.



6.  Put %load_ext rmagic in first cell and run it before trying %R



Hope this helps someone,



Re: fixed Rmagic in IPython Notebook Joris Van den Bossche 6/20/13 4:32 AM
Has it something to do with following issues?

Blank figure appears in output:
Another issues that I experience on Windows:

And for those who don't want to build RPy2 yourself, Christophe Gohlke also provides binaries: (which worked for me).


Op woensdag 19 juni 2013 06:10:27 UTC+2 schreef erin clausing het volgende:
Re: fixed Rmagic in IPython Notebook erin clausing 6/20/13 1:07 PM
Thank you SO MUCH!!!!  I have spent way too many hours trying to fix this problem so I was just going to live with manually resizing the empty image to a tiny size for a while.

Going into and using your line fixed my problem:

self.r('png("%s/Rplots%%03d.png",%s, type="cairo")' % (tmpd.replace('\\', '/'), png_args))

If I use the %R as in the following example, I get output:

In [1]:
%load_ext rmagic
%R x=c(1,2,3)

array([ 1.,  2.,  3.])

If I use the %%R, I get no output (I do get the output in the console) :
In [2]:
x <- c(0,1,2,3,4)
y <- c(1,1,1,1,1)
z = x + y

However I can get the output using a %R in the next cell
In [3]:
%R z

array([ 1.,  2.,  3.,  4.,  5.])

I can also do this to get the output:

In [4]:
%Rpull z

[ 1.  2.  3.  4.  5.]

This link seems to imply that a block of R code won't bring anything back by default:

Thanks again,