[perl #69524] [PATCH] I'm missing some needed files from the Parrot installation:

Showing 1-3 of 3 messages
[perl #69524] [PATCH] I'm missing some needed files from the Parrot installation: V-Lk 10/1/09 7:32 AM
# New Ticket Created by  v-lk
# Please include the string:  [perl #69524]
# in the subject line of all future correspondence about this issue.
# <URL: http://rt.perl.org/rt3/Ticket/Display.html?id=69524 >


Hello!

I've installed rakudo on my PC with Ubuntu AMD64.
Everything was OK, BUT later I began to configure Perl and received ERROR in the terminal after: /rakudo$ perl Configure.pl


===SORRY!===
I'm missing some needed files from the Parrot installation:
    /usr/local/lib/parrot/1.6.0-devel/languages/nqp/nqp.pbc
    /usr/local/lib/parrot/1.6.0-devel/tools/build/ops2c.pl
    /usr/local/lib/parrot/1.6.0-devel/tools/build/pmc2c.pl
    /usr/local/src/parrot/1.6.0-devel
    /usr/local/src/parrot/1.6.0-devel/pmc
    /usr/local/include/parrot/1.6.0-devel/pmc
(Perhaps you need to use Parrot's "make install-dev" or
install the "parrot-devel" package for your system?)

But I have the Parrot installed. I tryed several times to reinstall without any result.

Good Luck!!!

Victor

Re: [perl #69524] [PATCH] I'm missing some needed files from the Parrot installation: Will Coleda 10/1/09 3:19 PM

--
Will "Coke" Coleda

On Oct 1, 2009, at 10:32, v-lk (via RT) <parrotbug...@parrotcode.org
 > wrote:

Did you run 'make install' or 'make install-dev'?

Re: [perl #69524] [PATCH] I'm missing some needed files from the Parrot installation: Moritz Lenz 10/1/09 2:13 PM
v-lk (via RT) wrote:
> ===SORRY!===
> I'm missing some needed files from the Parrot installation:
>     /usr/local/lib/parrot/1.6.0-devel/languages/nqp/nqp.pbc
>     /usr/local/lib/parrot/1.6.0-devel/tools/build/ops2c.pl
>     /usr/local/lib/parrot/1.6.0-devel/tools/build/pmc2c.pl
>     /usr/local/src/parrot/1.6.0-devel
>     /usr/local/src/parrot/1.6.0-devel/pmc
>     /usr/local/include/parrot/1.6.0-devel/pmc
> (Perhaps you need to use Parrot's "make install-dev" or
> install the "parrot-devel" package for your system?)
>
> But I have the Parrot installed. I tryed several times to reinstall without any result.

You need the parrot-dev package (or if you built parrot yourself you
need 'make parrot-dev' in the parrot directory).

Didn't the error message say that? ;-)

Cheers,
Moritz