Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012

Showing 21-63 of 63 messages
Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Boudet, Xavier 10/3/12 6:07 AM
Hi there,

A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

New installation procedure:
  1- Add TI OMAP release PPA:
    $ sudo su -
    # export http_proxy=<your proxy if any>
    # export https_proxy=<your proxy if any>
    # add-apt-repository ppa:tiomap-dev/release
  2- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade
    $ sudo apt-get install ubuntu-omap4-extras
  3- You can re-run a dist-upgrade for safety at the end, then reboot

Update procedure:
1- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade


Post Installation Important Information:
* after the installation/update, it is advised to log as default user and to execute:
    # On Panda 4430: 
    $ /usr/bin/alsaucm -c Panda set _verb HiFi 
    # On PandaES 4460: 
    $ /usr/bin/alsaucm -c PandaES set _verb HiFi

* You need to force installation of new bootloaders (if any) through command:
    $ sudo /usr/sbin/flash-kernel --update-bootloader

* It is advised to use Ubuntu 2D instead of Ubuntu (3D) default UI. Nevertheless, main compiz issues have been fixed.

* In some cases, you might need to re-install dkms packages: after reboot,  check if omapdrm_pvr module is loaded, if not execute following command before to reboot:
    $ sudo apt-get install --reinstall pvr-omap4-dkms

New/Fixed in October 2012 release:
 * Kernel bug fixes:
- Rebase on Linux 3.4.11
- Panda DVI connector support
- DSS off mode support
 * Memory leaks during playback fixed
 * Decoder issues fixed
 * GBM/KMS support - Wayland DDK libs delivered.
 * Dual screen support on HDMI and DVI: you need to disable HWcursor in xorg.conf file, please edit /usr/share/X11/xorg.conf.d/99-omap.conf and add in section Device:
Option "HWcursor" "false"

Playing with GBM/KMS:
You just need to install following packages:
$ sudo apt-get install libwayland0 libgbm1

You can test now the kmscube test apps:
$ git clone git://github.com/robclark/kmscube.git

go into kmscube dir:
$ sudo apt-get install autoconf autotools-dev libtool libdrm-dev libwayland-dev libgbm-dev ubuntu-omap4-extras-graphics-dev
$ ./autogen.sh
$ make


Reboot with text in command line or stop lightdm with "sudo service lightdm stop"
If you have booted with text in bootargs, first execute "sudo pvrsrvinit", then execute:
$ sudo ./kmscube

Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Support:
updates for bug fixes in the PPA, so make sure to keep your system up-to-date!


Reference/Reminder:

The 'top-level' ubuntu-omap-extras will install the following packages:
 - ubuntu-omap-extras-multimedia: another meta package that installs all the requires packages for MM use case:
   * GST, a modified version still compatible with all Ubuntu apps such as totem
   * gst-ducati and libDCE the main components that bring MM h/w acceleration into the system
 - ubuntu-omap-extras-graphics: meta package that pulls in all GFX components including new X11 driver (binary blob) and SGX kernel module (source using DKMS to build)
 - ubuntu-omap-extras-config: some config scripts to set some permission issues, and to ensure that the Ducati firmware is loaded at boot time by upstart.

This release comes with the following major changes:
 - DCE interface for the h/w accelerated codecs - already there in 11.10
 - migration to rpmsg driver (aka syslink3, see http://lwn.net/Articles/448562/ and http://omappedia.org/wiki/Category:RPMsg)
 - DRI2 extension for Video support (http://www.phoronix.com/scan.php?page=news_item&px=OTgxOQ)
 - migration to a new open source X11 driver for OMAP (http://cgit.freedesktop.org/xorg/driver/xf86-video-omap/ )
 - a new GST video-sink: dri2videosink to display video through the SGX (instead of v4l2sink). For more information, see https://wiki.linaro.org/OfficeofCTO/MemoryManagement?action=AttachFile&do=view&target=linux-video.pdf
 - Linux 3.4 kernel, Ubuntu kernel will be replaced. This kernel is largely based of Linaro kernel, and sources are available here: http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git. Linux-image-<version> package version correspond to a tag ti-ubuntu-<kernel version>  in this tree.
 - ...

Regards, 
Xavier Boudet
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/3/12 9:16 AM
One important remark concerning bootargs when upgrading to TI kernel:
Please replace "vram=40M mem=456M@0x80000000 mem=512M@0xA0000000" or any vram or split mem settings with: "mem=1G@0x80000000"

We advise following bootargs:
ro elevator=noop console=ttyO2,115200n8 mem=1G@0x80000000 root=<UUID or LABEL root> fixrtc splash

Please update your /boot/boot.script file then run flash-kernel to apply the changes.
Re: [pandaboard] Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 JimD 10/3/12 9:34 AM
On 03/10/12 14:07, Boudet, Xavier wrote:
Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Xavier, if you want any help with this I can repeat the problem with every boot. Just give me some test cases and I'll give it a blast!

Regards,

Jim.
Re: [pandaboard] Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Joaquin Castellanos 10/3/12 4:57 PM
Hi Xavier,

After PPA upgrade pvrvideosink still not working for pandaboards rev A3   (for boards rev A4 seems to be working fine).

----------------------
jjcgp12@jjcgp12-desktop:~$ gst-launch filesrc location=/home/jjcgp0/Videos/MPEG4_VGA_AAC_HE.3gp ! qtdemux name=demux demux.video_00 ! queue ! mpeg4videoparse ! ducatimpeg4dec !  pvrvideosink

Setting pipeline to PAUSED ...
PVR:(Warning): PVRSRVOpenDCDevice: Warning - 138 returned [80, /bridged_pvr_dc_glue.c]
PVR:(Warning): PVRSRVOpenDCDevice: Warning - 138 returned [80, /bridged_pvr_dc_glue.c]
libdce-x11.c:64:    dce_auth_x11    info: attempting to open X11 connection

----------------------

Best regards
Joaquin Castellanos
Re: [pandaboard] Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/4/12 12:33 AM
Why don't you use dri2videosink? Nevertheless, pvrvideosink is still supported.
I have a rev A3 board that works fine with both.

Can you share the output of:
DISPLAY=:0 GST_DEBUG=*:2,ducati*:5 gst-launch-0.10 playbin2 uri=file:///home/jjcgp0/Videos/MPEG4_VGA_AAC_HE.3gp video-sink="pvrvideosink"
And:
DISPLAY=:0 GST_DEBUG=*:2,ducati*:5 gst-launch-0.10 playbin2 uri=file:///home/jjcgp0/Videos/MPEG4_VGA_AAC_HE.3gp video-sink="dri2videosink"

Can you check also that omapdrm_pvr module is loaded, if not do not hesitate to reinstall the dkms package to fix the issue:
sudo apt-get install --reinstall pvr-omap4-dkms

When you say "for boards rev A4 seems to be working fine" are you using same Filesystem on e.g. same SD card exactly?

Regards, 

Xavier Boudet
Re: [pandaboard] Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Joaquin Castellanos 10/4/12 3:44 PM
Hi Xavier

Yes, I am using the same Filesystem (same SD card) on both boards.

I don't have the File system right now but I will send you some GST logs shortly.

Best regards
Joaquin
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 dkar...@gmail.com 10/8/12 1:51 AM
Hi Xavier,

I have found another memory leak, maybe you have the possibility to look in to that. I run a looped video on the pandaboard (ES) with this command:
gst-launch-0.10 --loop playbin2 video-sink="dri2videosink" uri=file://<movie>.mov &

After running for 2 days the video stops. This was with the August update, but now after trying the latest October update, the problem persists.

Restarting the video shows a memory issue:
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...

libdce-x11.c:64:        dce_auth_x11    info: attempting to open X11 connection
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock

(gst-launch-0.10:19644): GStreamer-ERROR **: gstbuffer.c:455: failed to allocate 3637248 bytes

[1]+  Trace/breakpoint trap   gst-launch-0.10 --loop playbin2 video-sink="dri2videosink" uri=....


Looking at the memory usage it's clear that all the memory is exhausted:
# free
            total       used       free     shared    buffers     cached
Mem:       1024012     956432      67580          0        200      42208
-/+ buffers/cache:     914024     109988
Swap:            0          0          0


And seeing that Xorg is the culprit
# top
 [7m  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 (B [m 1677 root      20   0  771m 763m  15m S    2 76.3  64:44.14 Xorg
 (B [m19609 opticon   20   0 10756 5220 1064 S    0  0.5   0:01.78 xterm
 (B [m 1687 opticon   20   0 13544 3480 1504 S    0  0.3   0:00.72 openbox
 (B [m19615 opticon   20   0  6096 2868  984 S    0  0.3   0:01.76 bash

Any ideas?

Thanks in advance,

Dennis Karmelk

Op woensdag 3 oktober 2012 15:07:05 UTC+2 schreef Boudet, Xavier het volgende:
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet TIF 10/8/12 2:03 AM
Hi,

Can you please execute on the media file you have been using:
$ DISPLAY=:0 gst-discoverer-0.10 <media file>

Can you also execute the following to have main package version:
$ dpkg -l | grep -e gst -e linux-image -e pvr -e dce

Please send back the output.

Regards, Xavier Boudet
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 dkar...@gmail.com 10/8/12 2:26 AM
Hi Xavier,

Thanks for the quick response. The requested info:

opticon@panda-01:~$ DISPLAY=:0 gst-discoverer-0.10 /content/opticon/film2.mov
Analyzing file:///content/opticon/film2.mov

libdce-x11.c:64:        dce_auth_x11    info: attempting to open X11 connection
Done discovering file:///content/opticon/film2.mov

Topology:
  container: Quicktime
    subtitles: text/plain
    video: H.264

Properties:
  Duration: 0:00:24.375000000
  Seekable: yes
  Tags:
      video codec: H.264 / AVC
      language code: en
      subtitle codec: Quicktime timed text
      datetime: "2012-09-03T21:39:34.000000+0200"
      QT atom: { 0000000c61706d6470726f64, 0000000953656c4f01, 0000000c637479706e6f6e65 }
      container format: Quicktime

opticon@panda-01:~$ dpkg -l | grep -e gst -e linux-image -e pvr -e dce
ii  gir1.2-gst-plugins-base-0.10          0.10.36-1+ti1.6.6.1+1                   Description: GObject introspection data for the GStreamer Plugins Base library
ii  gir1.2-gstreamer-0.10                 0.10.36-1ubuntu1+ti1.6.3.2+1            Description: GObject introspection data for the GStreamer library
ii  gst-auto-launch                       0.3.21-3                                This is an improved version of gst-launch that accepts commands.
ii  gstreamer-tools                       0.10.36-1ubuntu1+ti1.6.3.2+1            Tools for use with GStreamer
ii  gstreamer0.10-alsa                    0.10.36-1+ti1.6.6.1+1                   GStreamer plugin for ALSA
ii  gstreamer0.10-faac                    0.10.23-1+ti1.6.7.2+1                   FAAC plugin for GStreamer
ii  gstreamer0.10-ffmpeg                  0.10.13-1+ti1.6.2.1+1                   FFmpeg plugin for GStreamer
ii  gstreamer0.10-gconf                   0.10.31-1ubuntu1+ti1.6.4.1+1            GStreamer plugin for getting the sink/source information from GConf
ii  gstreamer0.10-gnomevfs                0.10.36-1+ti1.6.6.1+1                   GStreamer plugin for GnomeVFS
ii  gstreamer0.10-plugin-ducati           1.6.7.2-1                               gst-plugin-ducati is a Gstreamer plugin
ii  gstreamer0.10-plugins-bad             0.10.23-1+ti1.6.7.2+1                   GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-base            0.10.36-1+ti1.6.6.1+1                   GStreamer plugins from the "base" set
ii  gstreamer0.10-plugins-base-apps       0.10.36-1+ti1.6.6.1+1                   GStreamer helper programs from the "base" set
ii  gstreamer0.10-plugins-good            0.10.31-1ubuntu1+ti1.6.4.1+1            GStreamer plugins from the "good" set
ii  gstreamer0.10-plugins-ugly            0.10.18.3-1ubuntu1+ti1.6.2.1+1          GStreamer plugins from the "ugly" set
ii  gstreamer0.10-pulseaudio              0.10.31-1ubuntu1+ti1.6.4.1+1            GStreamer plugin for PulseAudio
ii  gstreamer0.10-sdl                     0.10.23-1+ti1.6.7.2+1                   GStreamer plugin for SDL output
ii  gstreamer0.10-tools                   0.10.36-1ubuntu1+ti1.6.3.2+1            Tools for use with GStreamer
ii  gstreamer0.10-x                       0.10.36-1+ti1.6.6.1+1                   GStreamer plugins for X11 and Pango
ii  libdce0                               1.6.5.4-1                               OMAP4 DCE library
ii  libgstreamer-plugins-bad0.10-0        0.10.23-1+ti1.6.7.2+1                   GStreamer development files for libraries from the "bad" set
ii  libgstreamer-plugins-base0.10-0       0.10.36-1+ti1.6.6.1+1                   GStreamer libraries from the "base" set
ii  libgstreamer0.10-0                    0.10.36-1ubuntu1+ti1.6.3.2+1            Core GStreamer libraries and elements
rc  linux-image-3.4.0-1-linaro-lt-omap    3.4.0-1.1~120627131801                  Linux kernel image for version 3.4.0 on TI OMAP-based systems
ii  linux-image-3.4.0-1486-omap4          3.4.0-1486.9                            Linux kernel image for version 3.4.0 on TI OMAP4-based systems
ii  linux-image-3.4.0-1487-omap4          3.4.0-1487.6                            Linux kernel image for version 3.4.0 on TI OMAP4-based systems
ii  linux-image-3.4.1-3-linaro-omap       3.4.1-3.3~ci~20120626002601~4fe985dd    Linux kernel image for version 3.4.1 on TI OMAP[34]-based systems
ii  linux-image-ti-omap4                  3.4.0.1487                              Linux kernel image for the OMAP4 architecture.
ii  pvr-omap4                             1.9.0.6.1.1-3                           PowerVR SGX540 libraries for OMAP4, remaining libs and binaries
ii  pvr-omap4-data                        1.9.0.6.1.1-3                           PowerVR SGX540 libraries for OMAP4, data files
ii  pvr-omap4-dkms                        1.9.0.6.1.1-2                           PowerVR SGX540 kernel driver for OMAP4 in DKMS format.
ii  pvr-omap4-utils                       1.9.0.6.1.1-3                           PowerVR SGX540 utils for OMAP4
ii  pvr-omap4-xf86                        1.9.0.6.1.1-3                           X.org graphics -- TI OMAP pvr display driver
ii  ti-firmware-ipu-dce                   1.6+120926+122834+git7169521            Texas Instruments firmware
opticon@panda-01:~$

Best regards,

Dennis


Op maandag 8 oktober 2012 11:03:16 UTC+2 schreef Xavier Boudet TIF het volgende:
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Juergen 10/16/12 6:49 AM
I tried to install the omap4-extras, but every time I get an error:

Error! Bad return status for build on kernel: 3.2.0-32-oamp /boot/vmlinuz-3.2.0-32-omap

I used an new an clear Ubuntu 12.04 with your HowTo, but there is no chance to get it working

That's my log:

DKMS make.log for pvr-omap4-1.9.0.6.1.1 for kernel 3.2.0-1420-omap4 (armv7l) Tue Oct 16 15:35:41 CEST 2012

make[1]: Entering directory `/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/build/linux2/omap4430_linux'

../config/core.mk:292: Setting SGX_DISABLE_VISTEST_SUPPORT=1 because PVRSRV_USSE_EDM_STATUS_DEBUG=1

../config/core.mk:339: CROSS_COMPILE is not set. Target components will be built with the host compiler

../config/core.mk:419: $(KERNELDIR)/vmlinux does not exist. Kbuild may fail.

  LD      /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/built-in.o

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/osfunc.o

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/mutils.o

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/mmap.o

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/module.o

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/pdump.o

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/proc.o

In file included from /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/module.c:132:0:

/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/services4/srvkm/env/linux/private_data.h:95:28: fatal error: linux/omap_drv.h: No such file or directory compilation terminated.

/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/mmap.c:368:28: fatal error: linux/omap_drv.h: No such file or directory compilation terminated.

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/pvr_bridge_k.o

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/pvr_debug.o

In file included from /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/pvr_bridge_k.c:52:0:

/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/services4/srvkm/env/linux/private_data.h:95:28: fatal error: linux/omap_drv.h: No such file or directory compilation terminated.

make[4]: *** [/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/module.o] Error 1

make[4]: *** Waiting for unfinished jobs....

  CC [M]  /var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/mm.o

make[4]: *** [/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/mmap.o] Error 1

/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/mm.c:1774:30: fatal error: linux/omap_drv.h: No such file or directory compilation terminated.

make[4]: *** [/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/pvr_bridge_k.o] Error 1

make[4]: *** [/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild/services4/srvkm/env/linux/mm.o] Error 1

make[3]: *** [_module_/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/binary2_omap4430_linux_release/target/kbuild] Error 2

make[2]: *** [kbuild] Error 2

make[1]: *** [build] Error 2

make[1]: Leaving directory `/var/lib/dkms/pvr-omap4/1.9.0.6.1.1/build/eurasiacon/build/linux2/omap4430_linux'

make: *** [all] Error 2


Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/16/12 7:42 AM
Hello Juergen,

This is a known issue, the pvr dkms module is not able to build vs the "default" kernel.
Nevertheless, it compiles fine with the new kernel installed with omap4-extras.
So you can ignore this warning and if you are happy with the new kernel/ppa then un-install previous linux-image and associated linux-headers to prevent having this error again.

Regards, Xavier Boudet
This message has been hidden because it was flagged for abuse.
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 beren...@gmail.com 10/17/12 8:27 AM
I just installed the this using the new installation procedure. Now my pandaboard has frequent freezes and sometimes does not start up. Also when i hover over anything with the cursor the screen flashes with artifacts.

I dont really know what to do about it. 

Thanks in advance
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/17/12 9:01 AM
Hello Linus,

We have indeed few remaining memory leaks that can lead to crashes in some cases.
We shall have an update begin of November improving the situation.
Can you please try to disable "ondemand" to see if disabling ondemand reduce the probability?

Edit file: /etc/init.d/ondemand
Comment line:
        echo -n ondemand > $CPUFREQ

Can you also share the gst pipeline your are using and some info on the video you are using.
Please send output of command: gst-discoverer-0.10 <sample file>

Can you also confirm if both filesystem and samples are on the SD Card?
I would suggest to have at least sample on USB drive.
I would also advise to setup filesystem on USB drive for better performance.
Please check: http://omappedia.org/wiki/Ubuntu_on_OMAP_FAQ#I_want_to_install_Ubuntu_on_external_USB_hard_disk_instead_of_sluggish_SD_card

Regards, Xavier Boudet

Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/17/12 9:08 AM
Hello

First of all, please check that you are using Ubuntu2D and not Ubuntu desktop that uses compiz.

Mouse cursor flash is consequence of HWcursor, you can fix that by disabling HWcursor in xorg.conf file, edit file /usr/share/X11/xorg.conf.d/99-omap.conf and add the bold line:
Section "Device"
    Identifier    "Video Device"
    Driver         "omap"
    Option        "Debug"        "false"
    Option        "HWcursor"        "false"
EndSection

I suppose that you are using filesystem on SD card, I would advise to switch to a USB drive:
http://omappedia.org/wiki/Ubuntu_on_OMAP_FAQ#I_want_to_install_Ubuntu_on_external_USB_hard_disk_instead_of_sluggish_SD_card

Freeze and startup issue are surprising nevertheless.
Are you sure that the omapdrm_pvr module is loaded?

Regards, Xavier Boudet
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/17/12 9:34 AM
On more point, can you also check your bootargs, with new kernel you need something like:
ro elevator=noop console=ttyO2,115200n8 mem=1G@0x80000000 root=<your root>
Be sure not to use anymore vram=xxx.
If not, please update /boot/boot.script, then execute "sudo flash-kernel" then reboot.

Regards, Xavier Boudet
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Mathieu Hingant 10/17/12 11:12 AM
Hello,

I am having the same trouble with my pandaboard ES freezing very often and having troubles rebooting or starting up. I explained my trouble here but didn't get any reply so far.
Reading the comments below, I checked if omapdrm_pvr is loaded. Running lsmod show me this:
Module                  Size  Used by
omapdrm_pvr           336605  0 

The board freezes when I am either downloading and transferring files (180+ Mo) or when I install packages.


I also had the mouse flashing problem but this is solved by disabling HWcursor ;).


Cheers!


Mathieu
This message has been hidden because it was flagged for abuse.
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 beren...@gmail.com 10/17/12 11:31 AM
Changing the boot args as shown in the 2nd post worked for me.

For people newish to ubuntu this is what i did:
Open terminal and go to boot directory( cd /boot)
then in terminal type "sudo gedit boot.script"
gedit will open with a few lines of code, the one that needs to be changed is the setenv bootargs line. 
"Please replace "vram=40M mem=456M@0x80000000 mem=512M@0xA0000000" or any vram or split mem settings with: " mem=1G@0x80000000""

On Wednesday, October 3, 2012 3:07:05 PM UTC+2, Boudet, Xavier wrote:
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/18/12 12:34 AM
Hi,
I have checked the question you posted.

Can you check/confirm the following:

1- Bootloaders:
Which version is displayed for u-boot when booting?
You shall have:
U-Boot 2012.04.01 (Jul 19 2012 - 17:37:11)

If this is not the case, ensure the you have the correct u-boot package installed:
$ dpkg -l | grep u-boot-linaro-omap4-panda
ii  u-boot-linaro-omap4-panda              2012.04.2+6514+45+201207191704~precise1 U-Boot bootloader binary for the TI OMAP4 Panda board

Then execute:
$ sudo /usr/sbin/flash-kernel --update-bootloader

2- Bootargs:
Can you ensure that your bootargs are aligned with the following:
ro elevator=noop console=ttyO2,115200n8 mem=1G@0x80000000 root=<your root> fixrtc splash

Please update /boot/boot.script accordingly, then you can use "flash-kernel" to update your boot.scr in boot partition.

=======

Then concerning the traces you have reported on askubuntu, the kernel traces are "normal" and can be ignored.
Then, if you are still having issues, can you please execute command: "sudo omap-collect-info" after a freeze (except if the freeze never ends then do it after a successful boot...). Then please send me the generated tarball (to me only).

Regards, Xavier Boudet

Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 10/18/12 12:38 AM
Hi Linus,

As I explained in a separate thread, please ensure the following:

1- Bootloaders:
Which version is displayed for u-boot when booting?
You shall have:
U-Boot 2012.04.01 (Jul 19 2012 - 17:37:11)

If this is not the case, ensure the you have the correct u-boot package installed:
$ dpkg -l | grep u-boot-linaro-omap4-panda
ii  u-boot-linaro-omap4-panda              2012.04.2+6514+45+201207191704~precise1 U-Boot bootloader binary for the TI OMAP4 Panda board

Then execute:
$ sudo /usr/sbin/flash-kernel --update-bootloader

2- Bootargs:
Can you ensure that your bootargs are aligned with the following:
ro elevator=noop console=ttyO2,115200n8 mem=1G@0x80000000 root=<your root> fixrtc splash

Please update /boot/boot.script accordingly, then you can use "flash-kernel" to update your boot.scr in boot partition.

Then, can you please use the following pipeline to play the video:
gst-launch-0.10 playbin2 uri=<path_to_MPEG-2_file> video-sink="dri2videosink"

Regards, Xavier Boudet
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 beren...@gmail.com 10/19/12 12:34 PM
Ok i thought that my pandaboard was ok but no longer. It has the exact same problem as what this guy posted 

On Wednesday, October 3, 2012 3:07:05 PM UTC+2, Boudet, Xavier wrote:
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 beren...@gmail.com 10/19/12 2:15 PM
Ok I just did some major finds which some I do find quite annoying. The TI ppa is incompatible with qt-sdk. When I installed it, unity stopped working. There was no problems with the prebuilt binaries but now I cant use Qt with this. The reason for the freezes and crashing was that I was using the wrong u-loader after attempting to revert to the prebuilt binaries that I was using before upgrading to TI ppa.


On Wednesday, October 3, 2012 3:07:05 PM UTC+2, Boudet, Xavier wrote:
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 rob 10/19/12 3:15 PM
On Fri, Oct 19, 2012 at 4:15 PM,  <beren...@gmail.com> wrote:
> Ok I just did some major finds which some I do find quite annoying. The TI
> ppa is incompatible with qt-sdk. When I installed it, unity stopped working.
> There was no problems with the prebuilt binaries but now I cant use Qt with

I doubt this is related to anything in TI PPA.. I don't think we
include any qt in our PPA.

However unity-2d does use qt.. I don't know really about qt-sdk but
perhaps it is an incompatible version of qt.  If possible, try
installing qt-sdk in some location other than /usr... ie, if you use
/usr/local/qt or something like this, then it won't conflict with the
versions that unity-2d uses.  Or alternatively install openbox or some
desktop that does not use qt.

BR,
-R
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 beren...@gmail.com 10/19/12 3:54 PM
I reinstalled the ubuntu-omap4-extras using terminal and doing this removed qt-sdk. I was very surprised. But somehow Qt creator is still working, not exactly sure how.
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 beren...@gmail.com 10/20/12 4:17 AM
This is the result after I tried to install Qt sdk again. Qt Creator wont compile otherwise.
sudo apt-get install qt-sdk
[sudo] password for beren:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libswscale2 libpostproc52 libavformat53 libgles1-sgx-omap4
  gstreamer0.10-plugin-ducati
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libegl1-mesa libegl1-mesa-dev libegl1-mesa-drivers libgles2-mesa
  libgles2-mesa-dev libqt4-opengl-dev
The following packages will be REMOVED:
  libegl1-sgx-omap4 libgles2-sgx-omap4 pvr-omap4-utils ubuntu-omap4-extras
  ubuntu-omap4-extras-graphics ubuntu-omap4-extras-multimedia
The following NEW packages will be installed:
  libegl1-mesa libegl1-mesa-dev libegl1-mesa-drivers libgles2-mesa
  libgles2-mesa-dev libqt4-opengl-dev qt-sdk
0 upgraded, 7 newly installed, 6 to remove and 0 not upgraded.
Need to get 0 B/1 612 kB of archives.
After this operation, 4 574 kB of additional disk space will be used.
Do you want to continue [Y/n]?

So with this I cannot use the TI ppa.

On Wednesday, October 3, 2012 3:07:05 PM UTC+2, Boudet, Xavier wrote:
Hi there,

A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

New installation procedure:
  1- Add TI OMAP release PPA:
    $ sudo su -
    # export http_proxy=<your proxy if any>
    # export https_proxy=<your proxy if any>
    # add-apt-repository ppa:tiomap-dev/release
  2- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade
    $ sudo apt-get install ubuntu-omap4-extras
  3- You can re-run a dist-upgrade for safety at the end, then reboot

Update procedure:
1- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade


Post Installation Important Information:
* after the installation/update, it is advised to log as default user and to execute:
    # On Panda 4430: 
    $ /usr/bin/alsaucm -c Panda set _verb HiFi 
    # On PandaES 4460: 
    $ /usr/bin/alsaucm -c PandaES set _verb HiFi

* You need to force installation of new bootloaders (if any) through command:
    $ sudo /usr/sbin/flash-kernel --update-bootloader

* It is advised to use Ubuntu 2D instead of Ubuntu (3D) default UI. Nevertheless, main compiz issues have been fixed.

* In some cases, you might need to re-install dkms packages: after reboot,  check if omapdrm_pvr module is loaded, if not execute following command before to reboot:
    $ sudo apt-get install --reinstall pvr-omap4-dkms

New/Fixed in October 2012 release:
 * Kernel bug fixes:
- Rebase on Linux 3.4.11
- Panda DVI connector support
- DSS off mode support
 * Memory leaks during playback fixed
 * Decoder issues fixed
 * GBM/KMS support - Wayland DDK libs delivered.
 * Dual screen support on HDMI and DVI: you need to disable HWcursor in xorg.conf file, please edit /usr/share/X11/xorg.conf.d/99-omap.conf and add in section Device:
Option "HWcursor" "false"

Playing with GBM/KMS:
You just need to install following packages:
$ sudo apt-get install libwayland0 libgbm1

You can test now the kmscube test apps:
$ git clone git://github.com/robclark/kmscube.git

go into kmscube dir:
$ sudo apt-get install autoconf autotools-dev libtool libdrm-dev libwayland-dev libgbm-dev ubuntu-omap4-extras-graphics-dev
$ ./autogen.sh
$ make


Reboot with text in command line or stop lightdm with "sudo service lightdm stop"
If you have booted with text in bootargs, first execute "sudo pvrsrvinit", then execute:
$ sudo ./kmscube

Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Support:
updates for bug fixes in the PPA, so make sure to keep your system up-to-date!


Reference/Reminder:

The 'top-level' ubuntu-omap-extras will install the following packages:
 - ubuntu-omap-extras-multimedia: another meta package that installs all the requires packages for MM use case:
   * GST, a modified version still compatible with all Ubuntu apps such as totem
   * gst-ducati and libDCE the main components that bring MM h/w acceleration into the system
 - ubuntu-omap-extras-graphics: meta package that pulls in all GFX components including new X11 driver (binary blob) and SGX kernel module (source using DKMS to build)
 - ubuntu-omap-extras-config: some config scripts to set some permission issues, and to ensure that the Ducati firmware is loaded at boot time by upstart.

This release comes with the following major changes:
 - DCE interface for the h/w accelerated codecs - already there in 11.10
 - migration to rpmsg driver (aka syslink3, see http://lwn.net/Articles/448562/ and http://omappedia.org/wiki/Category:RPMsg)
 - DRI2 extension for Video support (http://www.phoronix.com/scan.php?page=news_item&px=OTgxOQ)
 - migration to a new open source X11 driver for OMAP (http://cgit.freedesktop.org/xorg/driver/xf86-video-omap/ )
 - a new GST video-sink: dri2videosink to display video through the SGX (instead of v4l2sink). For more information, see https://wiki.linaro.org/OfficeofCTO/MemoryManagement?action=AttachFile&do=view&target=linux-video.pdf
 - Linux 3.4 kernel, Ubuntu kernel will be replaced. This kernel is largely based of Linaro kernel, and sources are available here: http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git. Linux-image-<version> package version correspond to a tag ti-ubuntu-<kernel version>  in this tree.
 - ...

Regards, 
Xavier Boudet
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 denis....@ixonos.com 10/30/12 7:44 AM
Hello,

I have installed Ubuntu Core to the Pandaboard, updated it according to the instructions above, cross compiled Qt5 with wayland, eglfs, minimalegl and directfb support.
When I boot, I get a login prompt on the tty1, which is displayed on monitor connected to DVI-D connector of Pandaboard.
I can run weston from serial console, and tty1 disappear and only black screen is displayed.
If I run any Qt5 example with -platform wayland command line switch, it starts and runs but still no output is displayed on monitor.
If I run the same examples with -platform directfb, then some of them do run and do display something, although working partially.
If I run with -platform eglfs or minimalegl, then I get the following error:

# ./hellogl_es2 -platform minimalegl
gbmpvr: WSEGL_IsDisplayValid:77: hNativeDisplay=(nil)
PVR:(Warning): LoadWSModule: Window system module libpvrws_KMS.so did not validate native display [98, /generic_ws.c]
wlpvr: WSEGL_IsDisplayValid:174: hNativeDisplay=(nil)
PVR:(Warning): LoadWSModule: Window system module libpvrws_WAYLAND.so did not validate native display [98, /generic_ws.c]
PVR:(Warning): LoadWSModule: Window system module libpvrws_OMAPDRI2.so did not validate native display [98, /generic_ws.c]
Could not open egl display

EGL error
Aborted

However examples do work if I run them under X server.

My goal is to be abl to run Qt5 examples without using X on Pandaboard.

And I should also add, that kmscube demo works fine either from console or under X.
Before starting kmscube or weston, I do execute pvrsvrinit.
U-boot and kernel are the latest available from tiomap PPA.
Boot arguments are fixed to be without vram and new boot script is installed.

Do I miss something important?


Regards,
Denis Frolov



On Wednesday, October 3, 2012 4:07:05 PM UTC+3, Boudet, Xavier wrote:
New installation procedure:
  1- Add TI OMAP release PPA:
    $ sudo su -
    # add-apt-repository ppa:tiomap-dev/release
  2- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade
    $ sudo apt-get install ubuntu-omap4-extras
  3- You can re-run a dist-upgrade for safety at the end, then reboot

Update procedure:
1- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade


Post Installation Important Information:
* after the installation/update, it is advised to log as default user and to execute:
    # On Panda 4430: 
    $ /usr/bin/alsaucm -c Panda set _verb HiFi 

* You need to force installation of new bootloaders (if any) through command:
    $ sudo /usr/sbin/flash-kernel --update-bootloader

* In some cases, you might need to re-install dkms packages: after reboot,  check if omapdrm_pvr module is loaded, if not execute following command before to reboot:
    $ sudo apt-get install --reinstall pvr-omap4-dkms

Playing with GBM/KMS:
You just need to install following packages:
$ sudo apt-get install libwayland0 libgbm1

You can test now the kmscube test apps:
If you have booted with text in bootargs, first execute "sudo pvrsrvinit", then execute:
$ sudo ./kmscube

Known Issues:
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Assya 10/31/12 10:13 AM
Hi,
I have updated my Pandaboard according to these instructions (Ubuntu 12.04 Precise) - yet I fail to run OGLES executables obtained from Imagination PowerVR SDK (for SGX540 core) and I want to verify all my Open GL drivers are set/configured correctly.

me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
I$ ls
OGLES2HelloAPI  OGLESHelloAPI
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
I$ ./OGLESHelloAPI 
-bash: ./OGLESHelloAPI: No such file or directory
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
I$ ldd OGLESHelloAPI 
        not a dynamic executable
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
I$ file OGLESHelloAPI 
OGLESHelloAPI: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses
 shared libs), for GNU/Linux 2.6.14, not stripped


I suppose I will need to build them again for my system (as I am running Linux 3.4), yet I want to verify my OGLES drivers are configured correctly.
Can you please advise where can I obtain other OGLES demo's/executable to verify my only problem is the executable (built for older Linux)? 
Also , what are the OpenGL drivers (for  SGX540) that are being used for Pandaboaed? As I now understand this TI Installation guide for Graphics SDK is not relevant for PandaBoard (http://processors.wiki.ti.com/index.php/Graphics_SDK_Quick_installation_and_user_guide#Download_Information_for_TI_SGX_Graphics_SDK)?

Thank you, Assya.



On Wednesday, October 3, 2012 3:07:05 PM UTC+2, Boudet, Xavier wrote:
Hi there,

A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

New installation procedure:
  1- Add TI OMAP release PPA:
    $ sudo su -
    # export http_proxy=<your proxy if any>
    # export https_proxy=<your proxy if any>
    # add-apt-repository ppa:tiomap-dev/release
  2- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade
    $ sudo apt-get install ubuntu-omap4-extras
  3- You can re-run a dist-upgrade for safety at the end, then reboot

Update procedure:
1- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade


Post Installation Important Information:
* after the installation/update, it is advised to log as default user and to execute:
    # On Panda 4430: 
    $ /usr/bin/alsaucm -c Panda set _verb HiFi 
    # On PandaES 4460: 
    $ /usr/bin/alsaucm -c PandaES set _verb HiFi

* You need to force installation of new bootloaders (if any) through command:
    $ sudo /usr/sbin/flash-kernel --update-bootloader

* It is advised to use Ubuntu 2D instead of Ubuntu (3D) default UI. Nevertheless, main compiz issues have been fixed.

* In some cases, you might need to re-install dkms packages: after reboot,  check if omapdrm_pvr module is loaded, if not execute following command before to reboot:
    $ sudo apt-get install --reinstall pvr-omap4-dkms

New/Fixed in October 2012 release:
 * Kernel bug fixes:
- Rebase on Linux 3.4.11
- Panda DVI connector support
- DSS off mode support
 * Memory leaks during playback fixed
 * Decoder issues fixed
 * GBM/KMS support - Wayland DDK libs delivered.
 * Dual screen support on HDMI and DVI: you need to disable HWcursor in xorg.conf file, please edit /usr/share/X11/xorg.conf.d/99-omap.conf and add in section Device:
Option "HWcursor" "false"

Playing with GBM/KMS:
You just need to install following packages:
$ sudo apt-get install libwayland0 libgbm1

You can test now the kmscube test apps:
$ git clone git://github.com/robclark/kmscube.git

go into kmscube dir:
$ sudo apt-get install autoconf autotools-dev libtool libdrm-dev libwayland-dev libgbm-dev ubuntu-omap4-extras-graphics-dev
$ ./autogen.sh
$ make


Reboot with text in command line or stop lightdm with "sudo service lightdm stop"
If you have booted with text in bootargs, first execute "sudo pvrsrvinit", then execute:
$ sudo ./kmscube

Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Support:
updates for bug fixes in the PPA, so make sure to keep your system up-to-date!


Reference/Reminder:

The 'top-level' ubuntu-omap-extras will install the following packages:
 - ubuntu-omap-extras-multimedia: another meta package that installs all the requires packages for MM use case:
   * GST, a modified version still compatible with all Ubuntu apps such as totem
   * gst-ducati and libDCE the main components that bring MM h/w acceleration into the system
 - ubuntu-omap-extras-graphics: meta package that pulls in all GFX components including new X11 driver (binary blob) and SGX kernel module (source using DKMS to build)
 - ubuntu-omap-extras-config: some config scripts to set some permission issues, and to ensure that the Ducati firmware is loaded at boot time by upstart.

This release comes with the following major changes:
 - DCE interface for the h/w accelerated codecs - already there in 11.10
 - migration to rpmsg driver (aka syslink3, see http://lwn.net/Articles/448562/ and http://omappedia.org/wiki/Category:RPMsg)
 - DRI2 extension for Video support (http://www.phoronix.com/scan.php?page=news_item&px=OTgxOQ)
 - migration to a new open source X11 driver for OMAP (http://cgit.freedesktop.org/xorg/driver/xf86-video-omap/ )
 - a new GST video-sink: dri2videosink to display video through the SGX (instead of v4l2sink). For more information, see https://wiki.linaro.org/OfficeofCTO/MemoryManagement?action=AttachFile&do=view&target=linux-video.pdf
 - Linux 3.4 kernel, Ubuntu kernel will be replaced. This kernel is largely based of Linaro kernel, and sources are available here: http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git. Linux-image-<version> package version correspond to a tag ti-ubuntu-<kernel version>  in this tree.
 - ...

Regards, 
Xavier Boudet
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 ndec 10/31/12 10:37 AM
On Wed, Oct 31, 2012 at 6:13 PM,  <assya....@gmail.com> wrote:
> Hi,
> I have updated my Pandaboard according to these instructions (Ubuntu 12.04
> Precise) - yet I fail to run OGLES executables obtained from Imagination
> PowerVR SDK (for SGX540 core) and I want to verify all my Open GL drivers
> are set/configured correctly.
>
> me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
> I$ ls
> OGLES2HelloAPI  OGLESHelloAPI
> me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
> I$ ./OGLESHelloAPI
> -bash: ./OGLESHelloAPI: No such file or directory
> me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
> I$ ldd OGLESHelloAPI
>         not a dynamic executable
> me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAP
> I$ file OGLESHelloAPI
> OGLESHelloAPI: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically
> linked (uses
>  shared libs), for GNU/Linux 2.6.14, not stripped

i suspect the pre-built DDK samples are built for soft-float ABI, not
hard float. see

http://www.omappedia.com/wiki/Ubuntu_on_OMAP_FAQ#how_do_I_know_if_an_ARM_binary_is_built_for_soft-float_or_hard-float

>
>
>
> I suppose I will need to build them again for my system (as I am running
> Linux 3.4), yet I want to verify my OGLES drivers are configured correctly.

so yes you need to rebuild, but not because of kernel version, but ABI.

> Can you please advise where can I obtain other OGLES demo's/executable to
> verify my only problem is the executable (built for older Linux)?
> Also , what are the OpenGL drivers (for  SGX540) that are being used for
> Pandaboaed? As I now understand this TI Installation guide for Graphics SDK
> is not relevant for PandaBoard
> (http://processors.wiki.ti.com/index.php/Graphics_SDK_Quick_installation_and_user_guide#Download_Information_for_TI_SGX_Graphics_SDK)?

you should be able to recompile the IMG DDK samples from sources, but
for a quick test, we provide a simple test app in pvr-omap4-utils,
called /usr/bin/xgles2test1 which displays some 'spinning
triangles'...

the other option is to run kmscube, which would use gles but not X11.
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Jayneil 10/31/12 1:12 PM
Hi,

I tried installing the ppa updates on Pandaboard ES by following your instructions. But after doing so, Ubuntu won't boot at all. I tried it 4-5 times using different SD cards but still no luck. Everything works fine though before installing the ppa upates. 

Here is my logfile:

Here are my bootargs.

I would really appreciate if someone would help me solve this problem.

Cheers,
Jayneil.
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Assya 11/1/12 5:47 AM
Hi ndec,
thank you for your reply.

I have built the example (using the supplied make script) and still fail to run them on my pandaboard:

me@me-dt-panda:~$ ./OGLESHelloAPI 
-bash: ./OGLESHelloAPI: No such file or directory
me@me-dt-panda:~$ ldd OGLESHelloAPI 
        not a dynamic executable
me@me-dt-panda:~$ readelf -A OGLESHelloAPI 
Attribute Section: aeabi
File Attributes
  Tag_CPU_name: "5TE"
  Tag_CPU_arch: v5TE
  Tag_ARM_ISA_use: Yes
  Tag_THUMB_ISA_use: Thumb-1
  Tag_ABI_PCS_wchar_t: 4
  Tag_ABI_FP_denormal: Needed
  Tag_ABI_FP_exceptions: Needed
  Tag_ABI_FP_number_model: IEEE 754
  Tag_ABI_align_needed: 8-byte
  Tag_ABI_align_preserved: 8-byte, except leaf SP
  Tag_ABI_enum_size: int
  Tag_DIV_use: Not allowed
me@me-dt-panda:~$ file OGLESHelloAPI 
OGLESHelloAPI: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, not stripped

Does it mean I have a SOFT FLOAT ABI or HARD FLOAT ABI executable?
As it seems to me the binary I've built is also a SOFT FLOAT and I need HARD FLOAT, right? I remember I saw it when I have downloaded the pre-built image. How do I verify I need HARD FLOAT ABI on my system?
How do I build HARD FLOAT ABI? I am using Sourcery Codebench toolchain - is it configurable there?

I have checked readelf output for the pre-built example (I have executed originally):
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAPI$ ls -lF
total 22
-rwxrwxr-x 1 me me 11860 Oct 24 16:28 OGLES2HelloAPI*
-rwxrwxr-x 1 me me  9324 Oct 24 16:28 OGLESHelloAPI*
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAPI$ ./OGLESHelloAPI 
-bash: ./OGLESHelloAPI: No such file or directory
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAPI$ ldd OGLESHelloAPI 
        not a dynamic executable
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAPI$ file OGLESHelloAPI 
OGLESHelloAPI: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.14, not stripped
me@me-dt-panda:~/PowerVR_SDK/Binaries/Linux_armv7/Raw/Examples/Beginner/01_HelloAPI$ readelf -A OGLESHelloAPI 
Attribute Section: aeabi
File Attributes
  Tag_CPU_arch: v5TE
  Tag_ARM_ISA_use: Yes

I have executed the test application you suggested and saw for a glance the triangle:
me@me-dt-panda:/usr/bin$ xgles2test1 
--------------------- started ---------------------
gbmpvr: WSEGL_IsDisplayValid:77: hNativeDisplay=0x1f95070
PVR:(Warning): LoadWSModule: Window system module libpvrws_KMS.so did not validate native display [98, /generic_ws.c]
wlpvr: WSEGL_IsDisplayValid:174: hNativeDisplay=0x1f95070
PVR:(Warning): LoadWSModule: Window system module libpvrws_WAYLAND.so did not validate native display [98, /generic_ws.c]
PVR:(Warning): PVRSRVOpenDCDevice: Warning - 138 returned [80, /bridged_pvr_dc_glue.c]
Compiling program '/usr/share/sgx-lib/glsltest1_vertshader.txt', 262 bytes long
Compiling program '/usr/share/sgx-lib/glsltest1_fragshaderA.txt', 81 bytes long
Compiling program '/usr/share/sgx-lib/glsltest1_fragshaderB.txt', 214 bytes long
PVR:(Warning): PVRDRMSetFD: DRM fd already set [57, /pvr_bridge_u.c]
--------------------- finished ---------------------

Does this mean the TI DDK for SGX is installed and configured correctly in my system?
Can you please point me to the exact location (on the target) of the graphics library mentioned in Imagination SDK user guide?

I will try next to run kmscube.
Again, thank you for your help. 
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 rob 11/1/12 6:11 AM
On Tue, Oct 30, 2012 at 3:44 PM,  <denis....@ixonos.com> wrote:
> Hello,
>
> I have installed Ubuntu Core to the Pandaboard, updated it according to the
> instructions above, cross compiled Qt5 with wayland, eglfs, minimalegl and
> directfb support.
> When I boot, I get a login prompt on the tty1, which is displayed on monitor
> connected to DVI-D connector of Pandaboard.
> I can run weston from serial console, and tty1 disappear and only black
> screen is displayed.
> If I run any Qt5 example with -platform wayland command line switch, it
> starts and runs but still no output is displayed on monitor.

There is a special kernel needed, as some of the display updates
needed to make weston work (and also fix mouse issues w/ compiz) are
not in the release ppa.. see:

https://launchpad.net/~tiomap-dev/+archive/omap-trunk/+build/3882113

BR,
-R
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Assya 11/1/12 7:25 AM
Hi,
I want to run kmscube.
Can someone please specify how to set the bootargs to boot with text in command line? As I have read there are problems to start lightdm, after it was stopped.

Reboot with text in command line or stop lightdm with "sudo service lightdm stop"
If you have booted with text in bootargs, first execute "sudo pvrsrvinit", then execute:
$ sudo ./kmscube


On Wednesday, October 3, 2012 3:07:05 PM UTC+2, Boudet, Xavier wrote:
Hi there,

A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

New installation procedure:
  1- Add TI OMAP release PPA:
    $ sudo su -
    # export http_proxy=<your proxy if any>
    # export https_proxy=<your proxy if any>
    # add-apt-repository ppa:tiomap-dev/release
  2- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade
    $ sudo apt-get install ubuntu-omap4-extras
  3- You can re-run a dist-upgrade for safety at the end, then reboot

Update procedure:
1- Perform the upgrade:
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade


Post Installation Important Information:
* after the installation/update, it is advised to log as default user and to execute:
    # On Panda 4430: 
    $ /usr/bin/alsaucm -c Panda set _verb HiFi 
    # On PandaES 4460: 
    $ /usr/bin/alsaucm -c PandaES set _verb HiFi

* You need to force installation of new bootloaders (if any) through command:
    $ sudo /usr/sbin/flash-kernel --update-bootloader

* It is advised to use Ubuntu 2D instead of Ubuntu (3D) default UI. Nevertheless, main compiz issues have been fixed.

* In some cases, you might need to re-install dkms packages: after reboot,  check if omapdrm_pvr module is loaded, if not execute following command before to reboot:
    $ sudo apt-get install --reinstall pvr-omap4-dkms

New/Fixed in October 2012 release:
 * Kernel bug fixes:
- Rebase on Linux 3.4.11
- Panda DVI connector support
- DSS off mode support
 * Memory leaks during playback fixed
 * Decoder issues fixed
 * GBM/KMS support - Wayland DDK libs delivered.
 * Dual screen support on HDMI and DVI: you need to disable HWcursor in xorg.conf file, please edit /usr/share/X11/xorg.conf.d/99-omap.conf and add in section Device:
Option "HWcursor" "false"

Playing with GBM/KMS:
You just need to install following packages:
$ sudo apt-get install libwayland0 libgbm1

You can test now the kmscube test apps:
$ git clone git://github.com/robclark/kmscube.git

go into kmscube dir:
$ sudo apt-get install autoconf autotools-dev libtool libdrm-dev libwayland-dev libgbm-dev ubuntu-omap4-extras-graphics-dev
$ ./autogen.sh
$ make


Reboot with text in command line or stop lightdm with "sudo service lightdm stop"
If you have booted with text in bootargs, first execute "sudo pvrsrvinit", then execute:
$ sudo ./kmscube

Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Support:
updates for bug fixes in the PPA, so make sure to keep your system up-to-date!


Reference/Reminder:

The 'top-level' ubuntu-omap-extras will install the following packages:
 - ubuntu-omap-extras-multimedia: another meta package that installs all the requires packages for MM use case:
   * GST, a modified version still compatible with all Ubuntu apps such as totem
   * gst-ducati and libDCE the main components that bring MM h/w acceleration into the system
 - ubuntu-omap-extras-graphics: meta package that pulls in all GFX components including new X11 driver (binary blob) and SGX kernel module (source using DKMS to build)
 - ubuntu-omap-extras-config: some config scripts to set some permission issues, and to ensure that the Ducati firmware is loaded at boot time by upstart.

This release comes with the following major changes:
 - DCE interface for the h/w accelerated codecs - already there in 11.10
 - migration to rpmsg driver (aka syslink3, see http://lwn.net/Articles/448562/ and http://omappedia.org/wiki/Category:RPMsg)
 - DRI2 extension for Video support (http://www.phoronix.com/scan.php?page=news_item&px=OTgxOQ)
 - migration to a new open source X11 driver for OMAP (http://cgit.freedesktop.org/xorg/driver/xf86-video-omap/ )
 - a new GST video-sink: dri2videosink to display video through the SGX (instead of v4l2sink). For more information, see https://wiki.linaro.org/OfficeofCTO/MemoryManagement?action=AttachFile&do=view&target=linux-video.pdf
 - Linux 3.4 kernel, Ubuntu kernel will be replaced. This kernel is largely based of Linaro kernel, and sources are available here: http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git. Linux-image-<version> package version correspond to a tag ti-ubuntu-<kernel version>  in this tree.
 - ...

Regards, 
Xavier Boudet
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 11/5/12 1:00 AM
On 11/01/2012 01:47 PM, assya....@gmail.com wrote:
Hi ndec,
thank you for your reply.

I have built the example (using the supplied make script) and still fail to run them on my pandaboard:

me@me-dt-panda:~$ ./OGLESHelloAPI 
-bash: ./OGLESHelloAPI: No such file or directory
me@me-dt-panda:~$ ldd OGLESHelloAPI 
        not a dynamic executable
me@me-dt-panda:~$ readelf -A OGLESHelloAPI 
Attribute Section: aeabi
You are clearly using "aeabi". I suppose you are cross compiling, please use armhf cross compiler and that you have "-mfloat-abi=hard" in your CFLAGS (and not "-mfloat-abi=softfp")


I have executed the test application you suggested and saw for a glance the triangle:
me@me-dt-panda:/usr/bin$ xgles2test1 
--------------------- started ---------------------
gbmpvr: WSEGL_IsDisplayValid:77: hNativeDisplay=0x1f95070
PVR:(Warning): LoadWSModule: Window system module libpvrws_KMS.so did not validate native display [98, /generic_ws.c]
wlpvr: WSEGL_IsDisplayValid:174: hNativeDisplay=0x1f95070
PVR:(Warning): LoadWSModule: Window system module libpvrws_WAYLAND.so did not validate native display [98, /generic_ws.c]
PVR:(Warning): PVRSRVOpenDCDevice: Warning - 138 returned [80, /bridged_pvr_dc_glue.c]
Compiling program '/usr/share/sgx-lib/glsltest1_vertshader.txt', 262 bytes long
Compiling program '/usr/share/sgx-lib/glsltest1_fragshaderA.txt', 81 bytes long
Compiling program '/usr/share/sgx-lib/glsltest1_fragshaderB.txt', 214 bytes long
PVR:(Warning): PVRDRMSetFD: DRM fd already set [57, /pvr_bridge_u.c]
--------------------- finished ---------------------

Does this mean the TI DDK for SGX is installed and configured correctly in my system?
Yes, DDK is correctly installed.

Can you please point me to the exact location (on the target) of the graphics library mentioned in Imagination SDK user guide?
DDK libs are in /usr/lib, you can have the list of SGX packages with "dpkg -l | grep SGX".
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 denis....@ixonos.com 11/5/12 5:56 AM
Thank you for reply, Rob.
Wayland/weston do now work.

How about EGL errors?
They are still appear, if I try running any EGL-aware application, or Qt example with -platform eglfs switch.

WBR,
Denis
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Assya 11/5/12 8:06 AM
Hi,
I think I have solved the problem with the floating point ABI. However, I now get the following error:

me@me-dt-panda:~$ ./OGLESHelloAPI 
./OGLESHelloAPI: error while loading shared libraries: libGLES_CM.so: cannot open shared object file: No such f
ile or directory

Imagination PowerVR SDK documentation states that OpenGL ES libraries aren't distributed with the POWERVR Linux SDK and refers to the platform provider for these libraries (libGLES, libEGL, libGL).

I am also still have an error running ldd on the executable: not a dynamic executable.

Last request: can you please specify how to set the bootargs to boot with text in command line, for running the built kmscube.

Thank you,
Assya
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 ndec 11/5/12 4:16 PM
hi,

can you please create a proper forum topic for this issue? i think
this topic has become mostly unreadable...

thx
Re: [pandaboard] Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Assya 11/5/12 10:27 PM
Hi ndec,
I have posted my question on a new thread in pandaboard forum - as I am now not sure if this what you meant (or just a new post without quoting the old ones).
Can someone please specify how to set the bootargs to boot with text in command line? (In this thread)
Assya.
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 smith.wi...@gmail.com 2/26/13 5:48 PM
On Wednesday, October 3, 2012 9:07:05 AM UTC-4, Boudet, Xavier wrote:
A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

Known Issues:
* BT is not supported - shall be fixed next month.

Any update on BT support?  In particular integration of uim-sysfs into some kind of daemon?

Thanks,

W.
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Eloi Bail 3/1/13 8:00 AM
Hi, 

I am using pandaboard Rev A4.
I managed to enable HW decoding but erased my SD card and wanted to do it again. Now it is now working.
I followed user issues and your answer but can not have it working...

Could you please help me ? 

Thanks a lot,

Eloi



- My error :

DISPLAY=:0  GST_DEBUG=*:2,ducati*=5 gst-launch-0.10 filesrc location=/media/E7B0-F667/simpsons_movie_1080p_trailer.mp4 ! qtdemux ! queue ! ducatih264dec ! dri2videosink
Setting pipeline to PAUSED ...

libdce-x11.c:64: dce_auth_x11 info: attempting to open X11 connection
libdce.c:459: init error: could not get plugin ioctl base: -22
Setting pipeline to NULL ...
Freeing pipeline ...
0:00:00.430847161  2624   0x20a4c0 ERROR           GST_PIPELINE ./grammar.y:661:priv_gst_parse_yyparse: no element "2"
WARNING: erroneous pipeline: no element "2"

- my Packages

dpkg -l | grep -e gst -e linux-image -e pvr -e dce
ii  bluez-gstreamer                           4.98-2ubuntu7linaro1                       Bluetooth GStreamer support
ii  gir1.2-gst-plugins-base-0.10              0.10.36-1+ti1.6.7.1+1                      Description: GObject introspection data for the GStreamer Plugins Base library
ii  gir1.2-gstreamer-0.10                     0.10.36-1ubuntu1+ti1.6.3.2+1               Description: GObject introspection data for the GStreamer library
ii  gst-auto-launch                           0.3.21-3                                   This is an improved version of gst-launch that accepts commands.
ii  gstreamer-tools                           0.10.36-1ubuntu1+ti1.6.3.2+1               Tools for use with GStreamer
ii  gstreamer0.10-alsa                        0.10.36-1+ti1.6.7.1+1                      GStreamer plugin for ALSA
ii  gstreamer0.10-faac                        0.10.23-1+ti1.6.7.12+1                     FAAC plugin for GStreamer
ii  gstreamer0.10-ffmpeg                      0.10.13-1+ti1.6.2.1+1                      FFmpeg plugin for GStreamer
ii  gstreamer0.10-gconf                       0.10.31-1ubuntu2+ti1.6.4.1+1linaro1        GStreamer plugin for getting the sink/source information from GConf
ii  gstreamer0.10-gnomevfs                    0.10.36-1+ti1.6.7.1+1                      GStreamer plugin for GnomeVFS
ii  gstreamer0.10-nice                        0.1.1-2ubuntu1                             ICE library (GStreamer plugin)
ii  gstreamer0.10-plugin-ducati               1.6.7.20-1                                 gst-plugin-ducati is a Gstreamer plugin
ii  gstreamer0.10-plugins-bad                 0.10.23-1+ti1.6.7.12+1                     GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-base                0.10.36-1+ti1.6.7.1+1                      GStreamer plugins from the "base" set
ii  gstreamer0.10-plugins-base-apps           0.10.36-1+ti1.6.7.1+1                      GStreamer helper programs from the "base" set
ii  gstreamer0.10-plugins-good                0.10.31-1ubuntu2+ti1.6.4.1+1linaro1        GStreamer plugins from the "good" set
ii  gstreamer0.10-plugins-ugly                0.10.18.3-1ubuntu1+ti1.6.6.1+1             GStreamer plugins from the "ugly" set
ii  gstreamer0.10-pulseaudio                  0.10.31-1ubuntu2+ti1.6.4.1+1linaro1        GStreamer plugin for PulseAudio
ii  gstreamer0.10-sdl                         0.10.23-1+ti1.6.7.12+1                     GStreamer plugin for SDL output
ii  gstreamer0.10-tools                       0.10.36-1ubuntu1+ti1.6.3.2+1               Tools for use with GStreamer
ii  gstreamer0.10-x                           0.10.36-1+ti1.6.7.1+1                      GStreamer plugins for X11 and Pango
rc  libdce0                                   1.6.5.3-1                                  OMAP4 DCE library
ii  libdce1                                   1.6.7.3-2                                  OMAP4 DCE library
ii  libgstreamer-plugins-bad0.10-0            0.10.23-1+ti1.6.7.12+1                     GStreamer development files for libraries from the "bad" set
ii  libgstreamer-plugins-base0.10-0           0.10.36-1+ti1.6.7.1+1                      GStreamer libraries from the "base" set
ii  libgstreamer0.10-0                        0.10.36-1ubuntu1+ti1.6.3.2+1               Core GStreamer libraries and elements
ii  linux-image-3.4.0-1489-omap4              3.4.0-1489.22                              Linux kernel image for version 3.4.0 on TI OMAP4-based systems
ii  linux-image-3.4.0-2-linaro-lt-omap        3.4.0-2.2~ci+121213205906                  Linux kernel image for version 3.4.0 on TI OMAP-based systems
ii  linux-image-linaro-lt-omap                3.4.0.2.2                                  Linux kernel image for the OMAP architecture.
ii  linux-image-ti-omap4                      3.4.0.1489                                 Linux kernel image for the OMAP4 architecture.
ii  pvr-omap4                                 1.9.0.7.1.5-2                              Metapackage for TI PVR OMAP4 Graphics drivers
ii  pvr-omap4-data                            1.9.0.7.1.5-2                              PowerVR SGX540 libraries for OMAP4, data files
ii  pvr-omap4-dkms                            1.9.0.7.1.1-1                              PowerVR SGX540 kernel driver for OMAP4 in DKMS format.
ii  pvr-omap4-libs                            1.9.0.7.1.5-2                              PowerVR SGX540 libraries for OMAP4, remaining libs and binaries
ii  pvr-omap4-utils                           1.9.0.7.1.5-2                              PowerVR SGX540 utils for OMAP4
ii  pvr-omap4-xf86                            1.9.0.7.1.5-2                              X.org graphics -- TI OMAP pvr display driver
ii  python-gst0.10                            0.10.22-3                                  generic media-playing framework (Python bindings)
ii  ti-firmware-ipu-dce                       1.6+121207+151913+git17438c0               Texas Instruments firmware

- my bootloader script (mem attributes changed and flash-kernel update-bootloaders called)

more /media/boot/boot.scr
'Vʪ\B7aQ0Á\00\00\9E\00\00\00\00\00\00\00\005\E1\E8\A2\00boot.scr\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\96\00\00\00\00boot script
setenv initrd_high "0xffffffff"
setenv fdt_high "0xffffffff"
setenv bootcmd "fatload mmc 0:1 0x80200000 uImage; fatload mmc 0:1 0x81600000 uInitrd; fatload mmc 0:1 0x815f0000 board.dtb; bootm 0x80200000 0x81600000 0x815f0000"
setenv bootargs "console=tty0 console=ttyO2,115200n8  root=UUID=352d3e80-aaeb-4202-a824-32397383d7ea rootwait ro earlyprintk fixrtc nocompcache mem=1G@0x80000000"
boot

- my uboot

dpkg -l | grep u-boot-linaro
ii  u-boot-linaro-omap4-panda                 2012.08.2+6697+48+201211212230~precise1    U-Boot bootloader binary for the TI OMAP4 Panda board

- my loaded modules:

lsmod
Module                  Size  Used by
omapdrm_pvr           336846  0 
wl12xx                 13334  0 
wlcore                163986  1 wl12xx
mac80211              530759  1 wlcore
cfg80211              204870  2 wlcore,mac80211
bnep                   11557  2 
rfcomm                 39281  12 
omapdce                26475  0 
rpmsg_omx               9296  0 
omaprpc                18486  0 
omap_remoteproc         6099  4294967295 
rpmsg_resmgr_common     3282  0 
remoteproc             26460  3 rpmsg_omx,omap_remoteproc,rpmsg_resmgr_common
ppdev                   6739  0 
omap_rpmsg_resmgr       9586  0 
rpmsg_resmgr            7050  2 rpmsg_resmgr_common,omap_rpmsg_resmgr
virtio_rpmsg_bus       11933  4 omapdce,rpmsg_omx,omaprpc,rpmsg_resmgr
virtio                  5490  2 remoteproc,virtio_rpmsg_bus
virtio_ring             8369  2 remoteproc,virtio_rpmsg_bus
lp                      8917  0 
parport                37166  2 ppdev,lp
wlcore_sdio             3702  0 
btwilink                3794  0 
bluetooth             201817  24 bnep,rfcomm,btwilink
gator                  57960  1 
leds_gpio               3789  0 
gpio_keys               9032  0 
usbhid                 39129  0 
hid                    77135  1 usbhid
btrfs                 825861  0 
zlib_deflate           21307  1 btrfs
libcrc32c               1392  1 btrfs


Le mercredi 3 octobre 2012 09:07:05 UTC-4, Boudet, Xavier a écrit :
Hi there,

A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Support:
updates for bug fixes in the PPA, so make sure to keep your system up-to-date!


Reference/Reminder:

The 'top-level' ubuntu-omap-extras will install the following packages:
 - ubuntu-omap-extras-multimedia: another meta package that installs all the requires packages for MM use case:
   * GST, a modified version still compatible with all Ubuntu apps such as totem
   * gst-ducati and libDCE the main components that bring MM h/w acceleration into the system
 - ubuntu-omap-extras-graphics: meta package that pulls in all GFX components including new X11 driver (binary blob) and SGX kernel module (source using DKMS to build)
 - ubuntu-omap-extras-config: some config scripts to set some permission issues, and to ensure that the Ducati firmware is loaded at boot time by upstart.

This release comes with the following major changes:
 - DCE interface for the h/w accelerated codecs - already there in 11.10
 - migration to rpmsg driver (aka syslink3, see http://lwn.net/Articles/448562/ and http://omappedia.org/wiki/Category:RPMsg)
 - DRI2 extension for Video support (http://www.phoronix.com/scan.php?page=news_item&px=OTgxOQ)
 - migration to a new open source X11 driver for OMAP (http://cgit.freedesktop.org/xorg/driver/xf86-video-omap/ )
 - a new GST video-sink: dri2videosink to display video through the SGX (instead of v4l2sink). For more information, see https://wiki.linaro.org/OfficeofCTO/MemoryManagement?action=AttachFile&do=view&target=linux-video.pdf
 - Linux 3.4 kernel, Ubuntu kernel will be replaced. This kernel is largely based of Linaro kernel, and sources are available here: http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git. Linux-image-<version> package version correspond to a tag ti-ubuntu-<kernel version>  in this tree.
 - ...

Regards, 
Xavier Boudet

Le mercredi 3 octobre 2012 09:07:05 UTC-4, Boudet, Xavier a écrit :
Hi there,

A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Support:
updates for bug fixes in the PPA, so make sure to keep your system up-to-date!


Reference/Reminder:

The 'top-level' ubuntu-omap-extras will install the following packages:
 - ubuntu-omap-extras-multimedia: another meta package that installs all the requires packages for MM use case:
   * GST, a modified version still compatible with all Ubuntu apps such as totem
   * gst-ducati and libDCE the main components that bring MM h/w acceleration into the system
 - ubuntu-omap-extras-graphics: meta package that pulls in all GFX components including new X11 driver (binary blob) and SGX kernel module (source using DKMS to build)
 - ubuntu-omap-extras-config: some config scripts to set some permission issues, and to ensure that the Ducati firmware is loaded at boot time by upstart.

This release comes with the following major changes:
 - DCE interface for the h/w accelerated codecs - already there in 11.10
 - migration to rpmsg driver (aka syslink3, see http://lwn.net/Articles/448562/ and http://omappedia.org/wiki/Category:RPMsg)
 - DRI2 extension for Video support (http://www.phoronix.com/scan.php?page=news_item&px=OTgxOQ)
 - migration to a new open source X11 driver for OMAP (http://cgit.freedesktop.org/xorg/driver/xf86-video-omap/ )
 - a new GST video-sink: dri2videosink to display video through the SGX (instead of v4l2sink). For more information, see https://wiki.linaro.org/OfficeofCTO/MemoryManagement?action=AttachFile&do=view&target=linux-video.pdf
 - Linux 3.4 kernel, Ubuntu kernel will be replaced. This kernel is largely based of Linaro kernel, and sources are available here: http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git. Linux-image-<version> package version correspond to a tag ti-ubuntu-<kernel version>  in this tree.
 - ...

Regards, 
Xavier Boudet

Le mercredi 3 octobre 2012 09:07:05 UTC-4, Boudet, Xavier a écrit :
Hi there,

A major update has been done on TI PPA. Please read the below e-mail especially for upgrade.
If you do not have installed the TI release PPA, please refer to New installation procedure.

Known Issues:
* BT is not supported - shall be fixed next month.
* Black screen issue on some HW - workaround: Ctrl+Alt+F1 then Ctrl+Alt+F7 or boot with screen un-plugged, plug it after 1 minute. Issue under investigation.

Support:
updates for bug fixes in the PPA, so make sure to keep your system up-to-date!


Reference/Reminder:

The 'top-level' ubuntu-omap-extras will install the following packages:
 - ubuntu-omap-extras-multimedia: another meta package that installs all the requires packages for MM use case:
   * GST, a modified version still compatible with all Ubuntu apps such as totem
   * gst-ducati and libDCE the main components that bring MM h/w acceleration into the system
 - ubuntu-omap-extras-graphics: meta package that pulls in all GFX components including new X11 driver (binary blob) and SGX kernel module (source using DKMS to build)
 - ubuntu-omap-extras-config: some config scripts to set some permission issues, and to ensure that the Ducati firmware is loaded at boot time by upstart.

This release comes with the following major changes:
 - DCE interface for the h/w accelerated codecs - already there in 11.10
 - migration to rpmsg driver (aka syslink3, see http://lwn.net/Articles/448562/ and http://omappedia.org/wiki/Category:RPMsg)
 - DRI2 extension for Video support (http://www.phoronix.com/scan.php?page=news_item&px=OTgxOQ)
 - migration to a new open source X11 driver for OMAP (http://cgit.freedesktop.org/xorg/driver/xf86-video-omap/ )
 - a new GST video-sink: dri2videosink to display video through the SGX (instead of v4l2sink). For more information, see https://wiki.linaro.org
...
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 3/1/13 8:36 AM
According to the package versions, you are not using TI OMAP Release PPA.
Did you enabled a linaro-maintainers PPA?

Regards, Xavier Boudet
...
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Eloi Bail 3/4/13 2:26 PM
Hi,
Thanks for your answer. Your were right, I was missing some packages... 
It is now working right.

I still see some artifcats while playing H264 in 1080p. I was using the following command :

gst-launch filesrc location=/home/user/sample.mp4 ! qtdemux ! h264parse ! ducatih264dec !  pvrvideosink

But for sure it is much more better than using FFmpeg decoding.

I tried also to read RTSP streams on a pandaboard from my local rtsp server using this command:

gst-launch-0.10 -v rtspsrc location=192.168.50.113 name=t ! queue ! gstrtpjitterbuffer latency=1000 ! ducatih264dec !  pvrvideosink

Lot of frame must be dropped despite a good ethernet connection. 

Do you know how we could optimize it ?

Eloi
...
Re: Ubuntu Precise 12.04 - TI OMAP Release PPA Update October 2012 Xavier Boudet 3/4/13 11:57 PM
Hello,

You need to use "dri2videosink", pvrvideosink is still supported but dri2 is preferred.

Why don't you use playbin2 for pipelines?

Regards, Xavier Boudet
...
More topics »