problem with `opam init`

Showing 1-3 of 3 messages
problem with `opam init` Nathan Mishra Linger 9/28/12 8:27 PM
I tried to get opam running on my Ubuntu laptop.  After downloading
the 0.6.0 tarball from the OcamlPro tutorial page
(http://opam.ocamlpro.com/doc/Tutorial.html) and building and
installing it without incident, my first opam command fell over:

nathanml@panther:~$ opam init
File /home/nathanml/.opam/opam/benchmark.1.1.opam: Bad format!
Expecting list or list-list, got list({option(list({string("rm")
string("setup.ml")}),{string("%{ocaml-version}%") symbol(=)
string("4.00.0")}) option(list({string("oasis")
string("setup")}),{string("%{ocaml-version}%") symbol(=)
string("4.00.0")}) list({string("ocaml") string("setup.ml")
string("-configure") string("--prefix") string("%{prefix}%")})
list({string("ocaml") string("setup.ml") string("-build")})
list({string("ocaml") string("setup.ml") string("-install")})})
  'opam init' failed

I can't find the file mentioned here after this command runs (in fact
I still don't even have a $HOME/.opam), so I'm not sure how to get
past this problem.
Re: problem with `opam init` Anil Madhavapeddy 9/28/12 11:56 PM
Could you try it with a more recent version, such as 0.7.2?
https://github.com/OCamlPro/opam/tarball/0.7.2

I suspect the repository version may have moved beyond 0.6.0 as things are
rapidly being fixed (or it could be something else).  Hopefully this aspect
will stabilise soon, before it goes into a public beta.

-anil
Re: problem with `opam init` Nathan Mishra Linger 9/29/12 7:19 PM
Thanks for this suggestion.  It worked! :)

Now I've advanced to being stuck on
https://bitbucket.org/yminsky/ocaml-core/issue/3/exception-failure-could-not-configure-core
instead. :(