ocaml-core doesn't build with opam installed ocaml

Showing 1-2 of 2 messages
ocaml-core doesn't build with opam installed ocaml Sean McLaughlin 9/13/12 2:41 PM
Hi,

I tried to build core today using my opam-installed ocaml compiler.  It failed due to the error-enabled warnings.
It seems like we should try to get this to work out of the box, in case users want to work on core.

Best,

Sean

requesting all changes
adding changesets
adding manifests
adding file changes
added 140 changesets with 2188 changes to 1172 files
updating to branch default
cd ocaml-core
899 files updated, 0 files merged, 0 files removed, 0 files unresolved
$ cd ocaml-core-yminsky/
/usr/local/src/ocaml-core-yminsky
$ ./build-and-install 
=> base/type_conv
   * uninstalling
   * configuring
   * compiling
ocaml setup.ml -build 
/home/seanmcl/.opam/4.00.0/bin/ocamlopt.opt -I /home/seanmcl/.opam/4.00.0/lib/ocaml/ocamlbuild unix.cmxa /home/seanmcl/.opam/4.00.0/lib/ocaml/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml /home/seanmcl/.opam/4.00.0/lib/ocaml/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
ocamlfind ocamldep -package camlp4.quotations -package camlp4.extend -modules lib/pa_type_conv.mli > lib/pa_type_conv.mli.depends
ocamlfind ocamlc -c -g -w @Aemr-28 -strict-sequence -package camlp4.quotations -package camlp4.extend -I lib -o lib/pa_type_conv.cmi lib/pa_type_conv.mli
ocamlfind ocamldep -package camlp4.quotations -package camlp4.extend -syntax camlp4o -modules lib/pa_type_conv.ml > lib/pa_type_conv.ml.depends
ocamlfind ocamlc -c -g -w @Aemr-28 -strict-sequence -package camlp4.quotations -package camlp4.extend -syntax camlp4o -I lib -o lib/pa_type_conv.cmo lib/pa_type_conv.ml
+ ocamlfind ocamlc -c -g -w @Aemr-28 -strict-sequence -package camlp4.quotations -package camlp4.extend -syntax camlp4o -I lib -o lib/pa_type_conv.cmo lib/pa_type_conv.ml
File "lib/pa_type_conv.ml", line 275, characters 19-1267:
Warning 8: this pattern-matching is not exhaustive.
Here is an example of a value that is not matched:
(TyTypePol (_, _, _)|TyAnP _|TyAnM _)
File "lib/pa_type_conv.ml", line 4, characters 0-11:
Warning 33: unused open Lexing.
File "lib/pa_type_conv.ml", line 12, characters 4-8:
Warning 32: unused value both.
File "lib/pa_type_conv.ml", line 1:
Error: Error-enabled warnings (3 occurrences)
Command exited with code 2.
E: Failure("Command '/home/seanmcl/.opam/4.00.0/bin/ocamlbuild lib/pa_type_conv.cma -tag debug' terminated with error code 10")
make: *** [build] Error 1
*** ERROR: Couldn't compile type_conv
EXIT STATUS 1
/usr/local/src/ocaml-core-yminsky
Re: ocaml-core doesn't build with opam installed ocaml Yury 9/13/12 3:13 PM
Hi Sean, the released packages are more up-to-date than the bitbucket tree right now. The tree will get updated with the next release, 108.08.

Yury