NPM no longer working, can anyone help?

Showing 1-2 of 2 messages
NPM no longer working, can anyone help? @Marnix_IxD 10/13/12 2:11 PM
Hi, a couple of months back I installed node before (can't remember which version it was), but haven't done much with it, I now tried to upgrade to the latest version using the v0.8.12 installer, unfortunately now I can't use NPM as it gives me the following error:

Error: npm doesn't work with node v0.8.12
Required: node@0.4 || 0.5 || 0.6
    at /usr/lib/node_modules/npm/bin/npm-cli.js:57:23
    at Object.<anonymous> (/usr/lib/node_modules/npm/bin/npm-cli.js:77:3)
    at Module._compile (module.js:449:26)
    at Object.Module._extensions..js (module.js:467:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.runMain (module.js:492:10)
    at process.startup.processNextTick.process._tickCallback (node.js:244:9)

Am I the only one having this problem with the latest installer?
Can anyone tell me how to get it to work again?
Does the installer clear all old content for node.js & npm or do I need to do this manually, if so which terminal commands do I use for this?

Thank you very much for any help,

Marnix

Re: NPM no longer working, can anyone help? mscdex 10/13/12 2:57 PM
On Oct 13, 5:11 pm, "@Marnix_IxD" <marnix.puij...@gmail.com> wrote:
> Hi, a couple of months back I installed node before (can't remember which
> version it was), but haven't done much with it, I now tried to upgrade to
> the latest version using the v0.8.12 installer, unfortunately now I can't
> use NPM as it gives me the following error:

Probably you have an older versino of npm installed in a path that is
before the one you installed with node 0.8.12 in $PATH.

Execute `which npm` to find where it's installed at and delete all of
the relevant files there.