tried to start HA cluster on one node, failed with weird error

Showing 1-3 of 3 messages
tried to start HA cluster on one node, failed with weird error Alex Frieden 10/17/13 7:12 AM
Got this error when starting Neo 2.0.0M5 java.lang.IllegalStateException: i was denied entry
what does it mean?

Console.log:
java.lang.RuntimeException: Error starting org.neo4j.kernel.ha.HighlyAvailableGraphDatabase, /data/neo4j/neo4j-enterprise-2.0.0-M05/data/graph.db
        at org.neo4j.kernel.InternalAbstractGraphDatabase.run(InternalAbstractGraphDatabase.java:323) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.kernel.ha.HighlyAvailableGraphDatabase.<init>(HighlyAvailableGraphDatabase.java:156) ~[neo4j-ha-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.graphdb.factory.HighlyAvailableGraphDatabaseFactory$1.newDatabase(HighlyAvailableGraphDatabaseFactory.java:47) ~[neo4j-ha-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.graphdb.factory.GraphDatabaseBuilder.newGraphDatabase(GraphDatabaseBuilder.java:197) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.server.enterprise.EnterpriseDatabase$DatabaseMode$2.createDatabase(EnterpriseDatabase.java:64) ~[neo4j-server-enterprise-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.server.enterprise.EnterpriseDatabase.start(EnterpriseDatabase.java:89) ~[neo4j-server-enterprise-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:137) ~[neo4j-server-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.server.Bootstrapper.start(Bootstrapper.java:86) [neo4j-server-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.server.Bootstrapper.main(Bootstrapper.java:49) [neo4j-server-2.0.0-M05.jar:2.0.0-M05]
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.kernel.lifecycle.LifeSupport@71fbb079' was successfully initialized, but failed to start. Please see attached cause exception.
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:504) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:115) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.kernel.InternalAbstractGraphDatabase.run(InternalAbstractGraphDatabase.java:300) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        ... 8 common frames omitted
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.cluster.client.ClusterClient@6645d273' was successfully initialized, but failed to start. Please see attached cause exception.
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:504) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:115) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:498) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        ... 10 common frames omitted
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.cluster.client.ClusterJoin@609bb740' was successfully initialized, but failed to start. Please see attached cause exception.
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:504) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:115) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.cluster.client.ClusterClient.start(ClusterClient.java:421) ~[neo4j-cluster-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:498) ~[neo4j-kernel-2.0.0-M05.jar:2.0.0-M05]
        ... 12 common frames omitted
java.lang.IllegalStateException: i was denied entry
        at org.neo4j.cluster.protocol.cluster.ClusterState$2.handle(ClusterState.java:199) ~[neo4j-cluster-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.cluster.protocol.cluster.ClusterState$2.handle(ClusterState.java:121) ~[neo4j-cluster-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.cluster.statemachine.StateMachine.handle(StateMachine.java:88) ~[neo4j-cluster-2.0.0-M05.jar:2.0.0-M05]
        at org.neo4j.cluster.StateMachines$1.run(StateMachines.java:135) ~[neo4j-cluster-2.0.0-M05.jar:2.0.0-M05]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) ~[na:1.7.0_09-icedtea]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) ~[na:1.7.0_09-icedtea]
        at java.lang.Thread.run(Thread.java:722) ~[na:1.7.0_09-icedtea]
2013-10-17 14:10:01.192+0000 DEBUG [API] Failed to start Neo Server on port [7474]
Re: [Neo4j] tried to start HA cluster on one node, failed with weird error Michael Hunger 10/20/13 11:35 PM
Did you set different server-id's for each of the instances?

Sent from mobile device
--
You received this message because you are subscribed to the Google Groups "Neo4j" group.
To unsubscribe from this group and stop receiving emails from it, send an email to neo4j+un...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
Re: [Neo4j] tried to start HA cluster on one node, failed with weird error Alex Frieden 10/21/13 7:30 AM
Ya the server ids were duplicated.  Fixed it, got it working.