Can't compile XPCOM extension after upgrading to FF 25 sdk

Showing 1-9 of 9 messages
Can't compile XPCOM extension after upgrading to FF 25 sdk getan...@gmail.com 11/2/13 3:28 PM
Compiling my add-in is definitely broken in FF 25. I get errors like the following, which I can’t make sense of. I'm sure it's something simple, like the order of #includes or something. I'm using Visual Studio 2010. Any help would be greatly appreciated!

… xpcom-25.0\gecko-sdk\include\mozilla/Atomics.h(714): error C2059: syntax error : ‘sizeof’
… xpcom-25.0\gecko-sdk\include\mozilla/Atomics.h(717) : see reference to class template instantiation ‘mozilla::detail::IntrinsicBase’ being compiled
… xpcom-25.0\gecko-sdk\include\mozilla/Atomics.h(715): error C2059: syntax error : ‘)’
… xpcom-25.0\gecko-sdk\include\mozilla/Atomics.h(715): error C2143: syntax error : missing ‘)’ before ‘;’
… xpcom-25.0\gecko-sdk\include\mozilla/Atomics.h(715): error C4430: missing type specifier – int assumed. Note: C++ does not support default-int
… xpcom-25.0\gecko-sdk\include\mozilla/Atomics.h(715): warning C4183: ‘static_assert’: missing return type; assumed to be a member function returning ‘int’

Thanks,
Nicholas
Re: Can't compile XPCOM extension after upgrading to FF 25 sdk April Morone 11/2/13 8:24 PM
Let me do research o fugre it out and then let you know what I find out.
> _______________________________________________
> dev-extensions mailing list
> dev-ext...@lists.mozilla.org
> https://lists.mozilla.org/listinfo/dev-extensions
>
Re: Can't compile XPCOM extension after upgrading to FF 25 sdk April Morone 11/2/13 8:25 PM
Wait... what version of C++ are you using?
On Nov 2, 2013 6:30 PM, <getan...@gmail.com> wrote:

Re: Can't compile XPCOM extension after upgrading to FF 25 sdk April Morone 11/2/13 9:08 PM
Be sure to that you include <string> and either use namespace or append
std:: along with/to each time that you end up mention string.  Use this
link to read about this information, please :
http://www.cplusplus.com/forum/windows/51935/.  Hope this information helps.
April Morone
On Nov 2, 2013 6:30 PM, <getan...@gmail.com> wrote:

Re: Can't compile XPCOM extension after upgrading to FF 25 sdk Kyle Huey 11/2/13 9:14 PM
> _______________________________________________
> dev-extensions mailing list
> dev-ext...@lists.mozilla.org
> https://lists.mozilla.org/listinfo/dev-extensions
>

Sounds like you are using a compiler that doesn't support static_assert.
As of Gecko 25 such compilers are no longer supported.  See bug 895322 for
details.  You probably just need to upgrade your gcc.

- Kyle
Re: Can't compile XPCOM extension after upgrading to FF 25 sdk Neil 11/3/13 2:51 AM
You may be using Visual Studio 2010 but are you using Visual C++ 10?
Your project may have been set up to use Visual C++ 9 instead and this
won't work. See http://stackoverflow.com/a/7417820

--
Warning: May contain traces of nuts.
Re: Can't compile XPCOM extension after upgrading to FF 25 sdk April Morone 11/3/13 5:10 AM
I agree with Neil.  He is thinking along the same lines as me (I'd asked
you@ earlier, bfore he posted a response to you about which version of C++
you are using because I thought it could make the difference in the
project.  Neil is apparently mentioning this same thing as I'd previously
mention before I'd also mentioned about str:: (I think it could be both
str:: issue and also of the C++ you might be using.
April Morone
On Nov 2, 2013 6:30 PM, <getan...@gmail.com> wrote:

Re: Can't compile XPCOM extension after upgrading to FF 25 sdk getan...@gmail.com 11/3/13 4:46 PM

> You may be using Visual Studio 2010 but are you using Visual C++ 10?
>
> Your project may have been set up to use Visual C++ 9 instead and this
>
> won't work. See http://stackoverflow.com/a/7417820

Just seeing these responses now. Thanks for all the suggestions! This one was the culprit. Somehow my project was set to compile with VC9 instead of 10. I changed the setting in the project options and had to tweak a couple of header files and it compiles.
Re: Can't compile XPCOM extension after upgrading to FF 25 sdk April Morone 11/4/13 12:50 AM
Yay!  Glad it works for you, now.  :)
> _______________________________________________
> dev-extensions mailing list
> dev-ext...@lists.mozilla.org
> https://lists.mozilla.org/listinfo/dev-extensions
>



--
http://aprilmorone.blogspot.com/