bukkit doesn't work with 0.5.0?

Showing 21-41 of 41 messages
bukkit doesn't work with 0.5.0? Kyle 10/23/12 8:11 PM
Hi,

I just thought I would give 0.5.0 a try.  I am getting an error and can't seem to start my server.  I get this error every time I try anything:

'NoneType' object has no attribute 'startswith'
Re: bukkit doesn't work with 0.5.0? Will 10/23/12 8:47 PM
What method did you do to copy the scripts?
Did you get any errors?

If you look at the files in /usr/games/minecraft, do they match the ones here?

Re: bukkit doesn't work with 0.5.0? Kyle 10/23/12 9:29 PM
I just clicked update in the webui.  I'm guessing that was a mistake...
Yes, it said {failed: null}, I believe.  However, after restarting my browser the new webui appeared.

I will check those files and get back to you.
Re: bukkit doesn't work with 0.5.0? Will 10/23/12 9:51 PM
Well, the new web-ui won't work with the old scripts, so restarting your browser/clearing your cache would've been necessary--have you tried doing anything when the new web-ui was actually showing?
Re: bukkit doesn't work with 0.5.0? Kyle 10/23/12 9:57 PM
Ok, I can successfully start a bukkit server, however I'm experiencing two issues:

1) After starting it in the server status page it remains being "down", even though it shows as being "up" on the "backup and restore" page.  Then after restarting my browser nothing is listed on the server status page at all.

2) I cannot view the console messages.
Re: bukkit doesn't work with 0.5.0? Kyle 10/23/12 10:00 PM
Oh and I checked those files you listed.  They're all there and I overwrote them with yours.
Re: bukkit doesn't work with 0.5.0? Will 10/23/12 10:33 PM
Is this an existing bukkit server you're working with?  

Delete the server.config in the servers directory if so.

Re: bukkit doesn't work with 0.5.0? Kyle 10/24/12 6:18 AM
Yes it is.  I had noticed that the server.config and server.properties files were different in a new bukkit server, so I replaced* them with the new config and properties file.  I will try starting it without a config and properties file as you suggest.

*Actually, I wanted to preserve my old server folder in case I can't get 0.5.0 to work, so I copied the contents (except for those 2 files) into a new bukkit server.
Re: bukkit doesn't work with 0.5.0? Kyle 10/24/12 6:19 AM
Sorry, I mean I'll only delete the config file.
Re: bukkit doesn't work with 0.5.0? Kyle 10/24/12 6:26 AM
Ok, after deleting the config file, it treated it as a vanilla server, so I had to modify the config so it would use the bukkit profile.  It seems to be working now!  Thank you!!!
Re: bukkit doesn't work with 0.5.0? Kyle 10/24/12 6:52 AM
Now my console is getting spammed with messages like this:

127.0.0.1:41628 lost connection

I understand 127.0.0.1 is home, so it's the actual server computer itself... talking to itself? And failing? I'm at a loss.
Re: bukkit doesn't work with 0.5.0? Joel Falknau 10/24/12 7:07 AM
Nothing to worry about, simple spam that will I'd working on eliminating
Re: bukkit doesn't work with 0.5.0? Kyle 10/24/12 8:04 AM
Awesome!

Sent from my iPhone
Re: bukkit doesn't work with 0.5.0? Joel Falknau 10/24/12 9:28 PM
read this post by will if you want some more info https://groups.google.com/d/msg/mineos/EoR7g3xkB-s/TvBALPY7OZAJ
Re: bukkit doesn't work with 0.5.0? Kyle 10/27/12 9:26 PM
Sorry, Will.  I know you've been working so hard on 0.5.0, but I just can't seem to get it to work.  I want to go back to 0.4.11e.  I tried reinstalling it, but it seems that the iso you have online is 0.4.9.  Is there any way I can update to just 0.4.11e?

Kyle


On Tuesday, October 23, 2012 10:33:00 PM UTC-7, Will wrote:
Re: bukkit doesn't work with 0.5.0? Will 10/28/12 11:53 AM


On Saturday, October 27, 2012 9:26:41 PM UTC-7, Kyle wrote:
Sorry, Will.  I know you've been working so hard on 0.5.0, but I just can't seem to get it to work.  I want to go back to 0.4.11e.  I tried reinstalling it, but it seems that the iso you have online is 0.4.9.  Is there any way I can update to just 0.4.11e?

I thought you said you got it working?

Well, I guess if you really want to use the older scripts, you can, as they are still available online:


0.4.11e are in the /usr/games/minecraft and /var/www/hiawatha/admin directories--but avoid the stable and beta directories...those are 0.5.x

Keep in mind 0.4.x is finished (in my mind), so I would say with certainty it won't be getting updated ever again--0.5.0 has a few snags but ultimately I think is going to provide a much more straightforward experience, especially with the being done with 'template', 'foreign' and lock-based status things i had before.  I find that a clean install of 0.4.x (I actually work with an 0.4.9 iso, at that), and it updates 100% of the time no issues.
Re: bukkit doesn't work with 0.5.0? Kyle 10/28/12 2:44 PM
Yeah, it was. Then it stopped appearing in the list of servers.

I'm sure 0.5 will be the way to go in the future, but I'm not ready to trouble shoot right now. I accidentally updated when everything was working perfectly.

Sent from my iPhone
Re: bukkit doesn't work with 0.5.0? Ian M. Melsom 10/28/12 4:56 PM
A couple of things to chekc out before you dismiss (and blame) the latest version of MineOS entirely:

1. Did your pre 0.5 mineos server have any other chars init than letters ¤ numbers Inlcuding " ", _ , - , comma, or period? The new version of MineOS do not support servers with other charatcters than alphanumeric and _ ..  To get such a server to work, rename its server folder to something without any of the illegal characters. (I had the same dissaperaring server syndrome)

2. If it is only bukkit that is crashing  the latest Minecraft version (1.42) do not support bukkit, or rather.. The latest released version of Bukkit is to old for the latest version of Minecraft. Have you tried reconfiguring your server to a vanilla? (Mine is now vanilla untill bukkit gets updated to the latest minecraft-version)

3. Also. have you tried downloading the latest bukkit-jar  from bukkit.org? I have had problems letting the scrips autoupdate bukkit. Doing it manually, and configuring the servers to use the file I DL'ed manually, usually solved any non functionating bukkit problems for me.

iMelsom
Re: bukkit doesn't work with 0.5.0? Kyle 10/28/12 6:00 PM
I appreciate the suggestions.

1. No, the name of the server in question is "two".
2. I'm not trying to run 1.4.2 bukkit (as it doesn't exist yet).  I never switch to vanilla while Bukkit is trying to catch up.  Things could get stolen or griefed.
3. At the time it was running the latest recommended build of bukkit.
Re: bukkit doesn't work with 0.5.0? ad...@reviews.wox.org 10/28/12 8:12 PM
I usually run a test/fallback server with a fresh map on
vanilla, while bukkit catches up - or with a dumpcopy of my
main world in the end world for people to take their
frustration out on. (end world wont generate new chunks, so
you can explore to the end of the world! woo)

That way players can familiarise themself with the new game
features while i troll through all my plugins for updates to
the real server.

Only trouble with that was one update took so long for
bukkit to catch up some players actually preferred the
fallback world.. so i had to copy it to multiverse on my
main server HA!

BTW on point 2 - the 4.0 series is the new dev bukkit,
works, breaks about 25% of your old plugins,  and the new
mobs dont work right yet, also noticed some visual-range
artifacts; like people in fly mode appear to be halfway in
the blocks below.   Luckily lockette/worldguard didnt break
so players can limp on..

kills the old citizens plugin dead tho.. so bye bye npc
merchants :(also killed the disguise plugins so that ruined
our halloween event this year, staaff are using wither masks
instead :o(
Re: bukkit doesn't work with 0.5.0? Kyle 11/3/12 12:23 AM
Those are some smart ideas.

I should point out that I have upgraded to 0.5.0.  I wasn't having much success with downgrading... so, I guess I'll just deal with it.  I've stopped hosting my server publicly anyhow, but will still play around with mineos if only for myself.

That being said, I do like the new webui.  It's very spiffy.