Modified Scripts

Showing 1-26 of 26 messages
Modified Scripts Andrew Kallmeyer 3/9/12 6:49 PM
I've made some modifications to the webui python scripts and I wanted to share my work. So here it is: https://github.com/Fsmv/MineOSCrux-Fork. I have added Technic Pack support and I fixed the user list reporting to get rid of the terminal colors in the name list. This fixes the bug that makes bukkit servers display the incorrect number of online players in the webui.
Re: Modified Scripts Zone 3/9/12 8:48 PM
thank you!
Re: Modified Scripts Andrew Kallmeyer 3/31/12 6:30 PM
I updated again. Here are the changes:
  • Added Ability to choose to use c10t, pigmap, or both for mapping
  • Map and Backup commands notify the server with the say command
  • Added the 0.4.11b changes
Re: Modified Scripts Darkhand 4/5/12 12:55 PM
Cool!  I had an issue with the fix for the color code in the Bukkit name list:

mineos.py, line 1105:

You check for 0]m, but I had to change the match to [0m to get it to match, including adding an escape character at the beginning which I can't post properly here.  so [ESC][0m is what I needed to change it to.
Re: Modified Scripts cian.m...@gmail.com 4/21/12 2:09 AM
Hi. Thanks for your efforts ^.^

Just two questions, first where are the example minecraft.config and server.config's that you mentioned in README.md? Second do you have any examples for Tekkit? I always manage to just completely bork MineOS CRUX when trying to install that, so I wouldn't mind seeing one before I stuff it up again,

Thanks :D
Re: Modified Scripts cian.m...@gmail.com 4/21/12 2:54 AM
Ohp silly me they are in the tarball :/
Re: Modified Scripts cian.m...@gmail.com 4/21/12 4:22 AM
Still having trouble setting up a tekkit server though. Can someone please throw me a bone? Thanks :p
Re: Modified Scripts Andrew Kallmeyer 4/21/12 6:52 AM
You got this scripts installed right? They go it /usr/games/minecraft/ and you should backup the ones that are already there or just overwrite them.

Once you have that, log into the admin panel and you should be able to download the tekkit jar just like any other server jar right from the welcome page.
Once the tekkit jar is downloaded /usr/games/minecraft should look like this:

mineos.config           mineos_console.pyc
addons                        mineos.log              pigmap
craftbukkit.jar               mineos.py               server.py
go.class                      mineos.py.orig          server.py.orig
master                        mineos.pyc              tekkit
minecraft_server.jar          mineos_console.py       tekkit.zip
minecraft_server_nomod.jar    mineos_console.py.orig  update.sh


You'll need to modify the config files. I have examples at server.config and mineos.config. If you want a newer version of tekkit you'll have to change the link in mineos.config. The setting is tekkit_ziploc. The link for the newest version is https://github.com/downloads/TechnicPack/Technic/Tekkit_Server_2.1.1.zip
I'm not 100% sure but I don't think you'll have go.class that's probably an experiment I was working on. Anyway, you can then create a tekkit server just like you create a bukkit server. It will create the necessary files and be able to run tekkit.
Re: Modified Scripts Qualsa 5/13/12 2:18 PM
Could someone help me out? I did everything that it said on github, yet all that happened is the admin webpanel now has nothing in it and none of the links work. :(
Re: Modified Scripts Andrew Kallmeyer 5/16/12 2:07 PM
Sorry it took so long to get back, could you run ls -l in the /usr/games/minecraft directory and post the results? I suspect there may be a permissions problem. Each .py file should have permissions and group ownership that match this -rwxr-xr-x 1 mc games. If I'm right on yours the Xs will be missing.

This can be fixed by running
chmod +x *.py

Let me know what happens, I still could help if that doesn't work.
Re: Modified Scripts Alan 5/16/12 4:09 PM
Any chance you'll be updating the scripts with all the latest bug fixes Will has done? (I'm assuming since the last github changes, none have been implemented).

Thanks.
Re: Modified Scripts Andrew Kallmeyer 5/16/12 5:27 PM
Did he update the scripts? I have 0.4.11b patched into my scripts which seems to be the latest update.
Re: Modified Scripts Alan 5/16/12 7:06 PM
When I update it, it always says 0.4.11b
Re: Modified Scripts Alan 5/16/12 7:06 PM
Errr 0.4.11d sorry.
Re: Modified Scripts joshin...@gmail.com 8/24/12 12:32 PM
I have everything installed correctly, everything downloaded correctly, every link updated correctly. I create a new server in the webui using the tekkit.jar, it adds it as a template. I click start, but after the command executes (which takes much longer than it should) the server status is still "down"


On Friday, March 9, 2012 9:49:36 PM UTC-5, Andrew Kallmeyer wrote:
I've made some modifications to the webui python scripts and I wanted to share my work. So here it is: https://github.com/Fsmv/MineOSCrux-Fork. I have added Technic Pack support and I fixed the user list reporting to get rid of the terminal colors in the name list. This fixes the bug that makes bukkit servers display the incorrect number of online players in the webui.
Re: Modified Scripts Andrew Kallmeyer 8/30/12 9:15 PM
Check the logs for the server and mineos and post them here, I'll see if I can help. The server logs are in /home/mc/servers/[SERVER NAME]/server.log and the mineos logs are in /usr/games/minecraft/mineos.log
Re: Modified Scripts asurb...@gmail.com 9/10/12 2:17 PM
I must say...tekkit in mineos is the best idea ive ever heard of! I'm not sure however if the scripts I have are buggy or what but I just cant seem to get the server to start correctly. As someone else before had said I too find myself coming back to the original page for servers to find that it isn't up and running. I'm on my iPad right now but when I get onto my desktop I'll post the server logs.
Re: Modified Scripts asurb...@gmail.com 9/11/12 9:22 PM
Ok, I've finally came up with a solution to the problem! These scripts aren't geared for tekkit 3.1.2...it just doesn't work. As such take this link and place it in your tekkit zip location:


Once you have this done you should then do update jars to get the latest files there. Next is to create a server so do that in your mineos admin panel and mark it as tekkit.jar in the dropdown. Finally since this version of tekkit is NOT the recommended build you will have to change that in the launcher. Click on options in your launcher then click Use Manual Build Selection, then select Version 3.0.3 for Minecraft 1.2.5. After which you click ok and then login with an update. Your server should now appear when you type the correct address in. If it doesn't ping the there are 2 things I would recommend.

1. First off the port has to be excused through the firewall as the server has a built in defense mechanism which is the firewall. To get through this use:

"iptables -A INPUT -p tcp -m tcp --dport 25570 -j ACCEPT"

Without the "" and substitute 25570 for the port you are selecting to open for the server to pass through.

2. If you want friends to connect over the WAN, or Internet in simpler terms, you must go into your routers setup and configure port forwarding. The address for your router is most likely 192.168.1.1 and the login will most likely be USERNAME: Admin PASSWORD: Either Password or Admin depending on router type.

I hope this helped at least one of you out there as if it did then my job is complete.
Good Luck :D
Re: Modified Scripts Andrew Kallmeyer 9/11/12 9:30 PM
I've got mine running 3.1.2. Try unpacking the zip manually and putting the files in the Tekkit folder in /usr/games/minecraft the zip must be packaged differently and the script I wrote can't figure out extracting it. I'll see about fixing it tomorrow I guess.
Re: Modified Scripts asurb...@gmail.com 9/13/12 6:41 PM
In the meantime I find it much more conveinient to use 3.0.4 server version as it is completely automated. Thanks for replying Andrew :D


On Friday, March 9, 2012 9:49:36 PM UTC-5, Andrew Kallmeyer wrote:
Re: Modified Scripts Andrew Kallmeyer 9/16/12 7:14 PM
Sorry it took me so long to get back to you. I'm pretty sure I've fixed it now and the webui should be able to update tekkit properly now. You'll only need to update mineos.py to get the newest changes.
Re: Modified Scripts Will 9/16/12 7:44 PM
If you need help with extracting archives, take a look at my 0.5.0 scripts--they handle Tekkit just fine
Re: Modified Scripts Andrew Kallmeyer 9/16/12 7:57 PM
Oh, I thought I had pulled your implementation of tekkit extracting. Anyway, it wasn't an issue with extracting the zip it was in issue with a certain mod changing their filename as it updates so when you update an old installation with a new version of tekkit the new and old versions of that mod get installed because the old one doesn't get overwritten. I fixed that by just deleting the old extracted tekkit directory every time it goes to extract the new zip.
Re: Modified Scripts asurb...@gmail.com 9/17/12 8:49 PM
Ok, so tekkit is now working with 3.1.2. However, my friends and I have grown attached to the Crafting table III so I think we will be sticking with 3.0.3. Thanks for the help and for the modified scripts as a whole, they we're the most useful choice I'd made since I started using MineOS,  and using MineOS was a really good choice as well! Much less lag as compared to Windows machines.
Re: Modified Scripts chessehead17 9/23/12 2:40 AM
OK i figured i would give this a shot but as right after i did the final step in the read-me ( change the config files) i did a system reboot just because and now the web GUI has nothing. as in no words, no hyperlinks, and when you click the button you get nothing. i did this on a VM on ESXI 5 so its not a big deal i just would like to try and figure out what i did wrong.

Re: Modified Scripts Andrew Kallmeyer 9/23/12 9:14 PM
That was my fault, I broke something. However, I have now installed a virtual machine and done some proper testing and I think everything now works as expected. Just re-install my scripts it should work this time.

Note that the first time you run a tekkit server it might say unclean for a bit but it's still running it just hasn't finished generating the level and the status window is complaining about the world files not being there yet.

On Sunday, September 23, 2012 5:40:08 AM UTC-4, chessehead17 wrote:
OK i figured i would give this a shot but as right after i did the final step in the read-me ( change the config files) i did a system reboot just because and now the web GUI has nothing. as in no words, no hyperlinks, and when you click the button you get nothing. i did this on a VM on ESXI 5 so its not a big deal i just would like to try and figure out what i did wrong.

More topics »