Weird mumble Issue

Showing 21-45 of 45 messages
Weird mumble Issue bill3281 10/21/12 7:57 AM
I have been using mumble on mineos for about 6 months now, and it hasn't given me any trouble. Recently I have figured out that when I'm not talking, I can't hear others speak. But when I talk, or my mic gets activated I can hear others for a small amount of time then it cuts me off. I have tested this my asking a friend to count to 10 and I would only hear 1-3 . I have already reinstalled mumble and it didn't work. I'm hosting the server on a separate dedicated machine. I have also tested the bug on my network with my Ipod and it has it also. The only fix I have found so far is that if I keep my mic on the continuous setting, only then I can hear others. This is annoying, because then my friends can hear everything happening near me. Everyone but me has this issue. If anyone knows something about it would be very helpful.  
Re: Weird mumble Issue bill3281 10/26/12 5:28 PM

I've reinstalled mineos, mumble client on my pc, and my routers firmware which is ddwrt.
I am running the 0.5.0 scripts
I have correctly opened the port on my server and my router.
When I login it says: UDP packets cannot be received from the server. Switching to TCP mode.

Does anyone have any ideas?


Re: Weird mumble Issue bill3281 10/27/12 7:38 AM
Is it possible to update umurmur, because I don't know how.
I have found that the server is running 0.2.7 be default.
Can anyone explain to me how I can update to the most recent version 0.2.10
I see it has more features, and could possibly fix my issue.
Thanks for reading.
Re: Weird mumble Issue bill3281 10/27/12 7:40 AM
Here is the link to the downloads for umurmur: http://code.google.com/p/umurmur/downloads/list

Here is the steps I followed in the wiki: http://minecraft.codeemo.com/mineoswiki/index.php/Umurmur
Re: Weird mumble Issue Will 10/27/12 8:02 AM
You'll notice in the package files "Pkgfile" from /usr/ports/mineos/umurmur, there is the following header:

# Depends on: protobuf protobuf-c

name=umurmur
version=0.2.7
release=1

build(){
            cd $name-$version
            ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-ssl=openssl
            make
            make DESTDIR=$PKG install

Changing 0.2.7 to 0.2.10 and reinstalling the port is how you'd get it to install the newer version.  


For the most part, though, youre gonna do something like (as root:

cd /usr/ports/mineos/umurmur
pkgrm umurmur
pkgmk -c
(make the update to the version)
pkgmk -d -i

Something to that effect. Let me know how it goes

 
Re: Weird mumble Issue bill3281 10/27/12 10:06 AM
It appears that I have the newer version now, but I can't seem to find the configuration file.
I used to see a config file in /usr/ports/mineos/umurmur, now I can't find one anymore
Re: Weird mumble Issue bill3281 10/27/12 7:08 PM
I have found the config file, and it appears that I don't have the newer version.
I found it in the /etc/umurmur file called umurmur.conf
Re: Weird mumble Issue Will 10/27/12 7:22 PM
is it working?
Re: Weird mumble Issue bill3281 10/28/12 2:06 PM
Yes the server is working, but i can't seem to find the new options from updating in the configuration file, it appears that the server hasn't updated.

Also, I am still having the same issue as mentioned above.
I would like to also know why any computer in my network isn't allowed to receive UDP packets from my server.

Re: Weird mumble Issue Will 10/28/12 2:23 PM
Have you looked into the iptables firewall? 
Re: Weird mumble Issue bill3281 10/28/12 3:15 PM
Yes, I have permitted all traffic to test if it would solve the issue, no it hasn't
Also when I look at the information about packets, other people have UDP packets, and I have 0 received or sent
Another weird thing is, when i"m at the login screen it doesn't show me a ping for mumble, and it used to before I had the problem

I'm thinking that it's probably my router now.
Re: Weird mumble Issue Will 10/28/12 9:02 PM
If you think its your router, 'permit all traffic' in iptables and then also make your server the DMZ for your router; this should authoritatively tell you whether or not its your router in conflict.

That said, I don't recommend that you keep your server as DMZ full time (but it is a possible solution), -- if you can use UDP after you turn on DMZ, you know that the problem was a particular ports' forwarding rules anyway.

Re: the ping.  I dont know much about the mumble client--but if its actually doing 'ping'--like the standard internet ping, those are filtered.  If its a umurmur/mumble special ping it should be solved with the DMZ. 

I have this feeling that pings and 'permit all traffic' still operate on different rules (as in, youd have to change something IN ADDITION to permitting all traffic), but I could be wrong.  At any rate, if it worked before......thats confusing.  Is it a change to their protocol which is why it requires different ports/protocols to work?
Re: Weird mumble Issue bill3281 10/29/12 11:12 AM
Okay, I'm out of ideas, permitting all traffic on my server, and enabling DMZ on my router to my server didn't work.

One more weird thing,
is when I look at server listings in minecraft including mine,
I get a ping over 1 second, but when I'm in the server it doesn't lag
When I ping google.com in cmd i get a ping of around 27 consistently.

Like I said before, I'm running the server, I'm on the same network as the server, and others who connect to my mumble server have no issue.
When I get on, it tells me "UDP packets cannot be received from the server. Switching to TCP mode" After a few seconds being on.

Lastly, one more weird thing, If I restart the server and open mumble, I see a ping for a short period of time, then if I restart mumble it wont show me a ping anymore.
Re: Weird mumble Issue Will 10/29/12 11:58 AM
Strangely, it didn't really occur to me you said that nobody else was having that issue...if thats the case, then I guess it makes sense that both disabling the firewall and enabling DMZ wouldn't do the trick.

So that leaves just your actual desktop then---is there a firewall in place there?

Since operation is perfect for your external-to-the-network users, it shouldve been more evident that it wasn't dropping UDP packets...have you ever tried it from external to your network on your current computer (or, just to short circuit that testing)--can we deduce its specific to your client rather than your server from those symptoms?
Re: Weird mumble Issue bill3281 10/29/12 7:57 PM
Are you saying I should use a proxy?
Well I have been on another server without the issue.

Also, maybe installing the real murmur server would be better.

I'm not so good with linux, as this is my first os, could you help me with installing it?

http://mumble.sourceforge.net/Running_Murmur
Re: Weird mumble Issue Zone 10/29/12 8:23 PM
There's a lot of different factors going on here. Let's try reducing some of those testing your router and the rest of your network outside of mineos. I would recommend installing on one of your desktops. The Windows version of murmur. Once you have that installed try accessing it from lan and test it. Then try opening it up to the public with port forwarding and have a friend tried out.If you're able to perform these tests without incident, then something misconfigured murmur or mineos IP tables,

unk...@googlegroups.com 10/30/12 7:45 AM <This message has been deleted.>
Re: Weird mumble Issue bill3281 10/30/12 8:00 AM
It worked, I installed murmur on my windows 7 pc and connected to it with another pc on my lan with no issues.
I then had a friend connect outside my lan after I port-forwarded, he didn't have any issues.

I see Will has already acomplished installing murmur here.
could someone give a little more detail on how that was done?

https://groups.google.com/forum/?hl=en#!searchin/mineos/ventrillo/mineos/trqLvUTOLP4/hW1DtIPYPtgJ
Re: Weird mumble Issue bill3281 10/30/12 8:16 AM
Well I used Ftp and did like will said, I unziped it then uploaded it to /etc/murmur/ then I did chmod +x murmur.x86
then I changed the port to 64739 in the murmur.ini file, and did ./murmur.x86 to start it. once it was up I connected to it.

bam, same problem it tells me "UDP packets cannot be received from the server. Switching to TCP mode"
unk...@googlegroups.com 10/30/12 8:18 AM <This message has been deleted.>
Re: Weird mumble Issue Zone 10/30/12 10:24 AM

When testing are you using the same same pc for the mumble client?
Try installing the mumble client on another pc and see if you get "UDP packets cannot be received from the server. Switching to TCP mode"
That will us see what step to take next.

Re: Weird mumble Issue bill3281 10/30/12 10:41 AM
After installing the regular murmur server on my mineos server and running it on a separate port.
I then went to another pc on my lan, installed mumble and got the same issue.

by the way, murmur worked on my windows7 pc, but I had the UDP issue when I installed it on my mineos server
Re: Weird mumble Issue Zone 10/30/12 1:17 PM

All right, I was just being thorough. Now that we've tried those things. It mirrors it down to mineos and murmur.
How did you enable the firewall to allow all traffic? . Have you tried disabling the firewall?
Re: Weird mumble Issue bill3281 11/2/12 7:49 AM
I got it working, but in a weird way.
In the beginning, I used the information from the wiki as so:
  1. iptables -A INPUT -p udp -m udp --dport 64738 -j ACCEPT
  2. iptables -A INPUT -p tcp -m tcp --dport 64738 -j ACCEPT
  3. iptables-save > /etc/iptables-rules
  4. iptables-restore < /etc/iptables-rules
Then mumble would work, but I would still have my issue.
I then decided to block all UDP packets by using
iptables -D INPUT -p udp -m udp --dport 64738 -j ACCEPT
After taking the UDP rule off the iptables, It fixed my problem completely,
still can't see the ping or amount of users on, when looking at the server listing though.
Lastly, I have allowed all packets through before for testing, not sure if that's disabling the firewall.
iptables -P INPUT ACCEPT
iptables -F
Re: Weird mumble Issue Zone 11/2/12 7:59 AM

That's a weird solution, but hey it works!
What I did to disable the firewall is the comment about the entire file.
There is the possibility that the ping is being blocked by your router. . Someone more knowledgeable will have to speak on that in more detail.