problems building libarchive from git

Showing 1-3 of 3 messages
problems building libarchive from git john 8/5/12 2:25 AM
On Arch linux and Just pulled latest git build and attempted to compile but am running into errors:

  ./build/autogen.sh
  ./configure --prefix=/usr --without-xml2
  make

Errors are in this pastebin:  http://pastebin.com/aL0MiZPp

Thanks in advance for any suggestions.

I also tried adding --disable-acl to the configure step which does get further but still dies in errors:

./.libs/libarchive.a(archive_write_disk_posix.o): In function `_archive_write_disk_finish_entry':
archive_write_disk_posix.c:(.text+0xfec): undefined reference to `archive_write_disk_set_acls'
./.libs/libarchive.a(archive_write_disk_posix.o): In function `_archive_write_disk_close':
archive_write_disk_posix.c:(.text+0x273a): undefined reference to `archive_write_disk_set_acls'
collect2: error: ld returned 1 exit status
./.libs/libarchive.a(archive_write_disk_posix.o): In function `_archive_write_disk_finish_entry':
archive_write_disk_posix.c:(.text+0xfec): undefined reference to `archive_write_disk_set_acls'
./.libs/libarchive.a(archive_write_disk_posix.o): In function `_archive_write_disk_close':
archive_write_disk_posix.c:(.text+0x273a): undefined reference to `archive_write_disk_set_acls'
collect2: error: ld returned 1 exit status
Re: [libarchive-discuss] problems building libarchive from git Tim Kientzle 8/5/12 11:43 AM
On Aug 5, 2012, at 2:25 AM, da_aud...@yahoo.com wrote:

> On Arch linux and Just pulled latest git build and attempted to compile but am running into errors:
>
>   ./build/autogen.sh
>   ./configure --prefix=/usr --without-xml2
>   make
>
> Errors are in this pastebin:  http://pastebin.com/aL0MiZPp

The new ACL code needs some more work on Linux.
Any Volunteers?  (It shouldn't be hard; the hard parts of
the new ACL code are all platform-independent.)

> Thanks in advance for any suggestions.
>
> I also tried adding --disable-acl to the configure step which does get further but still dies in errors:
>
> ./.libs/libarchive.a(archive_write_disk_posix.o): In function `_archive_write_disk_finish_entry':
> archive_write_disk_posix.c:(.text+0xfec): undefined reference to `archive_write_disk_set_acls'

Ouch.  Looks like the new archive_write_disk_acl.c file
got left out of the autoconf build.

Please try this again and let me know.

Tim

Re: [libarchive-discuss] problems building libarchive from git john 8/5/12 12:45 PM
On Sunday, August 5, 2012 2:43:43 PM UTC-4, Tim Kientzle wrote:

Ouch.  Looks like the new archive_write_disk_acl.c file
got left out of the autoconf build.

Please try this again and let me know.

OK.  It builds now if I configure disabling acl.  Looking forward to the acl work you alluded to in your post.  I am NO programmer :)

$ ./configure --prefix=/usr --without-xml2 --disable-acl